Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Non Working esata port on dell XPS420


  • Please log in to reply
4 replies to this topic

#1 Sani-T-Capt1

Sani-T-Capt1

  • Members
  • 559 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Planet Earth
  • Local time:08:26 PM

Posted 01 February 2012 - 11:12 AM

I need about five post to apply to this wonderful forum's Malware Removal Training Program, so what better way than to get help with an issue that i had been searching for about a year now. My Dell XPS comes with an esata port and it doesn't recognize my Ext. LG super multi-burner. I understand that this is due to some config. situation that should have been enabled when Vista was first installed onto this machine (why i'll never know since it should be a part of the Plug N Play feature). currently i am using one of the USB ports which has significantly less power than the esata. if anyone can help me with this, it would be appreciated. I would also like to add that consumers should be very specific when ordering from these computer manufacturer (my next hobby is to build one from scratch), as when i ordered this one, i insisted that it come with a bl-ray burner and since i was new to computers i didn't know that this was a Blu-ray Rom reader(only) and DVD burner until a year later. :thumbdown:

Edited by Sani-T-Capt1, 01 February 2012 - 11:13 AM.

Either We Learn to Live Together as People, Or Die Apart as Fools !


Ignorance ISN'T Bliss, It's Just "IGNORANCE"!!

BC AdBot (Login to Remove)

 


#2 rotor123

rotor123

  • Moderator
  • 8,094 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:07:26 PM

Posted 01 February 2012 - 11:54 AM

My guess is that you need to have the drive plugged in and powered up.
Then turn on the computer
Go to the Bios setup, drives section, enable the eSATA port.
save and restart and test to see if the Bios is recognizing the drive.

Until the bios recognizes the drive on that port windows will never use it.

For reference the Dell manual for your computer.
http://support.dell.com/support/edocs/systems/xps420/en/OM/HTML/appendix.htm

The manual show 5 internal and one external sata ports and ports 2 to 4 set to on default. My guess the eSATA is off by default.

Good Luck
Roger

Edited by rotor123, 01 February 2012 - 11:59 AM.

Fortune Cookie says: Fortune not Found: Abort, Retry, Ignore?

Sent from my All-In-One Desktop. Perfect for Internet, Not for heavy usage or gaming however.

How Does a computer get Infected? http://www.bleepingcomputer.com/forums/t/2520/how-did-i-get-infected/
Forum Rules,    The BC Welcome Guide

167 @ June 2015


#3 Sani-T-Capt1

Sani-T-Capt1
  • Topic Starter

  • Members
  • 559 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Planet Earth
  • Local time:08:26 PM

Posted 01 February 2012 - 12:49 PM

thank you Rotor123 for your response. i actually worked with Dell support techs (approximately 5 different techs actually) because this issue is covered under my warranty. the last tech i worked with actually told me that this feature should have been enabled during the installation of the OS. we went through bios to do exactly what you describe above and the analysis was that there are two different ways that the drives work through Bios (don't ask me what they are, at the time i understood what he was saying) and since this loading feature wasn't enabled during the factory install, then the only way to do it would be to wipe my harddrive and do a clean install and enable that setting. i have read many forums on another way to enable the esata port which were thoroughly confusing involving HKLM(?) Machine/System so and so. to say the least, i was very angry on two levels. 1) they didn't give me what i asked for as for as ordering went (although i found out later that the blu-ray burner they would've installed were full of problems). 2)That Dell didn't have the foresite to enable this port so why put it on the tower in the first place?
Either We Learn to Live Together as People, Or Die Apart as Fools !


Ignorance ISN'T Bliss, It's Just "IGNORANCE"!!

#4 rotor123

rotor123

  • Moderator
  • 8,094 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:07:26 PM

Posted 01 February 2012 - 04:13 PM

What those other forums are suggesting does involve editing the registry and if you are uncomfortable with that since it can trash the entire windows. Then do not do it.

If you do decide to do that since it can trash the windows I would clone your existing windows first to a external drive so you can get back to where you currently are in case it does go bad.

If you decide to clone and need help with that post your windows version, how drive space is used etc.

Good Luck
Roger

Edited by rotor123, 01 February 2012 - 04:15 PM.

Fortune Cookie says: Fortune not Found: Abort, Retry, Ignore?

Sent from my All-In-One Desktop. Perfect for Internet, Not for heavy usage or gaming however.

How Does a computer get Infected? http://www.bleepingcomputer.com/forums/t/2520/how-did-i-get-infected/
Forum Rules,    The BC Welcome Guide

167 @ June 2015


#5 Sani-T-Capt1

Sani-T-Capt1
  • Topic Starter

  • Members
  • 559 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Planet Earth
  • Local time:08:26 PM

Posted 02 February 2012 - 11:00 AM

Good Morning rotor123, i found this on the dell support forum and it explains fully what the techs at dell told me when we were trying to enable the esata port:

its well documented in the forums and even with dell technical support that the earlier xps420's from early 08 that didnt have raid installed from the factory do not have esata capability. it was a flaw on dells part because they were supposed to install the vista image using raid (thus enabling ahci) and then not use raid once setting everything up. but when they installed the vista image with raid off, it didnt allow the esata port to work at all. the only way to get it to work is if i turn raid on, and then i can actually see the drive connected to my esata port in the bios, but you cannot then boot into windows as you get a bsod.

i now have decided to go with the following two options;

option 1: find the backplate that came with the LG and plug it into my motherboard (fat chance of that happening)
option 2: buying another backplate esata to sata to plug into my motherboard thus bypassing all of the tomfoolery associated with editing registry

i'll give you three guesses which option i'm taking but you'll only need one LOL



Addendum: what do you think of this?

*NOTE* :Please verify, but the following should work, always back up your registry before editing.



After making this change, restart and all your drives will be redetected by Windows. Once redetected restart again and plug in the eSATA drive.



1. navigate to: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Iastor
2. Click in the right pane with the right mouse on Start

3. Change Value from 4 (?) to 0 and click OK
4. Close register editor



5. Restart the computer

6. Press F2 to get into System Setup

7. Set the Harddrive configuration to RAID ON

8. Save and Exit

Message Edited by Astrophel on 09-17-2008 11:35 AM

Edited by Sani-T-Capt1, 02 February 2012 - 03:46 PM.

Either We Learn to Live Together as People, Or Die Apart as Fools !


Ignorance ISN'T Bliss, It's Just "IGNORANCE"!!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users