Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

hanging on shutdown


  • Please log in to reply
4 replies to this topic

#1 Stealth Assassin

Stealth Assassin

  • Members
  • 106 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:47 AM

Posted 31 January 2012 - 06:41 AM

hi there;

i had constant problems with win7 hanging of the shutting down screen or just after.

my system is clean of malware and i have modified some registry keys but some are not there (havent been created).

how do i enter new keys without screwing up the registry or is there another method of doing this?

any help will be appreciated as i am not confident with altering the registry, thanks.

BC AdBot (Login to Remove)

 


#2 Allan

Allan

  • BC Advisor
  • 8,572 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:04:47 AM

Posted 31 January 2012 - 08:46 AM

Open msconfig and on the General tab choose "selective startup" (uncheck all three items) and reboot. Now shut down. Does the problem still occur? If not, start adding items back to msconfig one or two at a time, rebooting after each change, until the problem reappears and you'll have identified the offending process. This is clearly a time consuming procedure, but it is the best way to determine if some process loading with the system is the cause of your problem.
After you've isolated the cause, do not use msconfig to permanently disable the process. Instead, if it is a service go to START - RUN and type: services.msc (then press enter) and disable the service OR, if it a program, you can download & run a simple app such as Mike Lin's Startup Control Panel (http://www.mlin.net/StartupCPL.shtml) to enable, disable, or otherwise manage startup programs.

#3 Stealth Assassin

Stealth Assassin
  • Topic Starter

  • Members
  • 106 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:47 AM

Posted 31 January 2012 - 11:23 AM

i have ran msconfig and disabled start up drivers: i have win7 home premium ruuning on 1GB of RAM :).

i know some people have registry keys enabled but some of these dont exist on my pc. is there anyway to force shutdown by tweaking the registry without data loss or hardware failiure? when i restored to factory defaults i didnt have the problem yet after i shutdown while MBAM was running it came back. it even happens when i close all running applications.

#4 Allan

Allan

  • BC Advisor
  • 8,572 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:04:47 AM

Posted 31 January 2012 - 12:25 PM

I don't understand your post. Did you follow my instructions and do a clean boot? If so, what happened when you shut down the system with NOTHING loaded?


If you simply want a band-aid, you can try these:

Here are some steps you can take to try to speed up Windows Shutdown. Before editing the registry, be sure to either create an image of your system partition or backup the registry. If you don't know how, please ask.

1) Make sure "clear pagefile at shutdown" is not enabled:
start - run - regedit
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]

Set ClearPageFileAtShutdown value to 0


2) Start - Run - Regedit
Navigate to the following Registry key:
HKEY CURRENT USER\Control Panel\Desktop
Double click on the AutoEndTasks entry and replace the 0 with a 1 in the Value data text box

For the next two, if the dword value indicated does not exist, create it:

Double click on the WaitToKillAppTimeout entry in the right pane and change the Value data to 2000

Double click on the HungAppTimeout entry in the right pane and change the Value data to 1000

Reboot

3) HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
Right-click on WaitToKillServiceTimeout and change it to 2000

#5 Stealth Assassin

Stealth Assassin
  • Topic Starter

  • Members
  • 106 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:47 AM

Posted 31 January 2012 - 04:23 PM

i have disabled lots of services in msconfig and services.msc. as the problem is intermittant i dont know what is causing it especially as i close all running applications and it still happens. this is why i did not do a clean boot as i thought it would not be able to determine the cause. i have compared tasklists from successful and unsuccessful shutdowns from my own computer and someone elses: sadly they did not come to a conclusion either.

the other person who i compared my tasklist to has no problems shutting down the computer. i have had this problem since i ran MBAM and shut it down while it was running: this is what leads me to believe an error somewhere or an application not terminating correctly.

as far as the registry keys: thanks for the keys to modify. i have modified them and created the entries that are absent. the pc is running fine and there have been successful shutdowns (but when it hangs is completely random).

note: it has hanged again but seems to be random

Edited by Stealth Assassin, 01 February 2012 - 11:02 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users