Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Belkin router allows access to only a few computers


  • Please log in to reply
16 replies to this topic

#1 cmrisner

cmrisner

  • Members
  • 94 posts
  • OFFLINE
  •  
  • Local time:01:28 AM

Posted 30 January 2012 - 06:46 PM

Hello,

About two months ago I installed a new Belkin N750 DB router. It worked great initially, but recently it's been denying access to apple devices only. PCs running windows are granted access no problem, but try using an iPad, iPhone, or itouch and it says “unable to join network." What's even more odd is that the second band works fine; in other words the primary band with greatest range denies access, but the secondary band, with a much more limited range, grants access without any problem.

If I rest the password on the router, the apple devices will be granted access to the primary band for anywhere from a few hours to a few days before the router begins denying access again. I've tried rebooting the router but that doesn't seem to help. I also reset the ip leases but that didn't help either.

So I'm puzzled why the router will allow these devices access for only a short time after I reset the password. As I said, the windows based PCs don't have any problems with connecting. The apple devices however will only connect to the second band after the first band begins denying the connection.

Does anyone have any advice?

Thanks

BC AdBot (Login to Remove)

 


#2 the_patriot11

the_patriot11

    High Tech Redneck


  • BC Advisor
  • 6,755 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wyoming USA
  • Local time:02:28 AM

Posted 30 January 2012 - 11:15 PM

What security system are you using? its possible the security system your apple devices are using (WPA, WPA II, for instance) may not be compatible with the router.

picard5.jpg

 

Primary system: Motherboard: ASUS M4A89GTD PRO/USB3, Processor: AMD Phenom II x4 945, Memory: 16 gigs of Patriot G2 DDR3 1600, Video: AMD Sapphire Nitro R9 380, Storage: 1 WD 500 gig HD, 1 Hitachi 500 gig HD, and Power supply: Coolermaster 750 watt, OS: Windows 10 64 bit. 

Media Center: Motherboard: Gigabyte mp61p-S3, Processor: AMD Athlon 64 x2 6000+, Memory: 6 gigs Patriot DDR2 800, Video: Gigabyte GeForce GT730, Storage: 500 gig Hitachi, PSU: Seasonic M1211 620W full modular, OS: Windows 10.

If I don't reply within 24 hours of your reply, feel free to send me a pm.


#3 jhayz

jhayz

  • BC Advisor
  • 6,922 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:28 PM

Posted 31 January 2012 - 12:49 AM

Additional information on certain problem can be found also Here.

Tekken
 


#4 James Litten

James Litten

    ¿Ԁǝǝ˥q


  • BC Advisor
  • 1,945 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:04:28 AM

Posted 31 January 2012 - 01:34 PM

Hi

Jhayz's link is an excellent place to look.

On that router, they actually did a firmware update to address some problems with Apple devices. It didn't change how it works as much as it changed what you are allowed to set in the configuration so if you get it working, I wouldn't worry about updating it for now.

To check if you are affected by this, login to the web interface of your router (should be instructions for this in your manual).

You want to go to the Wireless > Channel & SSID section

Look at the entry

802.11e WMM(QOS)

and you'll see two ON/OFF settings. One for 2.4GHz and one for 5GHz

Make sure that both are set to ON

If they are both set to on and grayed out then that means you have the latest firmware which locks you out of turning them off by accident. Then your problem is something else and you should refer to Jhayz's link in the previous post.

Hope this helps.

James

#5 cmrisner

cmrisner
  • Topic Starter

  • Members
  • 94 posts
  • OFFLINE
  •  
  • Local time:01:28 AM

Posted 01 February 2012 - 06:29 PM

Thanks for the replies. I do have the latest firmware; I checked again today to make sure. My router is set to use both wpa and wpa2 security.

Unfortunately the suggestions given in the prior posts did not resolve my issue. As I said previously, the router will grant access to apple devices for a time if I reset the wi-fi password, but then later begin denying them access. So I dont think that the security between the router and apple devices are incompatible since they do wrk for a time and since it has been tried with over 10 different apple dvices. Both the 2.4 and 5 ghz bands are on, but only the 5ghz band will work with apple devices. That would be fine except the 5ghz band has very limited range compared with the 2.4 ghz band.

Any other suggestions on what I can do?

#6 James Litten

James Litten

    ¿Ԁǝǝ˥q


  • BC Advisor
  • 1,945 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:04:28 AM

Posted 01 February 2012 - 06:51 PM

Just want to verify.

You looked in the settings and

802.11e WMM(QOS)

Was set to 'ON' for both 2.4GHz and 5GHz

James

#7 cmrisner

cmrisner
  • Topic Starter

  • Members
  • 94 posts
  • OFFLINE
  •  
  • Local time:01:28 AM

Posted 02 February 2012 - 03:12 AM

Yes both we're set to on.

#8 James Litten

James Litten

    ¿Ԁǝǝ˥q


  • BC Advisor
  • 1,945 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:04:28 AM

Posted 02 February 2012 - 09:34 AM

It sounds like something is resetting the router.

Does it have a default password out of the box on a paper 'network card' that is either in the box or affixed to the underside of the router?
If so, the next time it happens, rather than reset the password on the router, try to manually connect the device to it, search for wireless networks and enter the default password.

If that works then the router is resetting itself for some reason.

James

Edited by NeverSayDie, 02 February 2012 - 09:34 AM.


#9 cmrisner

cmrisner
  • Topic Starter

  • Members
  • 94 posts
  • OFFLINE
  •  
  • Local time:01:28 AM

Posted 02 February 2012 - 08:22 PM

To clarify, other non-apple devices connect flawlessly while simultaneously the apple devices stop connecting after a day or two of resetting the password manually. The password is not being reset by the router, rather I am restating it in my efforts to troubleshoot the problem. So you see, the password is fine since windows based pcs will connect while apple devices will not using the very same password. Furthermore, the apple devices will connect to the second band (5ghz) which has the very same password.

Edited by cmrisner, 02 February 2012 - 08:22 PM.


#10 James Litten

James Litten

    ¿Ԁǝǝ˥q


  • BC Advisor
  • 1,945 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:04:28 AM

Posted 03 February 2012 - 03:43 PM

Hi

I'm sorry, I misunderstood.

So what happens is
You turned on set up your router.
You went to each of your wireless devices and had them detect available networks.
As each one saw the Belkin router's long range channel, you connected to it and after it asked you, you entered the password and they connected to the router.
You used your wireless devices without problems then after a few days...
The Apple devices stopped connecting to the network that they were connecting to (the long range channel of the Belkin) but the PC devices were still able to connect to it.
So then you went on the Apple devices and looked at the wireless connection and typed the same password in again and they worked.
A few days later they stop working again.
So then you went on the Apple devices and looked at the wireless connection and typed the same password in again and they worked.
A few days later they stop working again.
ad nauseum... :)

Is this correct?

James

#11 cmrisner

cmrisner
  • Topic Starter

  • Members
  • 94 posts
  • OFFLINE
  •  
  • Local time:01:28 AM

Posted 03 February 2012 - 06:53 PM

Yes that is correct except for one thing. I would re-enter the password on the Apple devices and they still would not connect to the long range channel. Only after I re-enter the same password on the router's firmware are the apple devices able to connect and then only for at most two days. I tried renewing the ip leases thinking that maybe somehow they were all being taken but that didn't help.

#12 James Litten

James Litten

    ¿Ԁǝǝ˥q


  • BC Advisor
  • 1,945 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:04:28 AM

Posted 03 February 2012 - 07:03 PM

I just talked to someone who says she knows about an issue like this with MacBook Airs running Lion. She's going to get back to me later. Is that what some of the devices are?

James

#13 jhayz

jhayz

  • BC Advisor
  • 6,922 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:28 PM

Posted 03 February 2012 - 10:45 PM

My router is set to use both wpa and wpa2 security.

I don't have a Belkin router, but do you mean configured to use both(mixed mode)? So that all devices/computer is supported or can access the security encryption setup from the router.

Tekken
 


#14 cmrisner

cmrisner
  • Topic Starter

  • Members
  • 94 posts
  • OFFLINE
  •  
  • Local time:01:28 AM

Posted 04 February 2012 - 02:37 AM

Yeah both modes are being supported and all types of apple devices have experienced this problem including iPads, iPhones, itouches and MacBooks.

#15 jhayz

jhayz

  • BC Advisor
  • 6,922 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:28 PM

Posted 04 February 2012 - 03:21 AM

Yes upon seeing this online PDF Manual and from the technical details, page 18 :

Integrated 802.11n Wireless Access Point
Utilizing Dual-Band Network technology, your Router
creates two separate networks (one at 2.4GHz band and
the other at 5GHz band), allowing increased bandwidth to
all your connected wireless devices and computers.

This support page for WAP on apple devices and wifi router will give additional information.

Tekken
 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users