Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Puzzling Power Supply


  • Please log in to reply
3 replies to this topic

#1 joshmurray

joshmurray

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:01 PM

Posted 30 January 2012 - 10:09 AM

I have a desktop computer and it would not turn on. The power light would just flicker non-stop. I immediately pulled the main motherboard connection the ATX rev 2 with 24 pins. I used a voltmenter and a jumper wire to check the voltages. all the way from 3.3, 5 to 12 each pin checked out perfectly. I then pulled the processor regulator connection the 4 pin connector and checked the (2) 12 volt pins. Both produced 12 volts. Therefore I assumed the issue was with the motherboard. I ordered a brand new one and replaced it, same problem. I then replaced the ps and wholla! fixed!

How can this be explained? Every time I check this power supply I get perfect voltages but yet it has to be bad because when replaced the problem goes away. I have never been so stumped.

BC AdBot (Login to Remove)

 


#2 rotor123

rotor123

  • Moderator
  • 8,093 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:12:01 PM

Posted 30 January 2012 - 11:07 AM

You are measuring with no load. Under load the power supply is failing, quite common. If it has failing capacitors there could also be too much ripple on the DC lines causing problems. If you were to open the P/S you would most likely find bad capacitors. Be careful if you do open it there could on occasion be a stored DC voltage that can give a nasty shock.

For bad capacitor examples, www.badcaps.net

Good Luck
Roger

Fortune Cookie says: Fortune not Found: Abort, Retry, Ignore?

Sent from my All-In-One Desktop. Perfect for Internet, Not for heavy usage or gaming however.

How Does a computer get Infected? http://www.bleepingcomputer.com/forums/t/2520/how-did-i-get-infected/
Forum Rules,    The BC Welcome Guide

167 @ June 2015


#3 dpunisher

dpunisher

  • BC Advisor
  • 2,234 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:South TX
  • Local time:11:01 AM

Posted 30 January 2012 - 02:58 PM

BTW, wholla != voilą

It's at the point now when I have a tower that comes in for a no start condition, I pull the side cover, ck mobo caps, if they look OK I throw another PSU at it. Ditto on the above post. It also doesn't hurt to set your DVM to "AC volts" and ck those voltages again. If you get any significant AC voltage on a DC line, it means you have a problem eventhough your DC voltage is in spec, at least according to your meter.

I am a retired Ford tech. Next to Fords, any computer is a piece of cake. (The cake, its not a lie)

3770K @4.5, Corsair H100, GTX780, 16gig Samsung, Obsidian 700 (yes there is a 700)


#4 joshmurray

joshmurray
  • Topic Starter

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:01 PM

Posted 16 February 2012 - 09:20 PM

Thanks.
Maybe I can try it while plugged into the motherboard and powered on. I can still slide the test points into the back of the plug I think.

Thanks for the good answers. I did not know that it could only fail w/ a load on.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users