Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Bogus NTLDR is Missing message when non bootable USB drive is attached.


  • Please log in to reply
7 replies to this topic

#1 Steevow

Steevow

  • Members
  • 113 posts
  • OFFLINE
  •  
  • Local time:07:54 AM

Posted 29 January 2012 - 06:08 PM

This is so goofy I can't see why this should be happening.

I put a drive in a USB/eSATA external case, and I have it plugged into an XP Professional system through it's USB.
This is an external drive only for storage, it has no OS on it.
I partitioned it and quickformatted it myself.

In bios the boot order is set to
1. IDE
2. CDROM
3. USB

The IDE is the boot drive, always has been and that works fine.

The problem is if I reboot while the external drive is plugged into USB I get an error
NTLDR is missing
Press Control Alt Delete to reboot.

Pressing Control Alt Delete gives the same error.
This does not occur if I unplug the USB drive. Then the system boots from it's boot drive normally.
I can then plug in the USB drive and access it's storage.
But I can't see why the system would even be looking at the external USB drive since the IDE is a valid boot device and priority is set to use that first.
This should never be a problem.
The system should just boot.

There are no boot files, no boot.ini, no OS on the external USB drive.
The boot.ini on the IDE boot drive does not mention the external drive at all, so it shouldn't be looking at it.

So that's the problem.
It's looking at a drive that is not bootable even though the system has been told not to and the drive that is causing the error is way down in boot order.

I searched for a solution and all the references to NTLDR is missing relate to an actual problem where the NTLDR is actually missing and the system fails boot and how to fix that, and I have probably replaced NTLDR in the past at least once to resolve that problem. But that's not at all what's happening here. This is a bogus error.

Can anyone suggest any steps to resolve this?

Edited by Steevow, 29 January 2012 - 09:59 PM.


BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 56,124 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:09:54 AM

Posted 29 January 2012 - 10:08 PM

External drives which are in an "ON" state...tend to someetimes cause problems with Windows booting, since Windows cannot seem to get past the USB device.

The error message that NTLDR is missing...I would interpret that as Windows trying to boot from the external drive...and, of course, it cannot.

Which would explain why you can properly boot, with said drive detached.

I would do two things:

a. Do not connect the drive until Windows has booted, if there is no OFF switch control.

b. Check your BIOS boot options and ensure that you don't have USB boot enabled.

Louis

#3 Steevow

Steevow
  • Topic Starter

  • Members
  • 113 posts
  • OFFLINE
  •  
  • Local time:07:54 AM

Posted 29 January 2012 - 10:13 PM

External drives which are in an "ON" state...tend to someetimes cause problems with Windows booting, since Windows cannot seem to get past the USB device.

The error message that NTLDR is missing...I would interpret that as Windows trying to boot from the external drive...and, of course, it cannot.

Which would explain why you can properly boot, with said drive detached.

I would do two things:

a. Do not connect the drive until Windows has booted, if there is no OFF switch control.

b. Check your BIOS boot options and ensure that you don't have USB boot enabled.

Louis

Not connecting the drive would be a workaround.
I am not trying to find a workaround, I can work around problems without issue.
I want to resolve problems.

I did check the BIOS options and USB Device is third in boot priority.
I posted that in the OP.
This is what is not working.

Come to think of it, there is a possibility that the external drive was a bootable drive in the past, so it might have a bootable MBR. I wonder if a never bootable drive would have a more simple, non bootable MBR.

That does not however explain why the system is stupidly trying to boot from the third boot device when the first one (the IDE) is bootable. It supposed to try the first boot device and if that fails only then try the second, and so on.

That's where the problem lies. Obviously.

Edited by Steevow, 30 January 2012 - 12:40 AM.


#4 rotor123

rotor123

  • Moderator
  • 8,093 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:10:54 AM

Posted 30 January 2012 - 04:37 PM

Posting the make or model would allow better targeted help.

I have seen this problem and it seemed to be tied to certain systems hardware.

In some brands you can remove the USB as a option so it doesn't show up as a bootable
option. Then it should not matter if the drive is attached or not.

Try going into the Bios setup, then the bios settings go to the boot section and disable the USB bootable option.

Good Luck
Roger

Edited by rotor123, 30 January 2012 - 04:38 PM.

Fortune Cookie says: Fortune not Found: Abort, Retry, Ignore?

Sent from my All-In-One Desktop. Perfect for Internet, Not for heavy usage or gaming however.

How Does a computer get Infected? http://www.bleepingcomputer.com/forums/t/2520/how-did-i-get-infected/
Forum Rules,    The BC Welcome Guide

167 @ June 2015


#5 Steevow

Steevow
  • Topic Starter

  • Members
  • 113 posts
  • OFFLINE
  •  
  • Local time:07:54 AM

Posted 30 January 2012 - 07:45 PM

Posting the make or model would allow better targeted help.

I have seen this problem and it seemed to be tied to certain systems hardware.

In some brands you can remove the USB as a option so it doesn't show up as a bootable
option. Then it should not matter if the drive is attached or not.

Try going into the Bios setup, then the bios settings go to the boot section and disable the USB bootable option.

Good Luck
Roger

It's an old HP DC5000.
I can't see why it's trying to boot from a drive that far down in boot priority.

Removing USB as an option would again be a workaround.

#6 James Litten

James Litten

    Ԁǝǝ˥q


  • BC Advisor
  • 1,946 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:09:54 AM

Posted 30 January 2012 - 11:34 PM

In bios the boot order is set to
1. IDE
2. CDROM
3. USB


Hi

Is this the exact wording of the options in the BIOS?
There is an issue with some BIOS considering the USB HDD as HDD because of the order of detection.
Those often say 'Hard Drive' or 'Hard Disk' or 'HDD' instead of "IDE - Hard Drive" in the boot order options.

James

#7 Steevow

Steevow
  • Topic Starter

  • Members
  • 113 posts
  • OFFLINE
  •  
  • Local time:07:54 AM

Posted 02 February 2012 - 12:02 PM

In bios the boot order is set to
1. IDE
2. CDROM
3. USB


Hi

Is this the exact wording of the options in the BIOS?
There is an issue with some BIOS considering the USB HDD as HDD because of the order of detection.
Those often say 'Hard Drive' or 'Hard Disk' or 'HDD' instead of "IDE - Hard Drive" in the boot order options.

James

The first boot device is called IDE in bios.

#8 James Litten

James Litten

    Ԁǝǝ˥q


  • BC Advisor
  • 1,946 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:09:54 AM

Posted 02 February 2012 - 03:28 PM

The first boot device is called IDE in bios.


Okay, then that's not the issue I have seen. What I saw did not happen if IDE was specifically checked. I think it was something with some BIOS checking for a USB keyboard before checking for harddrives and as a result detected some USB storage devices before checking the IDE.

Wish I had a better answer for you.
James




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users