Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows Installer issues?"


  • Please log in to reply
7 replies to this topic

#1 Dj Moltar

Dj Moltar

  • Members
  • 54 posts
  • OFFLINE
  •  
  • Local time:07:57 PM

Posted 27 January 2012 - 04:05 AM

with several programs, I am having a problem installing. I repeatedly have errors with "another installation already in progress". I know the fix for that by changing it to disabled, restarting, and changing it to manual. But it keeps happening. On the various stuff I try to install, I get errors even AFTER doing that fix. Like ""there was an error creating a temporary file that is needed to complete this installation." That's the one I'm getting now. I can't find anything on google that could help me out.
Any ideas?

BC AdBot (Login to Remove)

 


#2 Dj Moltar

Dj Moltar
  • Topic Starter

  • Members
  • 54 posts
  • OFFLINE
  •  
  • Local time:07:57 PM

Posted 27 January 2012 - 02:58 PM

Okay. It's definitely "There was an error creating a temporary file that is needed to complete this installation." And I keep getting it while windows installer is doing the "updating component registration" part of installation.

#3 James Litten

James Litten

    Ԁǝǝ˥q


  • BC Advisor
  • 1,946 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:08:57 PM

Posted 27 January 2012 - 05:54 PM

Okay. It's definitely "There was an error creating a temporary file that is needed to complete this installation." And I keep getting it while windows installer is doing the "updating component registration" part of installation.


Hi

Did you find that by turning on Windows Installer logging?
If not you may want to turn that on and see what you get...
http://support.microsoft.com/kb/2545723

Another thing you can check is what the GetTempPath function is returning.
The Windows Installer uses the GetTempPath function to determine where to put temporary files.

The GetTempPath function checks for the existence of environment variables in the following order and uses the first path found:

The path specified by the TMP environment variable.
The path specified by the TEMP environment variable.
The path specified by the USERPROFILE environment variable.
The Windows directory.


Open a command prompt and try these in order. The first one that has a value should be where it's trying to write temp files. That might help you pinpoint the problem.

echo %TMP%

echo %TEMP%

echo %USERPROFILE%

If none of those are valid then it's the Windows directory

James

#4 Dj Moltar

Dj Moltar
  • Topic Starter

  • Members
  • 54 posts
  • OFFLINE
  •  
  • Local time:07:57 PM

Posted 28 January 2012 - 05:20 AM

Also I keep getting "Another Installation is in progress". So to even log the "error with temp file" error, I have to friggin' disable and reenable windows installer and then restart. Ugh.
But yeah, I didn't use logging. It's just the error that pops up when I do it after getting around the "Another installation is in progress" message. I do that by going into computer>manage>services and the setting it to disable, and then restarting and setting it to manual. Then it goes from the "another installation in progress" to the "error creating temp file" thing.
I'm about to try the gettemppath thing.

#5 Dj Moltar

Dj Moltar
  • Topic Starter

  • Members
  • 54 posts
  • OFFLINE
  •  
  • Local time:07:57 PM

Posted 28 January 2012 - 05:23 AM

Okay so I put all those in command prompt and in order I got
C:\users\Matt\appdata\local\temp
C:\users\Matt\appdata\local\temp
C:\users\Matt

What should I try from here? Sorry for the late reply by the way. B]

#6 James Litten

James Litten

    Ԁǝǝ˥q


  • BC Advisor
  • 1,946 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:08:57 PM

Posted 29 January 2012 - 03:16 PM

Okay. It's definitely "There was an error creating a temporary file that is needed to complete this installation." And I keep getting it while windows installer is doing the "updating component registration" part of installation.


Hi

Now that you know the installer is creating temporary files in...

C:\users\Matt\appdata\local\temp

First answer these...
Does that folder exist?
Is there enough space on the C: drive to create the temporary files needed?

If the answer is yes to those, then...
Delete what is in that C:\users\Matt\appdata\local\temp folder (Make sure you save any files you are working on and close all programs before deleting these).

It probably won't let you delete all of the files because some may be in use by the system. The problem may be with one of the files that it does not let you delete as the components that you are registering may have temp data in there.

At this point, try the installer again and see if it works.
If not then reboot, close all programs, try deleting files in C:\users\Matt\appdata\local\temp again.
Try the installer again and see if it works.
If not then we need to look at the files that it would not let you delete.
If it isn't too many, list them in a post. If it is a lot, I'll tell you how to output the list to a text file that you can copy and paste to a post here.

James

#7 Dj Moltar

Dj Moltar
  • Topic Starter

  • Members
  • 54 posts
  • OFFLINE
  •  
  • Local time:07:57 PM

Posted 30 January 2012 - 03:23 PM

I was able to delete everything from the folder and it did exist. I've got like 80 GB free on C:, but I'm still getting the same errors. B[

#8 James Litten

James Litten

    Ԁǝǝ˥q


  • BC Advisor
  • 1,946 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:08:57 PM

Posted 30 January 2012 - 04:00 PM


Okay. It's definitely "There was an error creating a temporary file that is needed to complete this installation." And I keep getting it while windows installer is doing the "updating component registration" part of installation.


Hi

Did you find that by turning on Windows Installer logging?
If not you may want to turn that on and see what you get...
http://support.microsoft.com/kb/2545723


Hi

Still wondering if you got this information from turning on Windows Installer logging?

If so, there should be some more information after...
"There was an error creating a temporary file that is needed to complete this installation."
If you have that, let me know. It should be a folder name and a Win32 system error code (usually a number)

Another question, what software are you installing that is having this problem? Some software will ask you to disable virus software before running to avoid this error but I would not do that unless I REALLY trusted the company.

James




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users