Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't reinstall net framework


  • Please log in to reply
3 replies to this topic

#1 impedious

impedious

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:12:45 PM

Posted 26 January 2012 - 04:24 PM

Hi
I was having problems loading Simply Accounting and I was told by their tech dept to repair or uninstall/reinstall Net 3.5(SP1). Repairing wasnít an option so I uninstalled but could not reinstall. I had net 4.0 on the computer so I uninstalled that. Didnít load tried talking to Microsoft but all they wanted to do was sell me an expensive service plan, and said I had a virus. I talked to my anti-virus provider. They told me what to do to see if virus. Ran that and nothing was found, still wouldnít load. Read more on Microsoft website, recommended removing net framework so I did and tried reloading net 3.5(SP1). Still get error, tried both by Microsoft updates and downloading and running neither worked. Keep get this error:

Framework 3.5 (x64) 'package'. MSI returned error code 1603
[01/26/12,12:55:42] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 (x64) 'package' is not installed.

Found someone on Microsoft forum recommend this forum, said solved right away. Couldnít find his post so put this hoping I can get this fixed
Tim

BC AdBot (Login to Remove)

 


#2 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,663 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:01:45 PM

Posted 26 January 2012 - 05:23 PM

Welcome aboard Posted Image

Let's try cleaning up your .NET framework...

Download, unzip, and run the dotnetfx_cleanup_tool. It will remove the .NET framework from your computer so that we can reinstall it later.

After running this cleanup tool, it should ask you to reboot. Please do so.

Next, download and install dotnetfx35.exe. This will reinstall the .NET framework onto your computer. Note: this is a large file, and could take some time to download depending on the speed of your internet connection.

After another reboot, download and install dotnetfx35setup.exe. This will update the .NET framework to version 3 SP1.

If you need any more updates for the .NET framework, Windows Update should find it for you (assuming updates are set to automatically download and install).

My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 


#3 impedious

impedious
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:12:45 PM

Posted 27 January 2012 - 04:53 PM

Hi did all that still stops at same place on both versions of dotnetfx3.5. I have run chkdsk, a registry cleaner, defragged the drive and still no luck. Two different programs say I have no malware. I am trying to load net 2.0 sp2 now to see if I can build up. can't load 2.0 trying 3.0. That didn't work need to turn off program but because program isn't there it hangs ups. Since I can't load 3.5, would reloading 4.0 work? I don't know how much legacy support it has. I tried Microsoft forums again but couldn't find an answer. What can I try next?
Tim

Edited by impedious, 27 January 2012 - 05:13 PM.


#4 hamluis

hamluis

    Moderator


  • Moderator
  • 55,411 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:03:45 PM

Posted 28 January 2012 - 08:50 AM

FWIW: NET Framework 2.0 is probably the most basic version which a user needs to install, I've seen various applications require it.

My experience is that the various versions must be installed in sequence...the earliest version must be installed first or the installer will detect a later version and the attempted install of the earlier version after the later version...will not complete.

The MS.NET versions are not cumulative...later versions do not necessarily incorporate all elements of earlier versions...but later versions may incorporate some elements of earlier versions. I find this particularly true with 3.5, SP1.

Louis




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users