Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Dell Vostro 1520 Battery/Charging Issue


  • Please log in to reply
2 replies to this topic

#1 Lydia Widbin

Lydia Widbin

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:06:55 PM

Posted 23 January 2012 - 02:09 PM

I have had a Vostro 1520 for 2 years. Recently, I received a message telling me to consider replacing my battery. Since the computer would not work for more than a few minutes without being hooked up to the ac adapter, I used it this way for several months with no issues. Then, last week, the computer shut off randomly while I was using it and would not turn back on. The charging light at the front of the computer was off, but when I took out the battery and put it back in, the light turned on and when plugged in, the computer would turn on for a second and then shut down again.

Thinking that all I needed to do was replace the battery, I ordered a replacement battery that said it was compatible with the Dell Vostro 1520. The battery worked fine, but when i plugged in my adapter to charge it, the computer said that it was plugged in but unable to charge. I figured it was an issue with the battery because I had not ordered the battery from Dell, so I purchased the 9 cell battery from Dell said to be compatible with my computer.

Today I received the battery and was once again able to turn on my computer. The battery had a 32% charge on it. I plugged in my ac adapter, and for a few seconds, the computer told me that it was charging the battery. Then, the computer shut off. I tried leaving the computer off with the ac adapter plugged in, but even though the charge light at the front of the computer is on, the battery did not appear to have charged at all when, a few hours later, I unplugged the computer and turned it on.

I have tried to plug in the adapter while the computer is on and turn on the computer with the adapter plugged in. No matter when I plug in the adapter, the computer will shut off after a second or two of the adapter being plugged in. I even tried a different adapter and the same thing happened, so I am certain that it isn't the adapter.

Please help! I spent over $150 on the battery and would like to be able to return it in time to get a refund if it is an issue with the battery or if the computer is just too expensive to repair and I need to just get a new computer.

Thanks!

BC AdBot (Login to Remove)

 


#2 rotor123

rotor123

  • Moderator
  • 8,094 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:06:55 PM

Posted 24 January 2012 - 05:18 PM

Several thoughts come to mind.

What happens when you try and run it without the battery installed?

If it runs with no battery and fails with any of the three batteries installed, And you are using a Dell AC Adapter?
In that case it may be an internal problem.

I Believe that 1525 for example is marked on the bottom for a PA-12 Family AC adapter.

Dell laptops on the bottom it will say for example PA-10 or PA-12 Adapter which means either will work.
Then in the bios if it is a genuine working Dell AC Adapter it will show a 65 Watt or 90 Watt or Unknown. If it shows unknown it won't try and charge and may slow down the laptop too.

Edited by rotor123, 24 January 2012 - 05:18 PM.

Fortune Cookie says: Fortune not Found: Abort, Retry, Ignore?

Sent from my All-In-One Desktop. Perfect for Internet, Not for heavy usage or gaming however.

How Does a computer get Infected? http://www.bleepingcomputer.com/forums/t/2520/how-did-i-get-infected/
Forum Rules,    The BC Welcome Guide

167 @ June 2015


#3 dif

dif

  • Members
  • 56 posts
  • OFFLINE
  •  
  • Local time:11:55 PM

Posted 25 January 2012 - 10:58 AM

It's either a faulty charger, i've seen them with the green light, but not enough power to power the laptop. Or a burnt out mosfet on the motherboard that Dell use for charging. I've seen and fixed a few of these. As you've tried another charger that tends to suggest to a motherboard fault.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users