Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

New Laptop. GT540M Problem


  • Please log in to reply
1 reply to this topic

#1 SimbaWalker

SimbaWalker

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:05:39 AM

Posted 19 January 2012 - 08:05 PM

Hey all, I recently ordered a laptop off Amazon, with the specs:

ASUS A53SV-EH71

CPU: Intel Core i7-2670QM 2.2GHz (Turbo to 3.1GHz)
GPU: Nvidia GeForce GT540M 1GB and an integrated Intel HD card through Optimus technology.
OS: Win 7 Premium
HDD: 640GB 5400 rpm
RAM: 6 GB DDR3

I just got this laptop yesterday, and the first thing I did was set it up and use Rainmeter to get it customized to my liking. Today, I updated drivers for the Intel Graphics Card along with the new Verde 285.62 WHQL driver.

I proceeded to boot up Starcraft 2 for the first time since installing, and I was stunned to see that my laptop was running it on a suggested medium-low graphical settings at 20-30 fps.

I thought that I must have been running it under the Integrated GPU, so I go back and make sure that it's running under the GT540M. Still, no dice, same graphical settings as before. Confused, I tried to run it under the integrated GPU just to check the graphical settings, and they were same as when I ran it with the GT540M.

I proceeded to look through forums and tried multiple different things. I opened the Nvidia Control Panel and went to Manage 3D Settings, and selected the program starcraftii.exe, and selected the preferred processor as the GT540M. Then, I went to Set PhysX configuration to make sure that GeForce GT 540M was selected. I even checked the setting that allows me to see the GPU Activity down in my Notifications bar.

I ran Starcraft 2 again, under the 540M. Graphical settings still have not changed, and fps was still around 20-30. I even alt-tabbed to check if it was actually running under the 540M, and the GPU Activity Notification confirmed that I indeed was.

I even downloaded the newer beta driver, the Verde 290.53, in hopes that it would give my GPU better performance. No difference at all.

This doesn't seem right to me, because when I go on System Requirements Lab, my benchmarks for Starcraft 2 exceed it's requirements, getting checks in every single category, and my specs are beyond what is recommended for that game. My DirectX is fully updated, and my resolution for the game is at 1366x780, if that helps.

Please, if anyone has encountered this problem and has found a fix, or if anyone even has an idea of what to do, let me know. It is greatly appreciated.

BC AdBot (Login to Remove)

 


#2 Phylar

Phylar

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wisconsin
  • Local time:05:39 AM

Posted 14 February 2012 - 09:32 AM

If I am correct (and since I have a GT555m I better be) GT540m runs NVIDIA's Optimize technology. Go into NVIDIA's control panel and in the upper right (right next to profile I believe) click on the tab and look for an option that shows information on your graphics processor while in-game (would have to tab out and check system tray for this). I would be more specific but am at work right now and thus do not have the panel opened in front of me. Anyhow Optimize allows the/a program to switch back and forth between graphics cards as needed so chances are you were recommended for Medium settings due simply because the computer was running your Integrated rather then your rig (persay).

To put it simply, try to set the game on higher graphics and play with the NVIDIA control panel (in global 3D settings (advanced tab) you should be able to set individual games to specifically run the NVIDIA High-End Graphics blah blah). From there tab-out on occasion and check to see if Optimizer is indeed working properly. Get back to us here on the forums if you are indeed still having this problem.

As for you forum mods, yes I know this is an old post, don't bite the head of the helper! =D




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users