Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't block Netbios ports 137,138,139


  • Please log in to reply
4 replies to this topic

#1 ghead

ghead

  • Members
  • 109 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:02:32 PM

Posted 17 January 2012 - 01:40 AM

Why is my firewall sending out UPD to ports 137 and 139? When I add a block to the rules it doesn't block them it keeps allowing it to pass.

BC AdBot (Login to Remove)

 


#2 ranget

ranget

  • Members
  • 250 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:32 PM

Posted 17 January 2012 - 07:12 AM

Maybe because your File and Printer sharing is enabled try disabling those
what version of windows you are using ?
if xp i think there was a free Tool Called Windows wormhole Cleaner that will close those for you try Locating it in Cnet Download.com beware of Bloatware and cnet adaware

A big thanks to Dider Stevens

sorry for not being around

 


#3 4dude

4dude

  • Members
  • 578 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:32 PM

Posted 17 January 2012 - 12:54 PM

Why is my firewall sending out UPD to ports 137 and 139? When I add a block to the rules it doesn't block them it keeps allowing it to pass.

Your firewall must have SMART FILTERING like mine does which means SOMETHING ON YOUR END IS ASKING FOR THIS CONNECTION.. (Otherwise it should be blocked)

Edited by 4dude, 17 January 2012 - 12:55 PM.


#4 Animal

Animal

    Bleepin' Animinion


  • Site Admin
  • 34,746 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Where You Least Expect Me To Be
  • Local time:12:32 PM

Posted 17 January 2012 - 07:11 PM

http://www.techexams.net/forums/off-topic/43459-traffic-port-137-138-139-question.html#post317088

If the client has NetBT enabled, it will always try to connect to the server at both port 139 and 445 simultaneously. If there is a response from port 445, it sends a RST to port 139, and continues it's SMB session to port 445 only. If there is no response from port 445, it will continue it's SMB session to port 139 only, if it gets a response from there. If there is no response from either of the ports, the session will fail completely.

If the client has NetBT disabled, it will always try to connect to the server at port 445 only. If the server answers on port 445, the session will be established and continue on that port. If it doesn't answer, the session will fail completely. This is the case if the server for example runs Windows NT 4.0.

If the server has NetBT enabled, it listens on UDP ports 137, 138, and on TCP ports 139, 445. If it has NetBT disabled, it listens on TCP port 445 only.


The Internet is so big, so powerful and pointless that for some people it is a complete substitute for life.
Andrew Brown (1938-1994)


A learning experience is one of those things that say, "You know that thing you just did? Don't do that." Douglas Adams (1952-2001)


"Imagination is more important than knowledge. Knowledge is limited. Imagination circles the world." Albert Einstein (1879-1955)


Follow BleepingComputer on: Facebook | Twitter | Google+

#5 ghead

ghead
  • Topic Starter

  • Members
  • 109 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:02:32 PM

Posted 17 January 2012 - 10:26 PM

I never had this problem until I switched back to netzero now my firewall and "System" is constantly trying to report out to 137 and 138 UPD only. If I block "grants access to get remote hosts name (137) then it blocks this stuff but I can't initally connect to the internet unless I enable it.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users