Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

rundll.exe not found after MalwareBytes removal


  • Please log in to reply
4 replies to this topic

#1 Domo!

Domo!

  • Members
  • 174 posts
  • OFFLINE
  •  
  • Local time:06:44 AM

Posted 14 January 2012 - 09:34 AM

Hello, I've had a strange run in whith what may be a virus and I came looking for some help. About a day ago Avast had been detecing a program that prevented programs from opening. For example if I tried to open Internet Explorer from the Start menu a Window would pop up asking if it would be safe to open, saying that it was associated with another file from a website and where it was coming from. I closed the windows when they appeared, and began going from the Internet Explorer Icon on the Desktop. After some browsing the a fake ad called Windows XP Security 2012 began scanning my computer and I immediatly closed it and scanned with Avast.

It found nothing at first and then asked Avast to do it boot time scan. (I have a log but I won't post it unless asked to.) It found some Java related infections and deleted them, and upon opening restarting the computer I chose to make sure I was clean. I went to scan with Malwarebytes and some more infection were found. I chose to delete those as well and when Windows started normally that is when rundll.exe was not found.

When any program tries to open it asks to find the program that opens said file. For example, I tried clicking the Avast Icon and then was asked to find the program associated with that file in order to open it. I then restarted in safe mode and decided to run an ESET scan, and some more infections were found. After the Eset quarentine the problem still persists. I have logs from the scans here but I won't posts them unless asked to.

Thanks again for any help in advance.

BC AdBot (Login to Remove)

 


#2 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:09:44 AM

Posted 14 January 2012 - 12:03 PM

Download

http://www.dougknox.com/xp/fileassoc/xp_exe_fix.zip

Extract and launch the registry file in normal mode

Click YES when you get a prompt

That should solve the OPEN WITH and run dll issue

Run a scan with malwarebytes in normal mode

Good luck

Edited by narenxp, 14 January 2012 - 12:05 PM.


#3 Domo!

Domo!
  • Topic Starter

  • Members
  • 174 posts
  • OFFLINE
  •  
  • Local time:06:44 AM

Posted 14 January 2012 - 02:36 PM

Thank you NarenXP, I've downloaded and run the suggested file and Malwarebytes was able to run again. The program ran and has come up clean. Nothing was detected and my programs are working again.

#4 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:09:44 AM

Posted 14 January 2012 - 07:53 PM

You're welcome :)

#5 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:09:44 AM

Posted 14 January 2012 - 07:54 PM

You're welcome :)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users