Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

How to disable Autorun


  • Please log in to reply
9 replies to this topic

#1 krMitchell

krMitchell

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Local time:09:23 AM

Posted 13 January 2012 - 04:19 PM

I have just had to re-install Windows XP and all my applications due to a virus. I have an external drive connected via a USB port. I have been unable to disable the autorun for this drive. Here is what I have tried so far:

1. In the registry I have set HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer\NoDriveTypeAutorun to 95(hex).

2. Installed Microsoft Update 967715. Ensured that registry entry HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer\HonorAutorunSetting is set to 1(hex).

Is there anything else that I am missing?

BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 56,300 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:09:23 AM

Posted 13 January 2012 - 06:47 PM

Worth reading, http://www.techsupportforum.com/forums/f10/solved-usb-drives-do-not-run-autorun-anymore-614507.html .

Louis

#3 AustrAlien

AustrAlien

    Inquisitor


  • Members
  • 6,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cowra NSW Australia
  • Local time:12:23 AM

Posted 14 January 2012 - 04:53 AM

@ Louis: Nice link! :thumbup2:

What exactly are you trying to achieve?
  • Do you wish to disable Autorun
    or
  • Do you wish to disable Autoplay
and for what reason?
AustrAlien
Google is my friend. Make Google your friend too.

Posted Image

#4 krMitchell

krMitchell
  • Topic Starter

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Local time:09:23 AM

Posted 14 January 2012 - 09:27 AM

Hi AustrAlien, every time the machine come out of sleep mode or hibernation, the Autoplay window pops up an starts scanning the hard drive connected to a USB port. I want to stop this.

#5 AustrAlien

AustrAlien

    Inquisitor


  • Members
  • 6,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cowra NSW Australia
  • Local time:12:23 AM

Posted 15 January 2012 - 07:28 PM

Understanding and managing the autorun and autoplay features, settings and configuration in Windows can be quite a daunting challenge. Now that I have a better understanding of your issue it seems likely that there may be a very simple solution to what you want to achieve. You are in fact more concerned with the "autoplay" rather than "autorun" feature. You may or may not have tried the following:

This article outlines how to disable the AutoPlay feature upon initial connection of external hard drive in Windows XP.

Open My Computer:

  • Right-click on the drive letter of the external hard drive and select Properties.
  • Click on the AutoPlay tab and select Take No Action for every type of content (in the drop-down box it will list each type of content).
  • Click Apply and then OK.
AutoPlay will then be disabled and the user should be able to connect the external drive without the AutoPlay feature coming up.

Source: How to Disable the AutoPlay Feature for External Hard Drives in Windows XP

http://seagate.custkb.com/seagate/crm/selfservice/search.jsp?DocId=188975
Let me know if trying that configuration does not solve your problem.
AustrAlien
Google is my friend. Make Google your friend too.

Posted Image

#6 krMitchell

krMitchell
  • Topic Starter

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Local time:09:23 AM

Posted 21 January 2012 - 04:29 PM

I have tried that several times. But every time the machine comes out of hibernation, it starts autoplay for the USB drive.

#7 AustrAlien

AustrAlien

    Inquisitor


  • Members
  • 6,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cowra NSW Australia
  • Local time:12:23 AM

Posted 22 January 2012 - 06:53 PM

I have tried that several times.

I had considered you may have already tried that, but wanted confirmation.

Please let me know which version of XP we are dealing with here:
  • Home
    or
  • Professional

I would like to have a look at the relevant entries in the Windows registry.

:step1: Please export to text files, the contents of two registry keys:
  • Click Start > Run
  • Copy and paste the following line of code in the open Run box
regedit /e C:\reg1.txt "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer"
  • Now click OK
  • Click Start > Run
  • Copy and paste the following line of code in the open Run box
regedit /e C:\reg2.txt "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\policies\Explorer"
  • Now click OK

:step2: Please post the contents of the two exported registry keys for us to look at:
  • Double-click/Open My Computer and then navigate to C:\ drive
  • In there, you should see two files called reg1.txt and reg2.txt.
  • Double-click one of the files to open it with Notepad.
    • Copy and paste the whole contents of that file in your next reply.
  • Repeat with the second text file, to include the contents of that file also in the same reply.

AustrAlien
Google is my friend. Make Google your friend too.

Posted Image

#8 krMitchell

krMitchell
  • Topic Starter

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Local time:09:23 AM

Posted 22 January 2012 - 07:36 PM

I have Windows XP Home Edition.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer]
"HonorAutoRunSetting"=dword:00000001

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\policies\Explorer]
"NoDriveTypeAutoRun"=dword:00000095

#9 AustrAlien

AustrAlien

    Inquisitor


  • Members
  • 6,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cowra NSW Australia
  • Local time:12:23 AM

Posted 23 January 2012 - 06:04 PM

You may wish to completely disable autorun/autoplay for security reasons, as is widely recommended these days, but for now, I will address your immediate concern.

Given that you are using XP Home Edition, presuming that you have the latest Service Pack (SP3), and having viewed your registry settings, I am going to suggest the simplest means possible for that should provide what you need, namely the ability to easily control autoplay on USB-connected devices. Let's see if this does the trick for you.

Download and install TweakUI from Microsoft.
  • Go to Start > Programs > Powertoys for Windows XP > Tweak UI
  • Expand My Computer.
  • Expand AutoPlay and click on Types.
  • Remove the checkmark from the box beside "Enable Autoplay for removable drives".
  • Click OK.
Re-start the system and test.

If the above is not successful, then please repeat the steps in my post #7 and paste the contents of the two exported text files in your reply.
AustrAlien
Google is my friend. Make Google your friend too.

Posted Image

#10 krMitchell

krMitchell
  • Topic Starter

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Local time:09:23 AM

Posted 27 January 2012 - 09:04 AM

"Enable Autoplay for removable drives" was already unchecked. I went through the process of checking and unchecking it. Still runs autoplay. Registry entries the same as before.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer]
"HonorAutoRunSetting"=dword:00000001

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\policies\Explorer]
"NoDriveTypeAutoRun"=dword:00000095

Would unchecking the drive(s) under the Drives section of Autoplay in TweakUI do the trick?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users