Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Problem with Gimp


  • Please log in to reply
2 replies to this topic

#1 Keith1

Keith1

  • Members
  • 504 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Hamilton, Ohio
  • Local time:06:06 PM

Posted 08 January 2012 - 03:50 PM

Here's how the problem started. I took some pictures with my Wifes camera ( 12.1 mp ). I've done this many times before with no problems. So... the first thing I do is connect the camera to my computer and open the pictures with Gimp - where I scale them from 4000X... to 500x and save them in my pictures folder, so they are a reasonable size to send in emails. But now, any picture I open in my pictures folder opens with Gimp by default - not just the recent ones.

When I right click on a picture, 'open with Gimp' is the first entry in the drop down menu - so I guess it has somehow been set as default. I can't figure out how to undo that which has been done. I thought about uninstalling/reinstalling Gimp, but I'm thinking that the a setting in my pictures folder is the real problem. I'm lost right now, so any ideas?

BC AdBot (Login to Remove)

 


#2 stiltskin

stiltskin

  • Members
  • 238 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Western MO
  • Local time:06:06 PM

Posted 08 January 2012 - 05:04 PM

Open Nautilus, go to where one of the files is, right-click it, choose Properties, click on Open With, and choose a different default.

You can also go through ~/.local/share/mime (a directory of files) to see which one in there handled the filetype, then change or delete it. Just be careful with the syntax if you alter one. It's plain text xml, but you need to make sure all opening/closing statements are done properly. You could also move it temporarily to your home directory to test things before committing to deletion. (Either action may require a logout/in to take effect.)

#3 Keith1

Keith1
  • Topic Starter

  • Members
  • 504 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Hamilton, Ohio
  • Local time:06:06 PM

Posted 09 January 2012 - 12:36 PM

Thanks for the information stiltskin, all is back to normal now - pictures opening with image viewer. I used the GUI route you mentioned to correct it.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users