Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Need help troubleshooting possible HW failure on new build


  • Please log in to reply
5 replies to this topic

#1 Thanlos

Thanlos

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:03:04 PM

Posted 08 January 2012 - 05:12 AM

A little bit of background information...

For Christmas I recently built a new budget gaming rig for my younger brother, needless to say, it hasn't turned out too well. I have built 4 PCs over the past few years and would consider myself above-average when it comes to computer knowledge. However, I have very little experience troubleshooting hardware or software failure because it has rarely happened to me. Anyway, my luck has run out with this latest build and now I require assistance from the users of this forum. I've never visited this site before, but after browsing through some of the topics I came to the conclusion that it had a helpful community, and that is exactly what I need right now. Thanks in advance to anyone willing to help.

In the next few sections I will attempt to provide info on the various aspects of the build: hardware, software, assembly, and my attempts at diagnosing the problems, also included are various attached files detailing specs, temps, and crashes that occurred during operation. P.S., I don't know how to debug, so hopefully somebody can make sense of them.

1. Hardware (Taken straight from my Newegg invoice)

Case- RAIDMAX Blade ATX-298WW Black / White Steel / Plastic ATX Mid Tower Computer Case
Case fans- [x3] XIGMATEK Cooling System XLF XLF-F1256 120mm LED Blue Case Fan PSU Molex Adapter/extender included
CPU cooling- Antec Kuhler H2O 620 Liquid Cooling System
PSU- RAIDMAX HYBRID 2 RX-630SS 630W ATX12V V2.2/ EPS12V SLI Ready CrossFire Ready Modular Modular LED Power Supply
Motherboard- GIGABYTE GA-880GM-USB3 AM3+ AMD 880G USB 3.0 HDMI Micro ATX AMD Motherboard (REV 3.0)
CPU- AMD FX-4100 Zambezi 3.6GHz (3.8GHz Turbo) Socket AM3+ 95W Quad-Core Desktop Processor FD4100WMGUSBX
RAM- G.SKILL NS 4GB (2 x 2GB) 240-Pin DDR3 SDRAM DDR3 1333 (PC3 10666) Desktop Memory Model F3-10666CL9D-4GBNS
GPU- HIS H677FN1GD Radeon HD 6770 1GB 128-bit GDDR5 PCI Express 2.1 x16 HDCP Ready CrossFireX Support Video Card with Eyefinity
HDD- HITACHI HDS721050CLA362 (0F10381) 500GB 7200 RPM SATA 3.0Gb/s 3.5" Internal Hard Drive -Bare Drive
Burner- LITE-ON DVD Burner - Bulk Black SATA Model iHAS124-04 - OEM
OS- Windows 7 Ultimate 64 Bit

2. Software

Windows 7 Ultimate 64 Bit
CPU-Z
HWMonitor
Speccy

3. Assembly & Troubleshooting

Assembly

Prior to installing everything in the case I set up a temporary test bed atop the motherboard's cardboard box. The components connected to the motherboard at this time included: CPU, CPU stock heat-sink, (no use in attaching the water cooling for a first boot) GPU, and power supply. The computer POSTed successfully aside from the error about there not being a HDD connected. At this point I thought the build was a success and proceeded to install everything into the case. I removed the stock heat-sink from the CPU, cleaned off the thermal grease, and then I swapped out the standard 120mm case fans for the new ones and mounted the radiator to one of them; I left the tubes dangling out of the way for the time being (It's a self-contained unit).

After that I attached the motherboard stand-offs and screwed everything in, making sure not to over-tighten, and taking precautions to avoid ESD; I placed the PSU in the case, leaving it unplugged and switched off; plugged in the front-panel audio and USB, front panel headers and speaker, 20+4 pin ATX power, mounted the CPU back plate and fastened the pump to the CPU (pump had pre-applied grease), and connected the CPU power and fan header along with the system fan header. I slid the HDD into a 3.5" bay and secured it, connected the SATA power and data cables. Finally I installed the disc burner with SATA and power, removed 2 expansion slot covers and inserted the GPU, connecting one 6 pin PCI-E power cable to it. Everything was in place and secure; it was time to check the fan speed and temps inside the case within the BIOS and install the OS.

Troubleshooting

I connected the keyboard, mouse, and monitor and pushed the power button; the speaker gave 1 short beep indicating a successful boot and the motherboard splash screen came up; I hit the delete key to enter BIOS setup. I checked to make sure all of the fans were spinning, and all were, except for the one mounted on the radiator and plugged into the pump. I was worried at first so I quickly checked the PC Health Status section of the BIOS to see if maybe the motherboard was managing the fan and the CPU just wasn't hot enough to start it spinning. Sure enough, I found the CPU temperature and it was reading 19 Celsius; and "CPU Smart FAN Control" was enabled. I went to the bathroom, came back, and the CPU fan had started spinning, so I knew it was working fine.

I then set the first boot device to the burner and put in my Windows 7 installation disc. Windows finished installing but upon reboot, entered installation again to start the process over. At this point, one of two things happened, either my HDD malfunctioned and caused the system to boot from CD drive again, or I messed up and forgot to select the HDD as my second boot option in BIOS prior to installing Windows. Being optimistic I assumed it was the latter, and restarted the PC, entering BIOS and switching the first boot device from the CD drive to my HDD which Windows was now installed on. I restarted again and it successfully loaded my OS and I was now at the Desktop.

I installed the aforementioned software from a thumb drive and checked temps and fan speeds again, everything looked good. I connected to the internet and installed all of the important Windows Updates. Restarted the PC and experienced my first problem, it froze on the motherboard splash screen; there was the single short beep from the speaker signifying a successful boot, but obviously something was wrong. I couldn't hit delete to enter the BIOS or F12 to select my boot options, so I hit the restart button on the case. It gave the same single short beep, but this time the screen was blank, it didn't even make it to the splash screen this time.

I thought the lack of a picture on the screen indicated a problem with the monitor or cable, so I turned the monitor off and then back on and unplugged the DVI cable from the graphics card and plugged it back in. Still no picture, I was disappointed and feared hardware or software failure; but I thought surely it wasn't hardware failure because that single short beep meant everything was functioning. I switched the PSU off and unplugged it, re-seated the GPU and the RAM (I read online somewhere that this sometimes fixes a failure to POST). I also unplugged the SATA connectors and plugged them back, making sure they weren't loose.

I put the side panel back on and booted it up again, this time it appeared to be working and allowed me into the BIOS setup once again. I made sure it was set to "Load Optimized Defaults" and then changed an option allowing me to bypass the motherboard's splash screen and instead view the POST information. I saved and exited and it rebooted, gave the same success beep and this time it showed the POST info which basically said that the RAM was ok and there was 4GB of it, and it also detected the HDD. The screen disappeared and Windows loaded. I figured I must have solved the problem and went on to install my favorite internet browser and things like a new desktop wallpaper and 1 or 2 of my games to test it's stability.

I periodically checked the temps and fan speeds and it was all fine. The temperature of the CPU never got above 25 C and the fan speed was hovering around 850-983 rpm. I went to get a glass of water and when I came back the system was frozen again, this time on the desktop just like I had left it. The monitor was still on, and the fans running, but the HDD activity light on the case was not blinking, so I thought it may have been a hard drive problem. I restarted and it froze on the POST info right when it got to detecting the hard drive; I then thought my assumption about the HDD error was correct, and I just kept restarting until it finally made it past POST.

I got back into the OS and the HDD activity light was flashing, which was a good sign. I decided to run Chkdsk to scan the drive for errors on the next boot. Restarted the PC and it started to run the disk check, after about an hour and a half it finished 100% and before I could read the results the system rebooted and this time it froze on POST right at "DDR3 OK 4096 MB" so I restarted again and ran Memtest86 from a bootable CD and encountered no errors. I restarted again and had a blank screen; same as before, the speaker gave the same beep as always and everything was powered on, but the monitor was blank. I went and grabbed a different monitor and connected it but it did the same thing. At this point I figured it didn't make sense for the culprit to be the HDD, since the disk checking utility completed without fail, and the PC wasn't even making it as far as to load the OS anyway.

I now blamed one or more of the essential components i.e. the motherboard, CPU, or RAM for being faulty. I gave up for the night and went to bed. The next morning I re-seated the RAM, cleared the CMOS and unplugged the HDD, CD-Drive, and GPU just to eliminate those as potential causes (This particular MOBO has an on-board GPU, so I could still use it without the card in). The system booted successfully and so I shut it down again, this time connecting things one at a time and then booting to see if it worked. First the HDD, and then the burner and graphics card.

It booted without a hitch all 3 times, which to me, didn't make sense because on the 3rd try it had the original configuration with all components connected. So once it got to the screen saying Windows did not shut down successfully, I chose to boot into safe mode; which it did and then a Windows alert popped up saying there had been a BSOD (File with copied and pasted text attached) and it had created a .dmp file (in dropbox) containing the info. I checked the Event Viewer, and there had been a few entries just stating the system lost power and shut down unexpectedly, and there was one entry saying the computer had rebooted from a bugcheck (text copied from event viewer also an attached file). I then proceeded to transfer that .dmp file from the BSOD it reported (I never saw the actual blue-screen, maybe that happens? IDK) to my thumb drive along with the other two files. I also found a larger DMP file in the same directory as the small ones, but it is 335 MB in size, and is therefore too large to attach to this forum.

After grabbing the files detailing the crashes, I used the programs mentioned in the "Software" section to get detailed info about the hardware config that I thought might be useful. The final step I took was to do a clean install of Windows, just in case it was the OS giving me problems. That was also unsuccessful as the same types of problems were experienced after install.

So that's pretty much it guys, just to quickly wrap things up in case I missed anything, here is what I've tried so far...

1. Made sure all connections were snug
2. Ran Chkdsk and Memtest (Inconclusive)
3. Tested 2 totally different monitors (Verified not problem with monitor)
4. Reseated RAM and GPU
5. Cleared CMOS
6. Tested Non-essential components one at a time (Inconclusive, boot seems successful at random)
7. Gathered a few DMP files and copied some text from Event Viewer detailing instability
8. Acquired in-depth hardware analysis through various software tools
9. Uploaded said files

Hopefully I have provided enough information for someone to assist me with a proper diagnosis of the problem. I don't have any spare parts laying around to swap in and out of the system or else I would have tried that as well. I think the best thing to do now is have someone look at these .dmp files for any hint at what exactly is happening (hopefully an experienced debugger will see this post). I only have about another week to RMA any hardware back to the retailer, so I'm hoping somebody can tell me which piece of hardware is defective.

If you think I can provide anymore information than this, please ask. But keep in mind that the stability of the PC is extremely unpredictable and it only functions for short periods of time.

P.S. The file attacher says i'm not allowed to upload .dmp files so I have placed them in my dropbox folder for downloading

First dump
Second dump

Attached Files


Edited by Thanlos, 08 January 2012 - 08:46 AM.


BC AdBot (Login to Remove)

 


#2 LucheLibre

LucheLibre

  • Members
  • 608 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Tennessee
  • Local time:04:04 PM

Posted 08 January 2012 - 12:57 PM

As far as I can tell, you're using an AM3+ CPU in a MB with an AM3 slot. See http://en.wikipedia.org/wiki/Socket_AM3# for details on compatibility. Be sure you have the latest BIOS installed.

Your MB is rated to run Phenom II and Athlon II CPUs. It may not be able to provide the power necessary to run the Zambezi line.

Edited by LucheLibre, 08 January 2012 - 12:59 PM.

If it looks like I know what I'm doing, there's a pretty good chance the only reason for that is because
I once asked someone to run chkdsk /r and a BC Advisor smacked me in the back of the head.

~ LL ~


#3 CmmTch

CmmTch

  • Members
  • 109 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:St. Louis, Missouri USA
  • Local time:02:04 PM

Posted 08 January 2012 - 07:00 PM

This is from the Gigabyte site, I believe this is the Mobo you have http://www.gigabyte.us/products/product-page.aspx?pid=3809# notice the alert at the middle of the screen about upgrading to the latest BIOS found in their motherboards download section for the AM3+ and FX series processors. The downloads are one of the tabs on the page.

Click on the "CPU support List" button on the screen, it shows this board supports your CPU with the latest BIOS version FD. That may be your problem.
Steve

#4 Thanlos

Thanlos
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:03:04 PM

Posted 08 January 2012 - 09:47 PM

Thanks for the reply,

That's definitly my MOBO, and I did what you said and flashed the BIOS to the latest version; which according to the link you posted, is version FE, published on 10/25/11. After successfuly updating the BIOS, the system booted and reported 1 error in Event Viewer which reads as follows...

EVENT 18, WHEA-Logger

A fatal hardware error has occurred.

Reported by component: Processor Core
Error Source: Machine Check Exception
Error Type: Bus/Interconnect Error
Processor ID: 3

The details view of this entry contains further information.

- System

- Provider

[ Name] Microsoft-Windows-WHEA-Logger
[ Guid] {C26C4F3C-3F66-4E99-8F8A-39405CFED220}

EventID 18

Version 0

Level 2

Task 0

Opcode 0

Keywords 0x8000000000000000

- TimeCreated

[ SystemTime] 2012-01-09T02:11:45.297650200Z

EventRecordID 3079

- Correlation

[ ActivityID] {05570CAD-E7A2-4352-AC10-B620A78FB3C3}

- Execution

[ ProcessID] 1228
[ ThreadID] 2088

Channel System

Computer Grant-PC

- Security

[ UserID] S-1-5-19


- EventData

ErrorSource 3
ApicId 3
MCABank 0
MciStat 0xb880000000020f0f
MciAddr 0x0
MciMisc 0x0
ErrorType 10
TransactionType 256
Participation 3
RequestType 0
MemorIO 3
MemHierarchyLvl 3
Timeout 1
OperationType 256
Channel 256
Length 928
RawData 435045521002FFFFFFFF03000100000002000000A00300002A1E0E0007010C140000000000000000000000000000000000000000000000000000000000000000BDC407CF89B7184EB3C41F732CB57131FE6FF5E89C91C54CBA8865ABE14913BB05356AE548CDCC0102000000000000000000000000000000000000000000000058010000C00000000102000001000000ADCC7698B447DB4BB65E16F193C4F3DB0000000000000000000000000000000001000000000000000000000000000000000000000000000018020000800000000102000000000000B0A03EDC44A19747B95B53FA242B6E1D0000000000000000000000000000000001000000000000000000000000000000000000000000000098020000080100000102000000000000011D1E8AF94257459C33565E5CC3F7E8000000000000000000000000000000000100000000000000000000000000000000000000000000007F010000000000000002040000030000120F60000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000300000000000000000000000000000000000000000000000000000000000000000000000000000007000000000000000300000000000000120F6000000804030B229816FFFB8B170000000000000000000000000000000000000000000000000000000000000000B3F8F31CB1C5A249AA595EEF92FFA63C01000000000000009E07C0C4070000000000000000000000000000000000000000000000000000000000000000000000010000000200000021D728EF48CDCC010200000000000000000000000000000000000000000000000F0F0200000080B8000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000



EDIT: The system locked-up again about 7 mins after that report. I went back to the Gigabyte website and downloaded the FD version of the BIOS; the FD version is the 2nd most recent version, but it is the first one to give support for AM3+ CPUs, so I thought it may be worth a shot incase something was wrong with the FE version. After 'downgrading' to the FD version, the system seems stable and has been functioning for the past 20 mins or so. I am now installing Windows 7 SP1, and will report back once either the system crashes, or it stays on for any significant amount of time, in which case it's probably fixed.

Thanks

#5 Thanlos

Thanlos
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:03:04 PM

Posted 08 January 2012 - 10:54 PM

After experiencing system stability for about an hour and 15 minutes, the system locked-up again. At the time, I was investigating the cause of a USB serial bus error in Device manager. One of my USB devices had a yellow triangle with a ! in it; I then hit scan for hardware changes and then I clicked uninstall on the device in an attempt to have the OS recognize it later.

For clarification, At the time this occurred I was using version FD of the Award BIOS for my motherboard GA-880GM-USB3 (rev. 3.1) from Gigabyte. Does anyone think that maybe my problems are due to physical damage to the CPU or Motherboard? If so, could you please explain why you think that?

#6 CmmTch

CmmTch

  • Members
  • 109 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:St. Louis, Missouri USA
  • Local time:02:04 PM

Posted 09 January 2012 - 10:39 PM

You are correct, "FD" was not the most recent BIOS update, my mistake talking about upgrading to the latest and "FD" in the same sentence. FD is the earliest BIOS that supports AM3+ CPU's, but FE is the most recent which should work, but if FD works for you then stay with that version.

After updating BIOS I wonder if updating the chipset drivers would help. Check the versions on your Mobo CD and compare with those on the Gigabyte site, it might be worth a try. Also you might check the USB driver versions too, the new BIOS could cause other components to need updated drivers.

I don't know if there is a physical damage problem, you were up and stable for an hour. That doesn't sound like there's damage, it sounds like software/driver issues. Check the manual for information on if anything else needs to be updated after updating the BIOS, I tried to look at it but get a message that Adobe has a problem when I try and download the manual. I have the latest version of Adobe and this is the only page that gives me a problem so I couldn't check the manual myself.
Steve




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users