Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

System restore in Task Scheduler no longer exists, help needed


  • Please log in to reply
4 replies to this topic

#1 Newuser28

Newuser28

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:07:56 PM

Posted 07 January 2012 - 05:40 PM

Hello Everyone,

I was trying to reduce the amount of times system restore was occurring on my PC, so I accessed System Restore in the 'Task Scheduler' and changed the 'trigger' from daily to monthly, and I changed the date to the 12th of each month and changed the time to 6am too. I'm not sure if this has anything to do with it, but at the time, windows was also installing updates, which were lots of security updates for Microsoft . NET Framework 4 Client Profile. After the updates, and the changes I made in the 'Task Scheduler,' I restarted my computer, and now when I access Task Scheduler, the sign 'The selected task “{0}” no longer exists. To see the current tasks, click refresh.' comes up... But this only comes up once, and then again, when I click on the 'system restore,' file, which now has no information displayed about it, so I can't access it, so obviously something is wrong with this 'system restore,' file in the task scheduler.... I have tried using the system restore option to a previous point, but that just makes things worse, where I can't access 'Task Scheduler and Event Viewer.' So I undid this system restore, and am left with the problem described above, where it says
'The selected task “{0}” no longer exists. To see the current tasks, click refresh.'
Any help appreciated on how to get things back on track.

Regards
Kelly.

Edited by Newuser28, 07 January 2012 - 05:41 PM.


BC AdBot (Login to Remove)

 


#2 Artrooks

Artrooks

  • Members
  • 1,463 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New York
  • Local time:08:56 PM

Posted 07 January 2012 - 10:13 PM

Hello Newuser28,

Have you tried to create a new system restore task?

  • Go to "Task Scheduler" and arrow down to Microsoft, Windows, System Restore.
  • Click "Create basic task" on right.
  • Name: SR
  • Description: This task creates regular system protection points.
  • Trigger: Choose when you want SR creation to start.
    Action: Start a program.
  • Start a program (script): %windir%\system32\rundll32.exe srrstr.dll,ExecuteScheduledSPPCreation
  • Finish.

Regards,
Brooks



 


#3 Newuser28

Newuser28
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:07:56 PM

Posted 08 January 2012 - 05:41 PM

Hello, thankyou for reply.

Unfortunately I cannot do this, when I click on the second step of clicking on 'create basic task,' I get the response 'Task Scheduler is not available or the folder does not exist. Verify the folder is running and the service exists.' Strangely enough when I click on the system restore folder in Task Scheduler, all the other folder/files in the windows folder (in the task scheduler) then display no information, which they do previously if I don't click on the system restore folder.

I also found that if I type in 'services' in the start function on the desktop, and then access 'Services (local),' and if I go down the list and click on 'Task Scheduler,' I find the Task Scheduler Dependencies - 'Remote Procedure Call (RPC) and 'Windows Event Log' are running fine and how they should be. However, all the other Task Scheduler tabs such as 'General, Log On and Recovery are all greyed out, meaning I can't change anything or access anything.'

Anyone know how to help with this task scheduler problem?

Thanks

#4 drw12333

drw12333

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:07:56 PM

Posted 27 January 2012 - 09:02 PM

Your system restore may have been turned off. Go to the services again and go down to
"Microsoft Software Shadow Copy Provider" make sure this is set to "Automatic"Attached File  restore.GIF   71.23KB   3 downloads

#5 mcleaver

mcleaver

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:02:56 AM

Posted 05 April 2015 - 11:29 AM

The task scheduler service is grayed out here. :-(






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users