Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Code 39 error on CD/DVD driver


  • Please log in to reply
3 replies to this topic

#1 mastobeam

mastobeam

  • Members
  • 76 posts
  • OFFLINE
  •  
  • Local time:06:51 PM

Posted 05 January 2012 - 05:31 PM

My CD rom/DVD drive is not being recognised by my computer. I am running XP service pack 3. The CD is an LG product in a Fujitsu machine. I have recently been infected by a virus which has (with the help of this forum) been cleaned however at some point between being infected and now my CD has stopped being recognised and device mgr reports a code 39 error with the device.

I have tried a number of things with no positive result. I have:

Uninstalled and re-installed the device in device manager
I have removed the upper and lower filters in the registry
I have run the Microsoft Mr Fixit for this type of error which just told me what I already knew - the CD isn't working
I have run the cdgone.reg file as in another post on this topic in this forum
I have attached another CD rom which I know works to the machine - same error (so not a dud CD drive)
Disconnected and reconnected the cables from the CD Rom
Uninstalled and reinstalled both primary and secondary IDE channels

I've now run out of ideas and looking for help. Due to the virus infection I don't have any 'clean' system restore points at a time when CD was working.

BC AdBot (Login to Remove)

 


#2 jhayz

jhayz

  • BC Advisor
  • 6,922 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:51 AM

Posted 05 January 2012 - 06:48 PM

Try running system file checker on command prompt first then uninstall/disable optical drive then reboot and let windows detect the drive.

Tekken
 


#3 LucheLibre

LucheLibre

  • Members
  • 608 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Tennessee
  • Local time:01:51 PM

Posted 05 January 2012 - 06:52 PM

http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/error-code-39-windows-7/a960b830-ac75-4825-8ae1-8ae68128834b

Check that link and see if it has any bearing on your situation.

If it looks like I know what I'm doing, there's a pretty good chance the only reason for that is because
I once asked someone to run chkdsk /r and a BC Advisor smacked me in the back of the head.

~ LL ~


#4 mastobeam

mastobeam
  • Topic Starter

  • Members
  • 76 posts
  • OFFLINE
  •  
  • Local time:06:51 PM

Posted 08 January 2012 - 01:37 PM

Yep tried all of the above. Still getting a code 39 error




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users