Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

I'm stuck in Linux Land!


  • Please log in to reply
10 replies to this topic

#1 michael-m

michael-m

  • Members
  • 26 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:07 AM

Posted 01 January 2012 - 12:11 PM

I've just installed Ubuntu (11.10) alongside Windows XP as a dual boot system. System shows that my hard drive in Linux is about half the size of the hard drive - as you'd expect for a partitioned drive.

On boot up, my pc is loading straight into Linux - not a problem in itself, but I'd like to have the opportunity to choose Windows should I wish.

Can I "slow things down" to give myself the choice? I'm fine with Linux as the default, but want to have the option.

According to the Ubuntu documentation, GRUB2 is the bootmanager ( https://help.ubuntu.com/community/WindowsDualBoot#Install_Ubuntu_after_Windows ). In the boot file, I can see GRUB.CFG, and GRUBENV, but not GRUB2 - and even if I could find it, I wouldn't know what to do with it!

Any advice please?

Michael

BC AdBot (Login to Remove)

 


#2 buddy215

buddy215

  • Moderator
  • 13,324 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:West Tennessee
  • Local time:09:07 PM

Posted 01 January 2012 - 01:59 PM

In my Ubuntu 10.04 I can go to startup manager by clicking on System and choosing Startup Manager.

See if yours is the same. If so, there are boot options available there.

It's been a while since I installed but I think you should see a boot screen with what I think is a 10 second default
time to choose which OS to boot to. Odd that you don't.

If you can't find a startup manager then someone who is using the latest Ubuntu should be able to assist you.
“Every atom in your body came from a star that exploded and the atoms in your left hand probably came from a different star than your right hand. It really is the most poetic thing I know about physics...you are all stardust.”Lawrence M. Krauss
A 1792 U.S. penny, designed in part by Thomas Jefferson and George Washington, reads “Liberty Parent of Science & Industry.”

#3 buddy215

buddy215

  • Moderator
  • 13,324 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:West Tennessee
  • Local time:09:07 PM

Posted 01 January 2012 - 02:04 PM

Just saw this:
Ubuntu 11.10: Problems with the boot loader? Here's how to solve ... | LinuxTechCrunch | Linux Software | Linux Software Download | Linux Software Tutorials
“Every atom in your body came from a star that exploded and the atoms in your left hand probably came from a different star than your right hand. It really is the most poetic thing I know about physics...you are all stardust.”Lawrence M. Krauss
A 1792 U.S. penny, designed in part by Thomas Jefferson and George Washington, reads “Liberty Parent of Science & Industry.”

#4 michael-m

michael-m
  • Topic Starter

  • Members
  • 26 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:07 AM

Posted 01 January 2012 - 02:58 PM

Just saw this:
Ubuntu 11.10: Problems with the boot loader? Here's how to solve ... | LinuxTechCrunch | Linux Software | Linux Software Download | Linux Software Tutorials


You are an absolute star - I'm posting this in I.E.

Thanks very much - I was getting a bit worried!

Michael

#5 michael-m

michael-m
  • Topic Starter

  • Members
  • 26 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:07 AM

Posted 07 December 2012 - 07:21 AM

Hmmm....

I Updated to 12:04 back in April (ish), and all was fine.

This morning, I've run Update Manager, and installed all updates - I'm back to where I started, and seem to have lost Grub with no option of running widows (I need to sometimes - very rarely, but it's nice to have the option).

So I went into Dash to try and access the StartUp Manager - but it seems there's no such thing any more.

Is there an equivalent to StartUp Manager that is now called something else? Alternatively, can I un-install the changes that have taken place this morning, and if so - how?

thanks.

Michael

Edited by michael-m, 07 December 2012 - 07:23 AM.


#6 buddy215

buddy215

  • Moderator
  • 13,324 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:West Tennessee
  • Local time:09:07 PM

Posted 07 December 2012 - 08:20 AM

Here is one possible solution. I haven't had a need to use it or similar as I have only 12.04 installed
a computer. Grub Customizer in Launchpad

More discussion and links to other solutions:
installation - How to install startupmanager in 12.04? - Ask Ubuntu
“Every atom in your body came from a star that exploded and the atoms in your left hand probably came from a different star than your right hand. It really is the most poetic thing I know about physics...you are all stardust.”Lawrence M. Krauss
A 1792 U.S. penny, designed in part by Thomas Jefferson and George Washington, reads “Liberty Parent of Science & Industry.”

#7 rburkartjo

rburkartjo

  • Members
  • 3,998 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:austin,tx
  • Local time:09:07 PM

Posted 07 December 2012 - 11:04 AM

michael you cold try this if the you still havent fixed. this will give you the option to boot into linux or windows on the startup screen. it is what i use

open terminal and type


gksudo gedit /etc/default/grub
the type in your password

you then will get something like this


# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=-1
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

change the first 4 items to exactly what is posted as above you just have to change after the = sign
save then exit

then go back and open the terminal and type sudo update-grub
that should do it
test it out by rebooting you computer you should be given the option of booting into linux or windows

Edited by rburkartjo, 07 December 2012 - 11:08 AM.

quote:He that would live in peace & at ease, Must not speak all he knows,nor judge all he sees.'

#8 bustedbritches

bustedbritches

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:08:07 PM

Posted 12 January 2013 - 03:49 PM

don't know if this has been posted before, but upon start up, press (frequently) F12, and you can pick and choose
your os.....

#9 michael-m

michael-m
  • Topic Starter

  • Members
  • 26 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:07 AM

Posted 18 January 2013 - 02:31 PM

michael you cold try this if the you still havent fixed. this will give you the option to boot into linux or windows on the startup screen. it is what i use

open terminal and type


gksudo gedit /etc/default/grub
the type in your password

you then will get something like this....


All I get is the command line.

The issue (solved by Buddy's bootloader link last time) is that something to do with th resolution of the screen - it just sits there, blank, for the 10 seconds whilst grub is waiting for me to decide between linux and windows. But all I see in the blank screen and screen message "out of range".

F12 doesn't work either...

#10 buddy215

buddy215

  • Moderator
  • 13,324 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:West Tennessee
  • Local time:09:07 PM

Posted 19 January 2013 - 07:14 AM

I think I would first install Grub Customizer and first try changing resolutions using it.
If that didn't solve the problem then I would use it to reinstall the bootloader.
Be sure to get the correct ppa for your installation of 12.04...Precise Pangolin....(Launchpad PPA for Grub Customizer : Daniel Richter )


Grub Customizer in Launchpad
Features:
* move, remove or rename menuentries (they stey updatable by update-grub)
* edit the contents of menuentries or create new ones (internally it edits the 40_custom)
* support for GRUB2 and BURG
* reinstallation of the bootloader to MBR
* settings like default operating system, kernel params, background image and text colors etc.
* changing the installed operating system by running on a live cd

Posted Image
“Every atom in your body came from a star that exploded and the atoms in your left hand probably came from a different star than your right hand. It really is the most poetic thing I know about physics...you are all stardust.”Lawrence M. Krauss
A 1792 U.S. penny, designed in part by Thomas Jefferson and George Washington, reads “Liberty Parent of Science & Industry.”

#11 Joseph Edwards VIII

Joseph Edwards VIII

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:07:07 PM

Posted 23 January 2013 - 08:43 PM

It's possible that the GRUB was installed on on a block partition or that the MBR was nullified. Has happened to me with dual Vista/Mint. I think I used the 'Super Grub Disk' to fix the MBR and was in like Flynn: http://www.supergrubdisk.org/

Another good tool is 'Boot Repair Disk': https://help.ubuntu.com/community/Boot-Repair




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users