Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Unable to Activate Automatic Updates After Cleaning XP Security 2012


  • Please log in to reply
5 replies to this topic

#1 HNLRoscoe

HNLRoscoe

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:10:17 AM

Posted 30 December 2011 - 02:49 PM

Hi,

My mom's laptop picked up the XP Security 2012 malware, and I think I've all but wiped it out thanks to the instructions on this site. However I'm still not able to turn Automatic Updates back on, so I think I may still be infected. I downloaded Comodo Antivirus and scans are showing negative. How do you think I should proceed?

BC AdBot (Login to Remove)

 


#2 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:03:17 PM

Posted 30 December 2011 - 03:18 PM

Hi

Try this

You may be missing automatic updates from your services

Click on start button ,go to RUN and type

cmd and click ok

Now run this command

regsvr32 wuaueng.dll and press ENTER

Now go to RUN and type

services.msc and click ok

Right click on Automatic updates and start it


If that doesnt fix the issue,run the MICROSOFT FIXIT

http://go.microsoft.com/?linkid=9665683

If that doesnt work,Download dial-a-fix

http://djlizard.net.nyud.net:8080/software/Dial-a-fix-v0.60.0.24.zip

Extract and launch it

Click on TICK mark and then click on GO

Good luck

#3 HNLRoscoe

HNLRoscoe
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:10:17 AM

Posted 30 December 2011 - 05:09 PM

Thanks for your quick response, Narenxp. Autoupdates are back on, and functioning properly, but a new problem has come up and I'm not sure what to make of it.

Every couple hours as my mom is using her laptop, the wireless connection disables itself and the COMODO Firewall detects a new Wired Network (even though it's not wired to anything) at 169.254.165.223/17. The only way I've found to reenable the wireless connection again is to restart the computer, but the connection just drops again a little later. Scans run by COMODO AV aren't picking up any infections. I remember having a problem like this related to malware back a couple years ago. Could this new network that my firewall keeps detecting be some kind of rogue connection?

Here's a picture of the Firewall detecting the network.

Posted Image

#4 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:03:17 PM

Posted 30 December 2011 - 05:19 PM

Receiving a IP address in the range of 169.254 means that you are not in contact with your router.There seems to problem with your internet connection.I guess this may have started after virus removal,try this

Download

Winsock fix


Launch it ,Click on FIX

Restart your PC after it gets completed

See if your wireless stays on,if you still face the issue

PLEASE create a restore point before trying this


Please copy the entire contents of the codebox below into Notepad:



REGEDIT4

[-HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock]

[-HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WinSock2]



Open a notepad ,copy the script,save it as

Filename:winsock.reg
save as type:All files


Launch it and click YES to add it to registry

After that, Reboot your computer.

After the restart,

Go to Network Connections
Right click on your normal connection icon, and choose Properties
Click the Install button
Choose Protocol then click Add
Click Have disk
In the drop down box, type in: C:\WINDOWS\INF and click OK
In the next dialog, click Internet Protocol (TCP/IP) then click OK
Click Close to leave the properties box

After that, restart your computer and see if you can browse now.

Good luck

#5 HNLRoscoe

HNLRoscoe
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:10:17 AM

Posted 31 December 2011 - 09:33 PM

Okay, Winsockfix seemed to do the trick (gave it a while just to be sure). Thanks a lot for all your help Narenxp.

#6 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:03:17 PM

Posted 31 December 2011 - 09:49 PM

:thumbsup:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users