Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

VPN network aaptor failed


  • Please log in to reply
5 replies to this topic

#1 Ishan Reddy

Ishan Reddy

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:07:31 PM

Posted 23 December 2011 - 11:56 PM

My VPN does not work any more and kept getting the message that "Failed to connect for following reason :activating VPN adapter failed ".
This happned after my system got hit by the Trojan "Win 7 Antispyware 2012 " and malware was run to remove it .

I am on windows 7 OS .

any ideas ...

thanks ,
Ishan

Attached Files


Edited by Ishan Reddy, 23 December 2011 - 11:59 PM.


BC AdBot (Login to Remove)

 


#2 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,769 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:04:31 PM

Posted 24 December 2011 - 12:27 PM

Please download Farbar Service Scanner and run it on the computer with the issue.
  • Make sure the following options are checked:
    • Internet Services
    • Windows Firewall
    • System Restore
  • Press "Scan".
  • It will create a log (FSS.txt) in the same directory the tool is run.
  • Please copy and paste the log to your reply.

My Website

My help doesn't cost a penny, but if you'd like to consider a donation, click DONATE

 


#3 Ishan Reddy

Ishan Reddy
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:07:31 PM

Posted 26 December 2011 - 12:20 AM

Thank you for the reply .

Farbar Service Scanner
Ran by nlv13187 (administrator) on 25-12-2011 at 22:19:19
Microsoft Windows 7 Enterprise Service Pack 1 (X64)
****************************************************************

Internet Services:
============

Connection Status:
==============
Localhost is accessible.
LAN connected.
Google IP is accessible.
Yahoo IP is accessible.


Windows Firewall:
=============
MpsSvc Service is not running. Checking service configuration:
Checking Start type: Attention! Unable to open MpsSvc registry key. The service key does not exist.
Checking ImagePath: Attention! Unable to open MpsSvc registry key. The service key does not exist.
Checking ServiceDll: Attention! Unable to open MpsSvc registry key. The service key does not exist.

bfe Service is not running. Checking service configuration:
Checking Start type: Attention! Unable to open bfe registry key. The service key does not exist.
Checking ImagePath: Attention! Unable to open bfe registry key. The service key does not exist.
Checking ServiceDll: Attention! Unable to open bfe registry key. The service key does not exist.

mpsdrv Service is not running. Checking service configuration:
The start type of mpsdrv service is OK.
The ImagePath of mpsdrv service is OK.


Firewall Disabled Policy:
==================


System Restore:
============
SDRSVC Service is not running. Checking service configuration:
The start type of SDRSVC service is OK.
The ImagePath of SDRSVC service is OK.
The ServiceDll of SDRSVC service is OK.

VSS Service is not running. Checking service configuration:
The start type of VSS service is OK.
The ImagePath of VSS service is OK.


System Restore Disabled Policy:
========================


File Check:
========
Attention! H:\Windows\System32\nsisvc.dll is missing.
Attention! H:\Windows\System32\drivers\nsiproxy.sys is missing.
Attention! H:\Windows\System32\dhcpcore.dll is missing.
Attention! H:\Windows\System32\drivers\afd.sys is missing.
Attention! H:\Windows\System32\drivers\tdx.sys is missing.
Attention! H:\Windows\System32\Drivers\tcpip.sys is missing.
Attention! H:\Windows\System32\dnsrslvr.dll is missing.
Attention! H:\Windows\System32\mpssvc.dll is missing.
Attention! H:\Windows\System32\bfe.dll is missing.
Attention! H:\Windows\System32\drivers\mpsdrv.sys is missing.
Attention! H:\Windows\System32\SDRSVC.dll is missing.
Attention! H:\Windows\System32\vssvc.exe is missing.
Attention! H:\Windows\System32\svchost.exe is missing.
Attention! H:\Windows\System32\rpcss.dll is missing.


**** End of log ****

#4 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,769 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:04:31 PM

Posted 26 December 2011 - 12:24 AM

What is drive H?

My Website

My help doesn't cost a penny, but if you'd like to consider a donation, click DONATE

 


#5 Ishan Reddy

Ishan Reddy
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:07:31 PM

Posted 26 December 2011 - 01:00 PM

H:\ is the network drive

I got local drive C but this did not scan ...

#6 brunsamatic21

brunsamatic21

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:07:31 PM

Posted 28 December 2011 - 02:22 PM

Hello.

I had the exact same issue due to the exact same virus and have resolved the "activating VPN adpater failed" problem.

This trojan appears to totally wipe out the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\BFE entry. There are other services (including IKE and AuthIP IPSec) that are dependent on the BFE service. I'm not sure which one (or all) services affected that cause the VPN issue as I did not yet go back and stop each one and test.

To resolve, I exported the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\BFE from my other Win7 64 bit machine and imported to registry on problem machine. After rebooting and starting the BFE service, VPN now connects fine.

Here is a blog that details the resolution steps. I did not use the reg file link available for download but I did follow the same procedure using my own reg export.

Hope this helps.

http://blogs.technet.com/b/asiasupp/archive/2011/12/27/error-code-0x80070424-with-windows-firewall-and-quot-base-filtering-engine-service-quot-not-available-in-services-database-list.aspx




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users