Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Motherboard USB Ports Non Functional - But have power


  • Please log in to reply
1 reply to this topic

#1 Captmaddog

Captmaddog

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:01:07 AM

Posted 21 December 2011 - 12:36 PM

Hi,

The system is built around an Intel Dual Core processor, Asus P5K motherboard running 4gb DDR 2 RAM and an ATI Radeon graphics card.

I installed a new copy of Windows 7 Ultimate on a recently formatted hard drive and added and an extra PCI 4 port USB card.

My issue is that ALL of the 6 motherboard USB ports are powered (I can charge my phone from each one) but do not recognise any device plugged into them. Have tried keyboard, mouse, usb drive, camera and so on. Windows doesnt blink when anything is plugged in.

When I plug a device into one of the 4 ports on my PCI USB card it installs new device and is working perfectly with absolutely no issues.

I have been reading page after page of advice and done the following,
Removed power cable and small lithium MBoard battery overnight,
Flashed the bios several times upto and including the lastest version,
Checked that USB is enabled in all BIOS settings,
Downloaded and installed the latest Chipset drivers,
Checked that Device Mananger correctly sees all the USB ports and drivers. Everything is displayed with no errors or flags.
Deleted and reinstalled all USB components.
Windows is fully updated including the language packs.

With my 4 port USB card working perfectly am I to assume I have a biffed motherboard?
I just cant understand that as they have power and are recognised in Device manager. And were working perfectly with Windows XP Pro installed previously.

Any help would be greatly appreciated as I am at my wits end!

BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 56,092 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:08:07 PM

Posted 22 December 2011 - 08:49 AM

See response at http://pcuser.com.au/help/pc-hardware/2011/dec/motherboard-usb-ports-non-functional-but-have-power#comments .

What is listed in Device Manager under USB controllers?

Have you tried uninstalling all controllers listed under USB controllers...then rebooting the system?

Louis




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users