Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Lost Internet Connection When Trying to Fix "Vista Security 2012"


  • Please log in to reply
1 reply to this topic

#1 AkaRai

AkaRai

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:06:42 PM

Posted 12 December 2011 - 09:22 AM

A few days ago I was in a hurry, and I opened up IE rather than my usual browser. I just googled something with it quickly, and after clicking a single image result, found myself infected with something along the lines of "Vista Security 2012". It did the usual stuff, shut down some programs, forced a restart, set it so whatever I program I tried to open would instead pop up a nag screen to let the program scan.

I was still able to scan with SuperAntiSpyware, Malwarebytes and AVG though, so after those scans finished a couple portions of the virus seemed to be taken care of. No more nag screens, no more redirects.

While computer use was livable at that point, I was still seeing a few other effects. Every so often when I opened up a new tab, I would be redirected somewhere else. Additionally, a process I hadn't previously seen called PING.exe was showing up in task manager, and if allowed to run would continually drain more CPU and memory until the computer locked up, and when closed in task manager would just re-open itself a short while later.

Searching for another anti-virus program to try, I read a few threads suggesting Microsoft Security Essentials. I downloaded that from Microsoft's site, but after it installed it would just freeze at the update stage. Unable to update, it will not scan or function at all, and the difficulty I was having with turning it off made me suspicious of the program. After restarting after another virus scan, I can't reconnect to the internet on the system anymore. I'm able to connect other devices, but not that one (I'm on a borrowed laptop at the moment.)

When I connect to the internet, it says it's connected, but the icon to indicate the connection is successful doesn't come up. I can't sign in with anything or access any websites or anything The connectivity icon just continually states it's "(identifying...)" my connection.

So I brought up Intel PROSet/Wireless Tools, and ran a diagnostic. It says everything is fine with my connection until predictably, it gets to the ping test. I'm receiving data, but I can't send it. It suggests the problem might be my firewall, so I go check my firewall, and things are apparently more dire than I thought.

"Due to an unidentified problem, Windows cannot display Windows Firewall settings." Crap. "Windows Firewall was unable to make the requested updates." Crap. "Application failed to initialize: 0x80070006. The handle is invalid." Huh?

So my last option is system restore. Go over to the program, and... It's been turned off, and my restore points appear to be gone.

What'd I do to my poor system? Number one for me here is restoring internet connection, so I can continue to try to fix it on the system itself.

Oh, and I did try rkill a little earlier. It shut down two processes, and I was then able to delete a further five pieces of malware with various scans from my anti-virus programs. However, every time I ran it, on completion explorerer.exe would shut down as well, and I'd have to re-open it with a run command. My OS is Vista.

Edited by AkaRai, 12 December 2011 - 09:28 AM.


BC AdBot (Login to Remove)

 


#2 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,679 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:05:42 PM

Posted 12 December 2011 - 11:49 AM

a process I hadn't previously seen called PING.exe was showing up in task manager


Please follow the instructions in ==>This Guide<== starting at Step 6. If you cannot complete a step, skip it and continue.

Once the proper logs are created, then make a NEW TOPIC and post it ==>HERE<== Please include a description of your computer issues, what you have done to resolve them, and a link to this topic.

If you can produce at least some of the logs, then please create the new topic and explain what happens when you try to create the log(s) that you couldn't get. If you cannot produce any of the logs, then still post the topic and explain that you followed the Prep. Guide, were unable to create the logs, and describe what happens when you try to create the logs.

It would be helpful if you post a note here once you have completed the steps in the guide and have started your topic in malware removal. Good luck and be patient.

If HelpBot replies to your topic, PLEASE follow Step One so it will report your topic to the team members.

My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users