Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

CD-ROM Drive error


  • Please log in to reply
3 replies to this topic

#1 MrUnknown

MrUnknown

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:05:25 AM

Posted 03 December 2011 - 02:15 AM

Hello - I'm having some hardware problems that I would like some help with.
I was attempting to install something on my computer through a CD and nothing happened. So, I had a look at the Device Manager and the CD-ROM Drive has a yellow error symbol. I then clicked properties, to be presented with this under the device status: "Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)". I then Googled this and didn't get much. However - I ran the Microsoft Fix it. It detected the problem and attempted to install it again. That however failed. I have an Acer Aspire 5750 with Windows 7. Any ideas on how to get the CD-ROM drive working again?

Edited by MrUnknown, 03 December 2011 - 04:10 AM.


BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 55,726 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:05:25 AM

Posted 03 December 2011 - 09:07 AM

Go to Device Manager...uninstall the drivers for the optical drive...reboot, the driver should reinstall automatically on reboot.

Let us know if problem still exists.

Louis

#3 MrUnknown

MrUnknown
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:05:25 AM

Posted 03 December 2011 - 05:49 PM

Hi Louis,

Thanks for your response.

I attempted the solution you provided but it didn't work. I uninstalled the driver - rebooted then a notifcation on the desktop said "installing driver" then a few seconds later it told me the installation failed. The hardware appears to be back on the devices manaer, but it still has that yellow error symbol.

#4 hamluis

hamluis

    Moderator


  • Moderator
  • 55,726 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:05:25 AM

Posted 04 December 2011 - 11:35 AM

It may be dead...if the driver could not install.

I don't know what else to suggest other than trying a replacement optical drive...or seeing if the drive works on another system...if this is a desktop.

Let's see what others think.

Louis




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users