Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Virus messed up some some sensitive settings, need help getting system restore operational


  • Please log in to reply
5 replies to this topic

#1 serain

serain

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:02:05 AM

Posted 02 December 2011 - 12:17 PM

hey last night I was watching a movie from some site and i got infected with a couple of viruses, namely omk.exe and ping.exe, anyways i believe they got on my system through javascript and began replicating and causing all sorts of malicious problems. I pretty much put that computer to sleep and started looking for answers on how to remove the viruses on my laptop(because it seemed like just by my very computer being on it was under all sorts of attacks like processes reopening, then opening other processes, chokeing the memory etc...) so anyways to jump ahead a little bit, i did a search in safe mode, got rid of some stuff, got back on normal windows, things are running fine w/o extra processes going nuts, but now i have some residual problems left beind...it seems that whenever i click common applications like internet explorer or video games i play, whose icons are on desktop, and a few start menu items (particularly system restore) it cant load the programs... i cant figure out why but whenever i try to open more sophisticated software it keeps asking me what program to open with (the choose from program/application window)

well anyways back to the direct topic/problem at hand, when i try to click on system restore i get window prompted asking "open with" program's to choose from the list of software applications i have. So anyways, no internet, no games, no system restore.... how on earth do i go about fixing that?

Edited by hamluis, 02 December 2011 - 12:40 PM.
Moved from XP to Am I Infected.


BC AdBot (Login to Remove)

 


#2 Allan

Allan

  • BC Advisor
  • 8,584 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:03:05 AM

Posted 02 December 2011 - 12:21 PM

You need to restore the file associations (http://www.dougknox.com/xp/tips/xp_easy_file.htm), but if I were you I'd post in the Am I Infected forum on this site and make sure your system is malware free.

#3 serain

serain
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:02:05 AM

Posted 02 December 2011 - 12:30 PM

yeah like heres the thing if i open internet explorer from start menu and i "open with [internet explorer]" it drops me off in c:\documents and settings\myusername... wierd... but system restore once operational should fix all these linkage problems right?

#4 Allan

Allan

  • BC Advisor
  • 8,584 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:03:05 AM

Posted 02 December 2011 - 12:33 PM

I have no idea - certainly not if your system is still infected.

#5 serain

serain
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:02:05 AM

Posted 02 December 2011 - 12:35 PM

oh man lol i am definitly not malware free lol, i went to shut down, and my shutdown button has been remapped too, only, itt opened up 6 internet explorer viruses lol...uhg back to the hibernation and killing board... =/

#6 Eyesee

Eyesee

    Bleepin Teck Shop


  • BC Advisor
  • 3,540 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:In the middle of Kansas
  • Local time:02:05 AM

Posted 02 December 2011 - 12:36 PM

Very doubtful.

Visues and malware love to hine in system restore. The authors know that is something that someone with an infected computer will try and in so doing will put the infection right back.

Fillow what Allan said & head over to our Am I Infected section to have our malware folks take a look at the system for you.
In the beginning there was the command line.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users