Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't get sound working right Ubuntu 11.10


  • Please log in to reply
5 replies to this topic

#1 Xantalen

Xantalen

  • Members
  • 135 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:America
  • Local time:05:24 PM

Posted 28 November 2011 - 04:26 AM

So I recently installed Ubuntu 11.10 on my MSI GX740-235US laptop. My knowledge of Linux is very limited, so I don't know a whole lot about this stuff. Anyway, whenever a sound/music played it would sound very muffled, as if someone held a pillow over the speaker or something.


I figured it had to do with my drivers as I would hear that muffle sound very briefly when a sound would play on Windows before what I'm assuming to be the driver kicked in and fixed it. So after trying to figure out how to install the Realtek HD drivers, (yes I even have a hard time with that) a friend sort of guided me through it. He got me to the directory I extracted everything to and had me "sudo .install" the stuff. It did a whole bunch of things and I restarted the laptop. Now I don't hear a bloody thing.

I'd appreciate it if someone could lend a hand here.

BC AdBot (Login to Remove)

 


#2 Xantalen

Xantalen
  • Topic Starter

  • Members
  • 135 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:America
  • Local time:05:24 PM

Posted 28 November 2011 - 09:05 PM

So, thanks to nobody here, I managed to find a solution which I will share for everyone here:

http://ubuntuforums.org/showthread.php?t=1855765

But to summarize:

In terminal,

gksudo gedit /etc/modprobe.d/alsa-base.conf

then at the bottom of the file add (on a separate line)

options snd-hda-intel index=0 model=acer-aspire-7730g

Save and restart and enjoy.

#3 Keith1

Keith1

  • Members
  • 504 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Hamilton, Ohio
  • Local time:04:24 PM

Posted 28 November 2011 - 09:46 PM

Xantalen - glad you got it working, and for posting the 'fix' here.

However, I question your comment "thanks to nobody here". There a lot of great folks here to help, maybe they didn't know the answer to your particular question, or they were busy, be patient.

#4 stiltskin

stiltskin

  • Members
  • 238 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Western MO
  • Local time:04:24 PM

Posted 29 November 2011 - 06:05 AM

Or maybe didn't even see it until now.

#5 Xantalen

Xantalen
  • Topic Starter

  • Members
  • 135 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:America
  • Local time:05:24 PM

Posted 11 December 2011 - 01:10 PM

Sorry, I was in a bit of a mood at the time as the issue was quite annoying and other usual life things were going on. I also remember a time when responses came ridiculously fast.

As for the fix I found, is there a place for it to go so that others like me will have a solution?

#6 Keith1

Keith1

  • Members
  • 504 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Hamilton, Ohio
  • Local time:04:24 PM

Posted 11 December 2011 - 04:05 PM

Just in my opinion, right here is fine. I think that most folks that encounter a Linux problem will look through the topics here to see if it was already posted. Plus, you worded the topic title very clearly. :thumbup2:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users