Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

USB Device Not Recognized


  • Please log in to reply
2 replies to this topic

#1 Ahiggins

Ahiggins

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New York, USA
  • Local time:05:07 AM

Posted 25 November 2011 - 04:33 PM

Recently I had a problem with my computer seen here at this topic:
http://www.bleepingcomputer.com/forums/topic426802.html

During that time when I was having trouble with my computer, when I plugged in a USB device, a windows pop up would come up saying: "USB Device Not Recognized" I figured that it would go away when my main computer problem was resolved. When the main problem at hand was resolved, the USB issue continued, but I made do. Turns out that problem is getting worse,because just today, my USB receiver for both my mouse and keyboard stopped working.

A list of devices that don't work are as follows:
Sony 8GB Flash Drive
Logitech Universal Receiver for both mouse and keyboard plugged into an extender that's then plugged into the computer
Xbox 360 Controller for Windows

And now recently, the Logitech Universal Receiver doesn't work at all (with or without the extender)

I was wondering if anyone has had a problem like this, or if someone has a solution to the problem. I have checked and all the USB ports have power. I tried out the devices on other computers as well, and that didn't make a difference, they still come up as "not recognized". Any information would be greatly appreciated.

BC AdBot (Login to Remove)

 


#2 jhayz

jhayz

  • BC Advisor
  • 6,922 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:07 PM

Posted 26 November 2011 - 12:12 AM

Have you seen this http://www.logitech.com/en-us/349/6072?debug=0

Tekken
 


#3 Ahiggins

Ahiggins
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New York, USA
  • Local time:05:07 AM

Posted 26 November 2011 - 11:37 AM

That is the device I have that I am having this issue with.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users