Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

net adaptors stuck at acquiring network address on all networks, windows firewall and internet not working


  • Please log in to reply
2 replies to this topic

#1 Simon Jaeger

Simon Jaeger

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:01:45 PM

Posted 16 November 2011 - 03:14 AM

Hello all,
I'm running windows XP pro 32 bit with service pack 3 on an HP 8510W notebook workstation.

Last night I was hit by a rather nasty virus, from a source that still remains unknown. It hijacked the list of hosted processes running under SVCHost.exe (no it was not scvhost.exe), and caused ping.exe to repeatedly launch and flood random IP addresses with huge amounts of data. I managed to get rid of this using microsoft security essentials, but a few times before I did this, and now consistently afterward, I have no internet connection. I've tried with several different wireless networks and two different ethernet cables connected to two completely separate networks. I also have another older HP laptop on the same network, which i'm using to type this message.
The general idea of this is as follows:
All network adaptors (this being ethernet, wireless, even iPhone tethering) showing acquiring network address consistently.
0 packets showing as sent / received in any network adaptor's properties, except WiFi which shows 2 both sent and received when I first connect, then stays there.
IP and subnet both set to 0.0.0.0.
doing an ipconfig /renew produces the following: "The RPC server is unavailable."
The remote procedure call service is started when I look under services.msc.
uninstalling and reinstalling devices does nothing.
doing a system restore does nothing.
I noticed earlier that trying to start windows firewall also produced an error 10050: A socket operation encountered a dead network.
Any help with this would be very much appreciated, as this s only a borrowed laptop and is currently my only form of internet access.

Edit: I forgot to mention that running both microsoft security essentials and malwarebytes had absolutely no effect either.
Edit #2: I just tried entering the IP / subnet / default gateway info manually into the wireless connection's settings. It connects, and claims to work, but I can't actually establish a connection with anything. I can ping my own IP address 192.168.1.125, but I cannot ping google, or even the address of the laptop I'm currently writing from. And of course, loading a web browser and attempting to access these pages results in the standard error. Something major is obviously being blocked.

Edited by hamluis, 16 November 2011 - 08:22 AM.
Moved from XP to Am I Infected.


BC AdBot (Login to Remove)

 


#2 Simon Jaeger

Simon Jaeger
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:01:45 PM

Posted 16 November 2011 - 11:49 AM

An update, of sorts.
I've resolved the problem after a few hours of fruitless searching and just a little bit of productiveness.
If you recall, I posted an error about windows firewall not working. I also discovered that the TCP/IP and network location awareness services were not starting due to an error 1075. The error description was as follows: The dependency service does not exist or has been marked for deletion.
I looked in the event viewer under system, and found the following:
Event
Date: 11/16/2011 Source: Service Control Manager
Time: 8:50:00 AM Category: None
Type: Error Event ID: 7003
User: N/A
Computer:HAMSTER
Description:
The Network Location Awareness (NLA) service depends on the following
nonexistent service: Afd
For more information, see Help and Support Center at
http://go.microsoft.com/fwlink/events.asp.

Doing some research, I found that most people were able to fix their AFD service by going into device manager, clicking show hidden devices under view, finding the non plug and play devices catagory and finding AFD, then going to properties and clicking start. Sometimes it's apparently necessary to go to the driver tab and set startup to "system".
This applied to TCP/IP and a few other things as well.
I can't actually verify any of this information, because... well, AFB wasn't showing up in device manager. I looked on the second laptop just to be sure, and there it was, right at the top.
So now I knew exactly what was causing the problem, but had no idea how to fix it.
I took AFD.SYS from another laptop and copied it to c:\windows\system32\drivers, even though it already existed, just to make sure I had a clean copy. Then I started researching a fix for the fact that it didn't show up in device manager.
After several failed attempts, several useless removal tools and several successfully restrained thoughts of throwing the computer out a third story window, I finally had the bright idea of copying the registry key for the service and importing it. Thanks to online research, I knew the location of services to be HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
On the functional laptop, I opened regedit, navigated to the given section of the registry and right-clicked AFB, exporting it to AFB.reg which then went on my trusty flash drive.
From there, it was a simple matter of clicking the .reg file from the hosed computer and restarting.
It was one of those "I can't believe it worked, but it did!" moments.

I was surprised about the lack of information available on the internet. Doing a search for such things as "How to reinstall AFD service", "AFD missing from device manager", and other similarly worded terms brought up nothing entirely relevant.

Either way, I wanted to leave this here in case, by some chance, someone else has the same problem. I appear to be one of the only people to have the problem along with enough computer knowledge to fix it, so I'm assuming it's extremely rare.

#3 aerodecks

aerodecks

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:07:45 PM

Posted 19 December 2011 - 11:51 AM

Simon your a total star!!!!!!

Like you, I have the patients and determination along with a touch of geek to resolve problems like this one.
I also suffered from the same problem, although the cause of my problem was after testing AVAST FREE EDITION for a friend I uninstalled it, and bang, no connection.

My main concern was when trying to launch Firewall/ICS I was getting back Dead Network, I had 0.0.0.0 IP in a roundabout way the same as you.

I had tried all the cmd scripts supplied by geek forums, configuration settings and every possible fix and remedy you can think of.
I was told about this forum as a last resort before formatting my drive and starting again. Following your instructions (thankfully you did all the hard work) It is back up and running!!!!

Again thanks for your research and more importantly the answer.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users