Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Dv7 Display comes on but showing nothing


  • Please log in to reply
1 reply to this topic

#1 MFire2003

MFire2003

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:04:26 PM

Posted 14 November 2011 - 06:41 PM

Hi There,

I'm new to here but was hoping someone could guide me on what could possibly be the problem with my Laptop. I'll try to include as much information as possible.

I have a HP DV7-1260US 17" Laptop running Windows 7 64Bit. I took the PC apart to clean out the fan that was really dusty. I disassembled the PC using this guide: http://www.insidemylaptop.com/disassemble-hp-pavilion-dv7-notebook/

I got to step 14, and stopped. I didn't want to remove the LCD display from the laptop so I just dusted the fan from that step and re-assembled the PC. When re-assembled the PC powers on, the Fan comes on, the Hard Drive light is displayed as if everything is ok. The screen "comes on" in the sense that the backlight turns on but nothing is displayed on the screen. The screen gives a dark-blue tint when it is "on" without a display. I disassembled the PC again to check any connections and noticed that the connector for the Power Cover/Board was broken off. So I ordered a new power cover & board as well as a LCD Video Cable (i didn't have reason to think this was damaged but since it wasn't very expensive I ordered it as well just in case).
http://www.insidemylaptop.com/images/HP-Pavilion-dv7-display/remove-lcd-screen-inverter-11.jpg
http://www.insidemylaptop.com/images/HP-Pavilion-dv7/disassemble-notebook-11.jpg

The parts arrived, I replaced them both very carefully...same problem. Boots up, screen turns on, screen displays nothing.
I plugged a Monitor to the laptop via VGA and it displays the desktop fine. So the computer boots up and is properly running, the video can be displayed with a external monitor.

**Update to this issue...I purchased a inverter and replaced it...still having the same issue. Display comes on but just shows a blue hue...everything works fine if i plug in a external monitor.
This is what I recently replaced:
http://www.insidemylaptop.com/images/HP-Pavilion-dv7-display/remove-lcd-screen-inverter-07.jpg

Any ideas on what could have gone wrong or what I should attempt next?
Any help would be appreciated, thanks!

BC AdBot (Login to Remove)

 


#2 a_cup

a_cup

  • Members
  • 172 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:04:26 PM

Posted 14 November 2011 - 08:33 PM

Hi MFire2003,

Sounds like a setting on your monitor...Check the monitor source..There should be a source button for the video input ...Make sure that it is set for your monitor. It should give you a choice of VGA, DVI, or HDMI..


Pauline




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users