Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows 7 Java Problems


  • Please log in to reply
2 replies to this topic

#1 A_User

A_User

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:01:03 AM

Posted 13 November 2011 - 08:15 PM

Well, since this IS my first post here, I might as well say hello.

But onto the real purpose of this.

I decided it was about time to update java from 6 update 23 to 7. So I went ahead and went to http://jdk7.java.net/download.html, and downloaded the JDK 1.7 update 2 installer, because I like to mess around in java programming sometimes. It installed, but it didn't show up as such (java -version, etc.). So I do some research and find I need to delete prior Java versions. So I go into Control Panel>Uninstall Programs and uninstall both versions, thinking there may have been something wrong with the installation. I notice jdk1.6.0_23 shows up twice in the list, and windows can't find the installer when I try to uninstall the second one. So I decide, "Screw this, I'll just delete the folder so it will install the new version." I delete both java folders in both Program Files folders (normal & x86), and try to install again. It gives me a nice message of "This software has already been installed on your computer. Would you like to reinstall it?" I click yes, and then there is an error on how it can't find the msi file in the jdk1.6.0_23 file I deleted beforehand, and therefore it can't uninstall it. Pressing no stops the installation. So I google and find I can either mess with the registry or try JavaRa. I try JavaRa and it says it deleted some previous version files but it still doesn't work. So then I try the registry stuff here, and pretty much delete everything related to installation and java. I attempt to try the installer again, and instead of a find msi file for the jdk1.6.0_23, it says "Error 1316.A network error occurred while attempting to read from the file C:\Windows\Installer\jdk1.7.0_02.msi" And that's where I've been for the past 30 minutes.

Also, if it makes any difference, I've tried to install 1.6.0_29 and 1.7.0_01 today also, both to no avail.

So, any way this can be fixed? If you need any more info, I'll be more than happy to elaborate.

Sub-topic: My java plugin for chrome doesn't update either, and whenever there's a java applet it shows 2 yellow bar things: One to tell me "The Java plugin was blocked because it was out of date", the other to tell me "An additional plugin is required to display some elements on this page."

BC AdBot (Login to Remove)

 


#2 jhayz

jhayz

  • BC Advisor
  • 6,922 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:03 PM

Posted 13 November 2011 - 08:52 PM

Download JavaRE7u1 here http://www.oracle.com/technetwork/java/javase/downloads/jre-7u1-download-513652.html .Choose the correct type(32/x86 or 64 bit) for your system and download offline version to be installed manually.

Tekken
 


#3 A_User

A_User
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:01:03 AM

Posted 13 November 2011 - 09:09 PM

jhayz, you have just perfectly troubleshooted my problem. I thank you considerably for this. I'll have to change some environment variables, but that's easy to do.

I thank you considerably for what probably took you a minute of your time. If only there was rep on these forums...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users