Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows XP Autoplay not functioning propoerly.


  • Please log in to reply
9 replies to this topic

#1 MafiaDon

MafiaDon

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Local time:10:02 AM

Posted 12 November 2011 - 07:54 PM

Several months ago I caught the Windows Recovery Virus. It was eraticated using this site (Thanks). Since then my autoplay does not run the setup program when new CDROMs are inserted. The CDROM contents will pop up in a Explorer window. I have to manually run all installations (i.e. clicking the setup icon, etc.). I've tried TweakIU and Autofix to no avail. Autofix detected a problem with the Autorun V1 but could not fix.

BC AdBot (Login to Remove)

 


#2 -KFS

-KFS

  • Members
  • 40 posts
  • OFFLINE
  •  
  • Local time:11:02 AM

Posted 12 November 2011 - 10:57 PM

Since you recently had to deal with a horrible infection recently, and there are some Malware out there that exploits the features you seek, perhaps it's a good thing your laptop is unable to to prompt you with the auto-run option. Just a suggestion.

#3 hamluis

hamluis

    Moderator


  • Moderator
  • 56,379 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:12:02 PM

Posted 13 November 2011 - 09:55 AM

Agree with -KFS...but have you tried simply right-clicking on the drive in My Computer...clicking Properties...and setting the AutoPlay feature?

Louis

#4 AustrAlien

AustrAlien

    Inquisitor


  • Members
  • 6,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cowra NSW Australia
  • Local time:04:02 AM

Posted 13 November 2011 - 04:07 PM

have you tried simply right-clicking on the drive in My Computer...clicking Properties...and setting the AutoPlay feature?

Louis,

Your suggestion will not be of any use.

After visiting the BC Malware Removal Forum back in June, 2011, and running the suggested tools there, by default, autorun will have been disabled for security reasons (a preventative measure): That is normal. Autorun is routinely disabled to protect the user from themselves, basically. Unfortunately, users are seldom advised of this "secretive" modification.

See previous topic: http://www.bleepingcomputer.com/forums/topic401441.html

In order to enable autorun again, a registry modification would be necessary. I cannot recommend that autorun be enabled, but if requested, I will assist to restore the function.

Edited by AustrAlien, 13 November 2011 - 04:08 PM.

AustrAlien
Google is my friend. Make Google your friend too.

Posted Image

#5 hamluis

hamluis

    Moderator


  • Moderator
  • 56,379 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:12:02 PM

Posted 13 November 2011 - 05:23 PM

Thanks, AA...I was just looking at my own systems and not thinking :).

Louis

#6 MafiaDon

MafiaDon
  • Topic Starter

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Local time:10:02 AM

Posted 14 November 2011 - 12:54 PM


have you tried simply right-clicking on the drive in My Computer...clicking Properties...and setting the AutoPlay feature?

Louis,

Your suggestion will not be of any use.

After visiting the BC Malware Removal Forum back in June, 2011, and running the suggested tools there, by default, autorun will have been disabled for security reasons (a preventative measure): That is normal. Autorun is routinely disabled to protect the user from themselves, basically. Unfortunately, users are seldom advised of this "secretive" modification.

See previous topic: http://www.bleepingcomputer.com/forums/topic401441.html

In order to enable autorun again, a registry modification would be necessary. I cannot recommend that autorun be enabled, but if requested, I will assist to restore the function.


Yes, I would very much like to restore my autorun features. Thank you for responding.

#7 AustrAlien

AustrAlien

    Inquisitor


  • Members
  • 6,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cowra NSW Australia
  • Local time:04:02 AM

Posted 14 November 2011 - 04:18 PM

I would like to have a look at the relevant entries in the Windows registry.

:step1: Please export to text files, the contents of two registry keys:
  • Click Start > Run
  • Copy and paste the following line of code in the open Run box
regedit /e C:\reg1.txt "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer"
  • Now click OK
  • Click Start > Run
  • Copy and paste the following line of code in the open Run box
regedit /e C:\reg2.txt "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\policies\Explorer"
  • Now click OK

:step2: Please post the contents of the two exported registry keys for us to look at:
  • Double-click/Open My Computer and then navigate to C:\ drive
  • In there, you should see two files called reg1.txt and reg2.txt.
  • Double-click one of the files to open it with Notepad.
    • Copy and paste the whole contents of that file in your next reply.
  • Repeat with the second text file, to include the contents of that file also in the same reply.

AustrAlien
Google is my friend. Make Google your friend too.

Posted Image

#8 MafiaDon

MafiaDon
  • Topic Starter

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Local time:10:02 AM

Posted 14 November 2011 - 09:44 PM

Hi there.

Thank you for helping me, again.

Here are the logs you requested:

reg1:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer]
"HonorAutoRunSetting"=dword:00000001
"NoDriveAutoRun"=dword:03fffff7
"NoDriveTypeAutoRun"=dword:00000091
"NoDrives"=dword:00000000

reg2:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\policies\Explorer]
"NoDriveTypeAutoRun"=dword:00000091
"NoDriveAutoRun"=dword:03ffffe7
"NoDrives"=dword:00000000

#9 AustrAlien

AustrAlien

    Inquisitor


  • Members
  • 6,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cowra NSW Australia
  • Local time:04:02 AM

Posted 16 November 2011 - 01:14 AM

The registry values currently disabling autorun are the following:
  • [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer]
    "NoDriveAutoRun"=dword:03fffff7

    and
  • [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\policies\Explorer]
    "NoDriveAutoRun"=dword:03ffffe7

    ...... although the entry in [HKEY_LOCAL_MACHINE\ is the controlling one of the two (such that the entry in [HKEY_CURRENT_USER\ not being used at all).

There are two registry values that can be used to persistently disable AutoRun: NoDriveAutoRun and NoDriveTypeAutoRun. The first value disables AutoRun for specified drive letters and the second disables AutoRun for a class of drives. If either of these values is set to disable AutoRun for a particular device, it will be disabled.

Source: Enabling and Disabling AutoRun

With the setting that you currently have controlling which devices (drives/drive letters) are allowed to autorun, namely:
  • [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer]
    "NoDriveAutoRun"=dword:03fffff7 (67108855) + 8 (8:D) = 67108863

    autorun is disabled on all drives except drive D:

To satisfy my curiosity, please tell me which of your drives is assigned the letter D on your system (CD/DVD, hard drive ?).


------

It is not necessary to have these entries in your registry at all, so I suggest that we delete them by doing the following:

Please open Notepad and paste the contents of the code box below into the open window of a new text file.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer]
"NoDriveAutoRun"=-

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\policies\Explorer]
"NoDriveAutoRun"=-

  • Make sure there are NO blank lines before "Windows Registry Editor Version 5.00"
  • Make sure there IS one blank line at the end of the file.
In the main menu of Notepad go to File > Save
  • In the "Save as type" box, choose "All files"
  • Enter the file name as delete.reg
  • Choose your desktop as the "Save in" location
  • Click on "Save".
Close the Notepad window.

On your desktop, locate the file that you just created, delete.reg.
Double-click on the file.
When prompted "Are you sure ... ", click "Yes".

Restart the computer normally to ensure that the changes are made. <<< Important
When you now insert a CD or DVD with autorun capability, it should run.

*** Please be aware that having autorun enabled is now considered a security risk, and is discouraged.
If in any doubt about the disk that you are inserting, you can disable autorun by holding down the <SHIFT> key while inserting the disk, and continuing to hold it down until the optical drive has stopped attempting to read the disk.
AustrAlien
Google is my friend. Make Google your friend too.

Posted Image

#10 hamluis

hamluis

    Moderator


  • Moderator
  • 56,379 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:12:02 PM

Posted 16 November 2011 - 08:13 AM

Admin note: Before attempting any registry edit, no matter how routine...users should always backup the registry as a first step. A good tool for such is ERUNT Registry Backup Tool - http://www.snapfiles.com/get/erunt.html .

Louis




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users