Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

new computer won't connect to internet


  • Please log in to reply
7 replies to this topic

#1 gib65

gib65

  • Members
  • 161 posts
  • OFFLINE
  •  
  • Local time:04:18 PM

Posted 10 November 2011 - 01:16 PM

Hello,

I'm setting up a new computer and I'm having trouble getting it connected to the internet. It's an Acer (model: Aspire M3910) running Windows 7. I have it plugged into a jack that I know works (other computers can connect on it), but when I type in ipconfig, I get this:

C:\Users\amy delvecchio>ipconfig

Windows IP Configuration


Wireless LAN adapter Wireless Network Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::883d:7932:a7fb:8029%9
   IPv4 Address. . . . . . . . . . . : 192.168.1.114
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1

Tunnel adapter isatap.{A4759F59-5120-4578-ADFA-93C67480E4F5}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter isatap.{F118797A-7FB8-48E4-B6F4-6C641CC22348}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter Teredo Tunneling Pseudo-Interface:

   Connection-specific DNS Suffix  . :
   IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:3c57:336e:3959:d50a
   Link-local IPv6 Address . . . . . : fe80::3c57:336e:3959:d50a%13
   Default Gateway . . . . . . . . . : ::

C:\Users\amy delvecchio>

Releasing and renewing doesn't work.

Any ideas?

BC AdBot (Login to Remove)

 


#2 computerxpds

computerxpds

    Bleepin' Comp


  • Moderator
  • 4,468 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:04:18 PM

Posted 10 November 2011 - 01:23 PM

Well according to ipconfig you are connected and have a valid ip. Are you not able to load a webpage? We need a bit more info. :)

sigcomp.png 
If I have replied to a topic and you reply and I haven't gotten back to you within 48 hours (2 days) then send me a P.M.
Some important links: BC Forum Rules | Misplaced Malware Logs | BC Tutorials | BC Downloads |
Follow BleepingComputer on: Facebook! | Twitter! | Google+| Come join us on the BleepingComputer Live Chat too! |


#3 Andrew

Andrew

    Bleepin' Night Watchman


  • Moderator
  • 8,257 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Right behind you
  • Local time:01:18 PM

Posted 10 November 2011 - 03:34 PM

Try visiting http://74.125.224.80 in your web browser. That's (one of) the IP addresses for Google.com. If you get to Google's home page by entering the IP, but can't get there by entering google.com then the problem likely is with your DNS settings. If visiting the IP address doesn't work, however, then something else is wrong. Do you have a firewall or other security software running? Try temporarily disabling them.

You might also try having Windows try to diagnose and repair the connection. The connection troubleshooter can be launched from the Network and Sharing Center (click on the "Internet" Globe or on any red X's shown on the network map.)

Edited by Andrew, 10 November 2011 - 03:38 PM.


#4 gib65

gib65
  • Topic Starter

  • Members
  • 161 posts
  • OFFLINE
  •  
  • Local time:04:18 PM

Posted 10 November 2011 - 06:11 PM

That must be my problem. I cannot connect to google through the usual route but clicking on that IP address gets me there.

What would I look for in my DNS settings?

#5 Andrew

Andrew

    Bleepin' Night Watchman


  • Moderator
  • 8,257 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Right behind you
  • Local time:01:18 PM

Posted 10 November 2011 - 06:34 PM

There are any number of DNS servers you can set your computer to use. I use Google's public DNS service. Here's a How-To on changing your DNS settings to use Google's servers.

Your ISP probably also has its own DNS service. If you prefer to use that, you would need to contact their support department to find out the IP addresses of their servers. You can follow the above guide to change to your ISP's servers simply by substituting Google's IP addresses for your ISP's.

Edited by Andrew, 10 November 2011 - 06:35 PM.


#6 gib65

gib65
  • Topic Starter

  • Members
  • 161 posts
  • OFFLINE
  •  
  • Local time:04:18 PM

Posted 14 November 2011 - 04:40 PM

Sorry I haven't replied in a while.

I've narrowed the problem down to a bad hosts file. Problem is I can't delete it. It seems to be hidden even when I specify in the folder settings to show hidden files. The erase and rename commands in a DOS prompt can't find it. But I know it's there because if I type in at the start menu "Notepad C:\windows\system32\drivers\etc\hosts" it opens up. Unfortunately it won't let me save it after changing the contents, so I'm still stuck.

#7 Andrew

Andrew

    Bleepin' Night Watchman


  • Moderator
  • 8,257 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Right behind you
  • Local time:01:18 PM

Posted 14 November 2011 - 08:39 PM

It's probably set as "Read Only"

#8 gib65

gib65
  • Topic Starter

  • Members
  • 161 posts
  • OFFLINE
  •  
  • Local time:04:18 PM

Posted 18 November 2011 - 01:42 PM

Again, I apologize for not responding in a while, but I'm happy to report I've solved the problem:

I figured out how to make the hosts file visible: In any folder, go to organize > folder and search options > view tab > unselect "hide protected operating system files".

Then it was a simple matter of opening the properties of the hosts file and changing the permission and ownership settings.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users