Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Graphics Card Not Showing Up


  • Please log in to reply
1 reply to this topic

#1 Cartoon Shark

Cartoon Shark

  • Members
  • 89 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:04:33 PM

Posted 05 November 2011 - 10:16 PM

Hello. I need help as soon as possible!

I just recently installed a new graphics card, a Radeon HD 4670 HIS IceQ card. I have tried to run games, however, they either do not run or state I do not have the updated drivers. I have installed the most recent drivers for it off of the AMD website, but to no avail. I have display, yet Speccy is displaying no information about my card at all. I need help as soon as possible to solve this! Do I not have the right drivers? Did I not install it properly?

Thank you for any help.

Edit: The fan on the card is running, and since I have display, the card is most certainly working. I believe I just have the wrong drivers. I need help trying to find the right drivers. I thought I had the right ones, but by the looks of it, I guess I don't.

Edited by Cartoon Shark, 05 November 2011 - 10:23 PM.


BC AdBot (Login to Remove)

 


#2 DJBPace07

DJBPace07

  • BC Advisor
  • 4,869 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:33 PM

Posted 05 November 2011 - 11:13 PM

Did you delete the old drivers before installing the new ones? With AMD cards, the old drivers must be removed before you install the new ones and your PC must be restarted after you uninstall the old drivers. Did you download the Catalyst 11.10 drivers and what games are you trying to play?

Edited by DJBPace07, 05 November 2011 - 11:14 PM.

3939.png

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users