Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Continuous 'Acquiring Network Address'

  • Please log in to reply
1 reply to this topic

#1 lfchockey


  • Members
  • 1 posts
  • Local time:04:32 AM

Posted 31 October 2011 - 07:27 AM

Unending Acquiring Network Address: Please Help!
I’ve been trying to fix this problem for the past week+ but to no avail. I’ve scoured the Internet and find many things that seem logical but nothing works.

Basically, I’m pretty sure that I acquired a virus/Trojan(s) somewhere along the way (Security Sphere?) and it totally messed with everything. I’m relatively confident it’s gone but not 100% sure (It wouldn’t allow me to run antivirus software and would crash it after a few minutes. Then, the next time I tried to run the software I would get a message “Windows cannot access the specified device, path or file. You may not have appropriate permissions to access them”. I’m signed in as an admin so I’m guessing the problem is that the registry keys have been messed with.

I was able to download some more antivirus software and transfer them to this laptop and did a complete scan and a couple of flaws (Trojans) were found so I’m hoping that was the end of them.

I tried doing a restore to a previous point, but no restore works unless I manually create one (I think the virus messed with the registry). Obviously the problem with that is that if I create one now, it reverts back to a time where the problem is still existent.

Some things I’ve noticed and tried:
1. In my Security Center, my Firewall is not on. I’m pretty sure it was on previously before getting the virus, I turned it off when I was having problems connecting to the Internet thinking that may be the problem and now I can’t get in to turn it back on again. When I click the “Enable” button, I get the message “We’re sorry. The Security Center could not turn on Windows Firewall… do it through the Control Panel”. The Control Panel gives me the error message “Windows Firewall settings cannot be displayed because the associated service is not running. Do you want to start the Windows Firewall/Internet Connection Sharing (ICS) Service?” and when I click “yes” eventually an error message says “Windows cannot start the Windows (ICS) service.”

2. For quite some time my Wireless Network Connection was ‘finding’ previous wireless networks and was able to connect to them but would stall out and get stuck on ‘acquiring network address’. If I went in to view the wireless networks in the area none would pop up even though it had already connected to different ones at different times (ones that I had previously had successful connections on). I tried re-installing all drivers for the PCI modem (which in the Device Manager was listed as ‘Unknown Device’ and the network adapters but this didn’t help. [Update: I re-installed the driver for my modem and now I’m back at the acquiring network address part. I have ‘Very Good Signal Strength’ and I'm logged in. I can also view the networks within range and can successfully log in to any I have a password for]

3. When I go into my “Services” many of my Local services that are supposed to start automatically aren’t doing so. I’m really focussed on the Internet connection. I’ve narrowed it down (I think???) to the IPSec because many of the Services not running are dependent upon IPSec or its driver. When trying to start manually I get an “Error 10050: A socket operation encountered a dead network.” This message was being displayed even though I am connected and logged into the network. (Services that do work: Wireless Zero Configuration, DNS Client, Network Connections, Remote Access Connection Manager, Remote Procedure Call)(Services that do NOT work: IPSEC, DHCP Client, Net Logon, TCP/IP NetBIOS Helper, Routing and Remote Access(Disabled))

4. I’ve tried downloading Winsockfix but that didn’t help.

5. Many of the programs(antivirus software – MBAM, Avast, HijackThis, SuperAntispyware) that initially had problems because of the virus ran fine for awhile and now inexplicably stopped running (this may have been because of a system restore although it was restored to a few minutes earlier???). I downloaded Avast again just recently and did another sweep thinking that it’s possible the original malware was never properly removed but came up with nothing. I also downloaded MBAM and have done several sweeps and found a trojan later but it should be gone by now.

6. I tried re-installing the Service Pack 3 for XP but it crashed my system and I had to do a restore.

7. I tried SFC/ Scannow but that didn't help and didn't give me any errors

8. I tried installing optional components from my Windows XP Pro Installation CDs in terms of Networking but nothing fixed or changed in that respect either.

9. I tried Reset WINSOCK entries to installation defaults: netsh winsock reset catalog
Reset TCP/IP stack to installation defaults. netsh int ip reset reset.log

10. I've downloaded registry repair tools, 10050 error fix

I’m kind of at wits end figuring this out. I feel fairly confident the malware is gone but who knows.
Basically I’m just mostly focussed with getting the Internet up and running again!

Here is the ipconfig/all:

Windows IP Configuration

Host Name . . . . . . . . . . . . : blackhome
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Wireless Network Connection 3:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Dell Wireless 1370 WLAN Mini-PCI Card
Physical Address. . . . . . . . . : 00-14-A4-41-A1-CD
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . :
Subnet Mask . . . . . . . . . . . :
Default Gateway . . . . . . . . . :
DHCP Server . . . . . . . . . . . :

Ethernet adapter Local Area Connection 3:

Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : Broadcom NetXtreme 57xx Gigabit Controller
Physical Address. . . . . . . . . : 00-14-22-E3-58-BD

I am in Canada. I’m connected to various networks wirelessly throughout the day, and I know that each one has other computers connected without a problem and they all use different routers and I’ve never had a problem before.
I know my wireless is on and working because I’m getting a signal.

As you can see my Ethernet adapter is not connected but I don’t feel that is a problem considering I’m never hardwired into a network??? When I am hard-wired, I'm able to connect and log in to a network but I get stuck on the 'acquiring network address' problem again

I’m also using Windows XP SP3

To Summarize: I've tried just about everything I can think of or found on the Internet. I feel my last two options are doing a Repair Install or potentially running ComboFix

Any help from anybody at this point would be infinitely appreciated!
I feel I'm at the point of just purchasing another computer because my business depends on it and I've already been without for over a week.

BC AdBot (Login to Remove)


#2 techextreme


    Bleepin Tech

  • Members
  • 2,125 posts
  • Gender:Male
  • Location:Pittsburgh, PA
  • Local time:05:32 AM

Posted 01 November 2011 - 01:36 PM

Hi ifchockey,

Can you tell me what error comes up when you try to manually start the DHCP Client service?

"Admire those who attempt great things, even though they fail."

-- Seneca

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users