Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

HP Photosmart printer has disabled all my USB ports!


  • Please log in to reply
3 replies to this topic

#1 cmh123

cmh123

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:02:34 AM

Posted 30 October 2011 - 11:23 AM

Hi, I recently bought and installed a HP photosmart B109a printer/scanner, which has been working fine. The problem is now when I plug in any other device to my USB ports I get a 'USB device not recognized' message.

This happens when I plug in my digital camera, web cam, and a USB memory stick.

It's definitely the new HP printer that has disabled the USB ports from working, because all worked well before installing the printer - and I have disconnected the HP printer and uninstalled all it's software and now the other USB devices work normally.

I have looked on the HP web site but can't find any info about this. I tried unplugging the computer from the mains to reboot the motherboard, as I read some articles on the web that said this might reinstall the USB device drivers and fix the problem, but it had no effect.

So at the moment I have uninstalled the printer and my other USB devices work fine, but I have no printer! How can I get the photosmart printer to install without disabling my other USB ports? (I'm using windows XP SP3)

Thanks very much for any help :)

Edited by cmh123, 30 October 2011 - 11:26 AM.


BC AdBot (Login to Remove)

 


#2 Eyesee

Eyesee

    Bleepin Teck Shop


  • BC Advisor
  • 3,540 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:In the middle of Kansas
  • Local time:09:34 PM

Posted 30 October 2011 - 11:54 AM

Just for the heck of it, have you tried another USB cable on the printer?
Thats about the only thing I can think of to try.
In the beginning there was the command line.

#3 hamluis

hamluis

    Moderator


  • Moderator
  • 55,398 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:09:34 PM

Posted 31 October 2011 - 12:21 PM

Well...it could be a bad USB port causing the problems, if you haven't tried the printer in all the ports.

In any case, I would uninstall the current USB controllers...reboot...and allow them to reinstall. This is how to reinstall the USB drivers.

Louis

#4 cmh123

cmh123
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:02:34 AM

Posted 14 November 2011 - 09:42 AM

Hi, thanks very much for your replies. I tried reinstalling the printer with a new USB cable and it worked! All the USB ports are working as normal now :)

Thanks! :thumbsup:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users