Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

None Of My Dvd/cd-rom Devices Will Work Correctly


  • Please log in to reply
4 replies to this topic

#1 Robertico

Robertico

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:02:49 PM

Posted 27 January 2006 - 06:13 AM

I was trying to solve a problem with a system tray icon disappearing. I checked 4 different forums and they said a fix could be made by stopping SSDP Discovery Service and Universal Plug and Play Service. I stopped those services and logged out and logged back in. Now all of my drives, the TDK cd burner, my Memorex DVD burner, and my AOpen DVD player all have the yellow diamond with the exclamation mark.
I can't get the drives to work, so I can't use my cds to upgrade the drivers. I've tried downloading the drivers from the websites and they don't recognize the drives being there on the computer. I have absolutely no idea what I can do. I've restarted my SSDP and UPnP services and made them automatic, unplugged and replugged my drives (turned off the computer and plugged them in after restarting), and still have the same problems.
Whenever I try scanning for hardware changes, the screen will go black and come back, then it tells me that it has not found any hardware changes. Regardless of the fact that my TDK 16/10/40x internal CD burner, AOpen 16x DVD player, and Memorex external DVD 16x burner (usb) all won't work.
Also whenever I uninstall and reinstall the drives, the screen will go black again.

I'm using Windows XP Professional 2002 with SP 2, AMD Athlon XP 1500+ 1.3 GHz, 512 mb of RAM, the devices that don't work exactly read as, AOPEN16XDVD-ROM/AMH, Memorex DVD 16+/-DL 4RW|D2 USB device, and TDK CDRW161040X.


Please help! I've been trying to fix this for almost a week now!

BC AdBot (Login to Remove)

 


m

#2 tg1911

tg1911

    Lord Spam Magnet


  • Members
  • 19,274 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:SW Louisiana
  • Local time:04:49 PM

Posted 27 January 2006 - 11:12 AM

When you say, "whenever I uninstall and reinstall the drives", did you just unplug, then re-plug the drives?
Or did you go into the Devive Manager, uninstall it there, then reboot (not restart)?
MOBO: GIGABYTE GA-MA790X-UD4P, CPU: Phenom II X4 955 Deneb BE, HS/F: CoolerMaster V8, RAM: 2 x 1G Kingston HyperX DDR2 800, VGA: ECS GeForce Black GTX 560, PSU: Antec TruePower Modular 750W, Soundcard: Asus Xonar D1, Case: CoolerMaster COSMOS 1000, Storage: Internal - 2 x Seagate 250GB SATA, 2 x WD 1TB SATA; External - Seagate 500GB USB, WD 640GB eSATA, 3 x WD 1TB eSATA

Become a BleepingComputer fan: Facebook

#3 Robertico

Robertico
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:02:49 PM

Posted 27 January 2006 - 05:05 PM

I uninstalled and reinstalled the drives, I unplugged and replugged the drives (turned the computer off and unplugged all of them and started the computer up and then turned it off and plugged them in and then turned the computer on) and still have the same problem.

I get error code 39, the driver is either missing or corrupted.

By the way, what do you mean by uninstalling the drive and rebooting?...

Also, my AOpen drive is at location 1(1) and says the manufacturer is (Standard CD-ROM drive), my Memorex external DVD burner says it's at location 0 and manufacturer is (Standard CD-ROM drives), and my TDK internal cd burner says it's at location 0(0) and manufacturer is (Standard CD-ROM drive). I do realize now that the manufacturer data is incorrect. I can't get my drives to update though, the firmware won't say that the drive is there. What can I do?

I can also just re-install windows on my C:\ drive to fix it, but I have a slave drive with most of my games, movies, music, ect. Would I have to reformat it to get it to work with my newly formatted C:\ drive? I don't want to delete anything on my F:\ drive. So if I have to reformat my slave drive for it to work with my primary drive after it's formatted, I don't want to use that fix.

Edited by Robertico, 27 January 2006 - 07:42 PM.


#4 ThorXP

ThorXP

  • Banned
  • 880 posts
  • OFFLINE
  •  
  • Local time:06:49 PM

Posted 30 January 2006 - 08:50 AM

Hello, First of all here is a quote from the first post in this series:

I checked 4 different forums and they said a fix could be made by stopping SSDP Discovery Service and Universal Plug and Play Service.

From reading thru all of the posts on this series apparently this person is a novice (nothing against a novice) and to teach this person what it is going to take to fix his system thru this forum is going to be a very large task. One thing is if you are going to get your computer fixed it is bad to forum jump to help you fix your computer we here do not know what the other forums are telling you to do and I am sure this lack of knowing what is going on else where will eventually hurt your computer, and we here do not want to hurt your computer just to help you fix it.

I would suggest that having someone that is knowledable with computers look at it whether it is a computer repairperson, a member of a computer user group (Ask how long they have been doing computers), but none the less it has to be someone who can look at the system.

I will try to give you directions on how to uninstall your drives and re-install them.

We will assume that the drives are still in the same position and the drive select switches have not been moved. If this is not the case - take your computer to someone to have it serviced.

1st - Go to Control Panel then Open System - then open Hardware tab - then open Device Manager - then find DVD\CD-ROM drives and double click on it. This will open it up and show the two lines for the drives in your system.

Now on each drive you do the following: Right click with the mouse and you get a context box that will have Uninstall in it. = Left click on uninstall and answer yes to the prompt.

Do the same thing to the other drive and when finished click Ok to exit out of this window and then exit out to the desktop.

Now to reinstall the drivers for the drives all you have to do is REBOOT your computer and let it do its thing. If after it reboots it tells you to reboot again please do so.

This should fix the drives.

If you think this is a bit difficult please have some one else help.

#5 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,073 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:05:49 PM

Posted 30 January 2006 - 10:06 AM

Hi Robertico!

I agree with ThorXP - Please try to keep all the issues in the same place. It's essential in order to troubleshoot things. Often the most seemingly insignificant thing can lead to a fix.

Also, please follow the instructions that he wrote on how to uninstall and reinstall your drives.

Finally, could you let us know what make and model your motherboard is? And, if you've installed the latest version of the chipset/motherboard drivers (and if so, which ones?)?
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users