Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

windows xp system slow shutdown


  • Please log in to reply
2 replies to this topic

#1 Paul Gray

Paul Gray

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:08:45 PM

Posted 13 October 2011 - 12:01 PM

Windows XP sp3 is taking a very long time to shutdown, I have turned off Automatic Updates and that speed it up a bit and i have set the HungAppTimeout to 1000. Startup seems not to bad.

BC AdBot (Login to Remove)

 


#2 Allan

Allan

  • BC Advisor
  • 8,602 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:08:45 PM

Posted 13 October 2011 - 12:13 PM

Here are some steps you can take to try to speed up Windows Shutdown. Before editing the registry, be sure to either create an image of your system partition or backup the registry. If you don't know how, please ask.

1) Make sure "clear pagefile at shutdown" is not enabled:
start - run - regedit
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]

Set ClearPageFileAtShutdown value to 0


2) Start - Run - Regedit
Navigate to the following Registry key:
HKEY CURRENT USER\Control Panel\Desktop
Double click on the AutoEndTasks entry and replace the 0 with a 1 in the Value data text box

For the next two, if the dword value indicated does not exist, create it:

Double click on the WaitToKillAppTimeout entry in the right pane and change the Value data to 2000

Double click on the HungAppTimeout entry in the right pane and change the Value data to 1000

Reboot

3) HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
Right-click on WaitToKillServiceTimeout and change it to 2000


If none of that helps, try a selective startup:

Open msconfig and on the General tab choose "selective startup" (uncheck all three items) and reboot. Does the problem still occur? If not, start adding items back to msconfig one or two at a time, rebooting after each change, until the problem reappears and you'll have identified the offending process. This is clearly a time consuming procedure, but it is the best way to determine if some process loading with the system is the cause of your problem.
After you've isolated the cause, do not use msconfig to permanently disable the process. Instead, if it is a service go to START - RUN and type: services.msc (then press enter) and disable the service OR, if it a program, you can download & run a simple app such as Mike Lin's Startup Control Panel (http://www.mlin.net/StartupCPL.shtml) to enable, disable, or otherwise manage startup programs.

#3 Paul Gray

Paul Gray
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:08:45 PM

Posted 13 October 2011 - 01:14 PM

Thanks, I already did the first part as i did research on the internet.
So I am in the process of doing what you suggest next,
However under Selectivie startup there are 4 boxes to uncheck
Process SYSTEM.INI File
Process WIN.INI File
Load Systsem Services
Load Startup Items
And you requested that I uncheck the first 3, is that correct and then reboot and see if the problem occurs under which section. Is that correct, I feel that I am missing something
Thanks
Paul




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users