Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Security Warning 2


  • Please log in to reply
6 replies to this topic

#1 T_Belden

T_Belden

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:04:25 AM

Posted 06 October 2011 - 02:12 AM

Good Morning to everyone!!

For the past 2 weeks I've had a Security Warning window pop up when going to different web-sites and I would like to know how the heck to get rid of it. The exact words in the box are these

Security Warning

Do you want to view only the webpage content that was delivered securely? This webpage contains content that will not be delivered using a secure HTTPS connection which could compromise the security on the entire webpage.

Then I'm suppose to check "yes" or "no" ... Ever since this warning box has poped up I have had nothing but problems getting to webpages I look at every single day ... I am running SUPER antiSpyware and Advast Antivirus ... I also run CCleaner once a day ... I have cleaned out everything and this security window still pops up and prevents me to see web pages I've always been able to see clearly before. Any suggestions? Thanks so very much for all your time, Jodi




I'm having exactly the same problem. Ever since installing the August or September Microsoft updates. The blasted "Security Warning" box keeps popping up on pages where it never popped up before, and I've got "Display mixed content" set to Enable in both the Internet Zone and the Trusted Zone.

Control Panel --> Add Remove Programs shows that the latest update to Windows Internet Explorer 8 was KB2559049 installed on 8/11/2011.

It looks like my next logical step would be to uninstall that update, or uninstall and reinstall MSIE completely.

Anyone have a better/alternative suggestion?

TIA,
T. Belden

Edited by hamluis, 06 October 2011 - 08:19 AM.
Split from different topic, PM sent new OP.


BC AdBot (Login to Remove)

 


#2 bludgard

bludgard

  • Members
  • 934 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:No Clue Whatsoever, Western Hemishere
  • Local time:05:25 AM

Posted 06 October 2011 - 08:43 PM

The blasted "Security Warning" box keeps popping up on pages where it never popped up before....

TIA,
T. Belden


Hi, T_Belden.

Can you post a screenshot of these pop-ups?

Edited by bludgard, 06 October 2011 - 08:44 PM.


#3 T_Belden

T_Belden
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:04:25 AM

Posted 07 October 2011 - 04:40 AM

Can you post a screenshot of these pop-ups?


Posted Image

I'm running Internet Explorer 8 on WindowsXP. This security warning pops up right in the center of the screen, where I would expect it to be. I clicked on the title bar of the main browser window while the security warning was on the screen (to make sure the warning wasn't a disguised popup window sitting on top of my Internet Explorer window) and as expected I couldn't switch from the warning to the main browser window, so this certainly seems to be part of Internet Explorer.

After satisfying myself that the warning was legit, I clicked on the More Info button, and it opened the Windows Help System at this section:

Understanding Security and Privacy on the Internet-->How do I know if an online transaction is secure?-->What does it mean when I have both secure and non-secure (mixed) content?

The warning seems to pop up on every secure (https) website and every time I move to a different page within a secure website or refresh a page. It doesn't pop up on normal (http) webpages. It doesn't pop up when I use Google Chrome to visit secure websites. Also the thread I quoted in my original post shows that other people were having this same problem in January 2011.

In addition to installing the current Microsoft "Patch Tuesday" updates and the MSIE update I mentioned in my original post, I've also recently updated MSIE's Adobe Flash plugin, installed Google's Chrome browser, and installed Java (which Chrome wanted). I suppose any of those could have changed a registry setting and caused this problem as a side effect....

Any suggestions will be appreciated.

T. Belden

#4 T_Belden

T_Belden
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:04:25 AM

Posted 07 October 2011 - 04:46 AM

Addendum to my post:

I checked my security settings and "Display Mixed Content" is set to Enable in both the Internet Zone and the Trusted Zone.

#5 bludgard

bludgard

  • Members
  • 934 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:No Clue Whatsoever, Western Hemishere
  • Local time:05:25 AM

Posted 08 October 2011 - 11:53 PM

The pop-ups are a warning that there is non-secure content on the page that is currently loading. As is stated in the message, the non-secure content can render the secure webpage insecure.
If you want to disable this warning message (and probably all other warnings in IE), do the following:
Start > Run > type gpedit.msc >
Local Computer Policy
Computer Configuration
Administrative Templates
Windows Components
Internet Explorer
Double-click on Turn off the Security Settings Check
Dot Enable
Apply
OK.
Close gpedit.

A word of warning: If this policy edit is enforced, browsing risky sites may be more risky.
Let us know how you get on....

#6 T_Belden

T_Belden
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:04:25 AM

Posted 13 November 2011 - 11:49 PM

--- SOLUTION FOUND ----
My problem with a "Mixed Content" security warning popping up on every HTTPS:// webpage was being caused by Kaspersky Internet Security 2012, which I recently installed. Kaspersky's Safe Surf feature puts a small K next to every URL it finds on a webpage; Green for known safe, Red for known malicious, and Grey for "not in our database". Internet explorer sees these K's as coming from a non-secure website and pops up the mixed-content warning. The simplist solution is to reset Safe Surf to only check URLs listed in search results. This lets Safe Surf work in the place you need it most, but keeps it quiet on HTTPS:// pages. This isn't a perfect solution since it requires partially disabling Safe Surf, but it is good enough untill I can find a more elegant one. The link below shows where the setting I'm reffering to is located:

http://i1110.photobucket.com/albums/h451/Bobwhite_Club/PostedImages/KasperskyCure.jpg

Since the poster I quoted in my original post on this subject was having this problem while running a different antivirus program, it's probably something that can happen with a number of different products, and the solution will probably be similar for those products. If nothing else, this thread will give anyone else who experiences this problem a place to start and food for thought.

Note to bludgard: I chose not to disable my security settings, but your advice was still useful to me. It led me a gpedit.msc setting that eliminates the search box that Microsoft stuck in the top right corner of Internet Explorer 8. I've always hated that thing and refused to use it. So now, thanks to you, it is no longer wasting screen space and MSIE's address box goes all the way across the screen as it should. :-)

T_Belden

#7 bludgard

bludgard

  • Members
  • 934 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:No Clue Whatsoever, Western Hemishere
  • Local time:05:25 AM

Posted 14 November 2011 - 12:11 AM

... the search box ... in the top right corner of Internet Explorer 8. I've always hated that thing and refused to use it.

Me too! :o

I've always wondered how to get rid of that eyesore in IE8. Thanks for the update and the tip. :thumbup2:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users