Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows will not set an internal IP


  • Please log in to reply
31 replies to this topic

#1 ryladine

ryladine

  • Members
  • 58 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:45 AM

Posted 05 October 2011 - 08:35 PM

Windows is failing to set my internal IP, I have disabled my AV entirely (process and services included), I have ensured all settings are correct, I am certain I am modifying the correct device, I have removed or disabled all other networks, and network devices. I have used ipconfig /release and /renew both more than 30 times now, and have tried unplugging, and re-connecting my network adapter multiple times. I have ran several netsh commands based on the suggestions of others, and have disabled/restarted my DHCP service manually.

Basically windows is ignoring the fact that it is set entirely.

Here is my ipconfig/all
Windows IP Configuration

   Host Name . . . . . . . . . . . . : Ryladine-PC
   Primary Dns Suffix  . . . . . . . : 
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : Belkin

Wireless LAN adapter Wireless Network Connection 2:

   Connection-specific DNS Suffix  . : Belkin
   Description . . . . . . . . . . . : RangeMax Dual Band Wireless-N USB Adapter
   Physical Address. . . . . . . . . : 00-22-3F-90-97-8C
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::6c4e:463a:c3d6:8145%20(Preferred) 
   IPv4 Address. . . . . . . . . . . : 192.168.2.3(Preferred) 
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Wednesday, October 05, 2011 9:03:01 PM
   Lease Expires . . . . . . . . . . : Sunday, November 12, 2147 3:57:13 AM
   Default Gateway . . . . . . . . . : 192.168.2.1
   DHCP Server . . . . . . . . . . . : 192.168.2.1
   DHCPv6 IAID . . . . . . . . . . . : 436216383
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-15-9A-F3-E3-E0-CB-4E-BA-4F-F1
   DNS Servers . . . . . . . . . . . : 192.168.2.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.Belkin:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : 
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter 6TO4 Adapter:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : 
   Description . . . . . . . . . . . : Microsoft 6to4 Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

And here is proof that windows is set correctly.

http://s596.photobucket.com/albums/tt44/ryladine/?action=view&current=ip.png



YES that is the DNS I use, and I won't take any complaining about it! It works better than what my ISP had me using.

Edited by hamluis, 11 October 2011 - 11:19 AM.
Moved from Win 7 to Networking.

"Ignorance is not stupidity, refusing to correct it is. Stupidity should be a crime punishable by death." A soon to be famous quote by: Ryladine

Most scientist's think that man is the dominant species on earth, I know the truth, its not man that is the dominant species, its cats.

BC AdBot (Login to Remove)

 


#2 noknojon

noknojon

  • Banned
  • 10,871 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:05:45 PM

Posted 06 October 2011 - 02:29 AM

Windows is failing to set my internal IP - - -
YES that is the DNS I use, and I won't take any complaining about it! It works better than what my ISP had me using.

Well, if it is not working ? ?, and you refuse to use the settings from your ISP ? ?, then there is a chance your ISP is correct - :mellow:

Are you asking us to find a way to "Hot up" (to use mechanics terms) your system, so that it performs better than your "normal" ISP settings -

Sometimes your ISP knows what works with their servers - - -

#3 ryladine

ryladine
  • Topic Starter

  • Members
  • 58 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:45 AM

Posted 06 October 2011 - 02:31 AM

Windows is failing to set my internal IP - - -
YES that is the DNS I use, and I won't take any complaining about it! It works better than what my ISP had me using.

Well, if it is not working ? ?, and you refuse to use the settings from your ISP ? ?, then there is a chance your ISP is correct - :mellow:

Are you asking us to find a way to "Hot up" (to use mechanics terms) your system, so that it performs better than your "normal" ISP settings -

Sometimes your ISP knows what works with their servers - - -

Did you not read the post at all?
The DNS doesn't matter so long as it's valid, and it is.
My entire problem is that windows WILL NOT use the settings for a static internal IP that I have set.
"Ignorance is not stupidity, refusing to correct it is. Stupidity should be a crime punishable by death." A soon to be famous quote by: Ryladine

Most scientist's think that man is the dominant species on earth, I know the truth, its not man that is the dominant species, its cats.

#4 hamluis

hamluis

    Moderator


  • Moderator
  • 55,398 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:02:45 AM

Posted 07 October 2011 - 09:12 AM

I'm somewhat confused.

Your ISP told you to enable DHCP...yet you want to set a static IP address. Is that correct?

Info

Louis

#5 ryladine

ryladine
  • Topic Starter

  • Members
  • 58 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:45 AM

Posted 07 October 2011 - 09:17 AM

I'm somewhat confused.

Your ISP told you to enable DHCP...yet you want to set a static IP address. Is that correct?

Info

Louis


Again. No.
I'm trying to set an internal IP. You know, the only kind you can set through windows?
And again. No, my ISP has never told me to enable DHCP.

Let me clarify this for EVERYONE who reads the thread.

I am attempting to set a static INTERNAL IP because I run servers from my computer. Windows WILL NOT use the settings I have set though it accepts them just fine, windows also removes the settings when I restart.

Yes. I know both windows, and my router are capable of it, both because I have another machine set static right now, and because this one, on this EXACT OS has been set to a static INTERNAL IP before.

Edited by ryladine, 07 October 2011 - 09:19 AM.

"Ignorance is not stupidity, refusing to correct it is. Stupidity should be a crime punishable by death." A soon to be famous quote by: Ryladine

Most scientist's think that man is the dominant species on earth, I know the truth, its not man that is the dominant species, its cats.

#6 ngм

ngм

  • Members
  • 98 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:45 AM

Posted 07 October 2011 - 09:09 PM

Try switching your DNS to OpenDns (http://www.opendns.com/) Also, why run a server on Windows? Way too many problems, man. Get Linux. If you want to keep windows, learn about networking. Otherwise, get a gateway.
Nosce te ipsum.

#7 ryladine

ryladine
  • Topic Starter

  • Members
  • 58 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:45 AM

Posted 07 October 2011 - 09:25 PM

Alright let me clarify.

THE PROBLEM IS NOT THE DNS

I went ahead and tried it and it did not fix the issue.

The problem IS NOT that I am unable to connect to the internet with these settings. The problem is that even though windows allows me to input them, IT WILL NOT USE THEM.

I welcome ANYONE with a post count of 1k or more to come onto my pc with team-viewer, to SEE the problem first hand.
Maybe you can tell them what the problem is better than I can if you are unable to solve it.
If you want to try it add me on skype (My skype-name is ryladine), and tell me your Bleepingcomputer username, as well as posting here so I can verify you are an active member of the community, and not someone who joined to help with tiny problems, like being unable to find C:\programfiles (In fact I welcome you to come on teamviewer, set the static IP yourself, and watch it not take effect at all.)

Second. I have tried linux, but I don't have the patience to learn it. (Not that i wouldn't love to.) I know enough about networking that I have never had a problem. Please forgive me if I seem a bit rude here, I've been fighting this problem that simply should not be happening for the past three days, and I have been ignoring it for more than a week.

Also, I was running these servers on windows because my main desktop is on windows, and it was the only machine at the time with the power to do it. I'm not running that much, just a minecraft server I use to test mods, and learn plugins before I upload them to the server I work with. And a teamspeak3 server.

Edited by ryladine, 07 October 2011 - 09:34 PM.

"Ignorance is not stupidity, refusing to correct it is. Stupidity should be a crime punishable by death." A soon to be famous quote by: Ryladine

Most scientist's think that man is the dominant species on earth, I know the truth, its not man that is the dominant species, its cats.

#8 ngм

ngм

  • Members
  • 98 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:45 AM

Posted 07 October 2011 - 09:42 PM

Alright let me clarify.

THE PROBLEM IS NOT THE DNS

I went ahead and tried it and it did not fix the issue.

The problem IS NOT that I am unable to connect to the internet with these settings. The problem is that even though windows allows me to input them, IT WILL NOT USE THEM.

I welcome ANYONE with a post count of 1k or more to come onto my pc with team-viewer, to SEE the problem first hand.
Maybe you can tell them what the problem is better than I can if you are unable to solve it.
If you want to try it add me on skype (My skype-name is ryladine), and tell me your Bleepingcomputer username, as well as posting here so I can verify you are an active member of the community, and not someone who joined to help with tiny problems, like being unable to find C:\programfiles


Yes, we hear you. There's no need to yell at us. We uderstand the issue isn't that with connectivity, or DNS. We suggested changing your DHCP for a specific reason. If you're going to be rude, don't post. Or look up the solution on Google. It seems you're trying to fit a square peg into a round hole. What worked for one computer won't work for another. They are not the same. You need to understand this concept if you're setting up a server.

Since you're trying to act as a server, with an internal static ip (no idea why you'd want ANY server with a static IP) what are you working with? CAT5, Fiber? Who is your ISP? DSL? Cable? Have you configured your routing tables? What software are you using to enable the computer to act as a server. Have you configured Windows correctly? You may not be able to set a static IP for your computer (like I said, delete windows and go with Linux if you're gonna make your comp into a server). Your ISP could be blocking this activity (or you went and bought the wrong equipment).

Also, why not configure these settings at the Layer1 protocol? Open a connection to your default gateway, log in and change the settings of the router to static IP. There shouldn't be any need to set an internal, static IP if you're a server. It's the last thing you should do, actually.
Nosce te ipsum.

#9 ngм

ngм

  • Members
  • 98 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:45 AM

Posted 07 October 2011 - 09:47 PM

Second. I have tried linux, but I don't have the patience to learn it. (Not that i wouldn't love to.) I know enough about networking that I have never had a problem. Please forgive me if I seem a bit rude here, I've been fighting this problem that simply should not be happening for the past three days, and I have been ignoring it for more than a week.

Also, I was running these servers on windows because my main desktop is on windows, and it was the only machine at the time with the power to do it. I'm not running that much, just a minecraft server I use to test mods, and learn plugins before I upload them to the server I work with. And a teamspeak3 server.


If you knew anything about networking, you'd be doing it on Linux. Also, if your desktop is on windows, get a gateway. Or make your server into a VPS. Also, TeamSpeak does not make your computer a server, since you're forwarding ports and creating a loopback address between dns and your localhost. No FTP.
Nosce te ipsum.

#10 ryladine

ryladine
  • Topic Starter

  • Members
  • 58 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:45 AM

Posted 07 October 2011 - 09:52 PM

Alright.. I am not "making" my computer anything. I am running server software on the machine. I was aware of that. I don't want linux on this machine, which is my most powerful machine in the house, because I do not know how to use linux.

Why do I need an internal static IP? Because I'm behind a router, so that all of the computers in my network can connect wirelessly and I do not want to enable dmzhosting. Therefore I must port forward, and if my internal IP changes everytime the router loses power, or my two of the computers in the house lose connection at the same time, I do not want to port-forward again just because the IP changed.

Now. Can we PLEASE go back to my original issue and stop trying to correct the way I run my servers which has ran fine for the past few years I have done it this way.

To clarify what my original problem is, windows is ignoring the settings I have changed to make it use a static internal IP.

Edited by ryladine, 07 October 2011 - 09:56 PM.

"Ignorance is not stupidity, refusing to correct it is. Stupidity should be a crime punishable by death." A soon to be famous quote by: Ryladine

Most scientist's think that man is the dominant species on earth, I know the truth, its not man that is the dominant species, its cats.

#11 ryladine

ryladine
  • Topic Starter

  • Members
  • 58 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:45 AM

Posted 07 October 2011 - 10:09 PM



Second. I have tried linux, but I don't have the patience to learn it. (Not that i wouldn't love to.) I know enough about networking that I have never had a problem. Please forgive me if I seem a bit rude here, I've been fighting this problem that simply should not be happening for the past three days, and I have been ignoring it for more than a week.

Also, I was running these servers on windows because my main desktop is on windows, and it was the only machine at the time with the power to do it. I'm not running that much, just a minecraft server I use to test mods, and learn plugins before I upload them to the server I work with. And a teamspeak3 server.


If you knew anything about networking, you'd be doing it on Linux. Also, if your desktop is on windows, get a gateway. Or make your server into a VPS. Also, TeamSpeak does not make your computer a server, since you're forwarding ports and creating a loopback address between dns and your localhost. No FTP.


Oh yes, I forgot to mention, I also run an ftp server.
Also, let me correct myself. Your right, teamspeak does not make my computer a server. The teamspeak3 server I run certainly helps though. Also the garrysmod server, and the minecraft server.

Edited by ryladine, 07 October 2011 - 10:10 PM.

"Ignorance is not stupidity, refusing to correct it is. Stupidity should be a crime punishable by death." A soon to be famous quote by: Ryladine

Most scientist's think that man is the dominant species on earth, I know the truth, its not man that is the dominant species, its cats.

#12 ngм

ngм

  • Members
  • 98 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:45 AM

Posted 07 October 2011 - 10:52 PM

Alright.. I am not "making" my computer anything. I am running server software on the machine. I was aware of that. I don't want linux on this machine, which is my most powerful machine in the house, because I do not know how to use linux.

Why do I need an internal static IP? Because I'm behind a router, so that all of the computers in my network can connect wirelessly and I do not want to enable dmzhosting. Therefore I must port forward, and if my internal IP changes everytime the router loses power, or my two of the computers in the house lose connection at the same time, I do not want to port-forward again just because the IP changed.

Now. Can we PLEASE go back to my original issue and stop trying to correct the way I run my servers which has ran fine for the past few years I have done it this way.

To clarify what my original problem is, windows is ignoring the settings I have changed to make it use a static internal IP.


A router routes. No need to have a static IP, man. (which is what everyone is to get across) What type of router do you use? Netgear? If you're trying to WiFi a LAN, set up workstation(s) to connect to that router (you'd just need a name and a pass), then set up your host server. You do not need an internal static IP. If your router looses power and changes your internal IP, you're setting it up incorrectly. A routers firmware is designed to hold your connection information even in the event of an outage. You want to set up the routing (tables) inside your router. This is its function. Assign a static IP to the router alone, spoof dns with opendns and set up accordingly.

Edited by ngм, 07 October 2011 - 10:54 PM.

Nosce te ipsum.

#13 ryladine

ryladine
  • Topic Starter

  • Members
  • 58 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:45 AM

Posted 07 October 2011 - 10:59 PM

I use a Belkin N Wireless F5D8236-v v3
I have tried getting it to keep my internal IP the same, and failed.
I have had three others try the same thing, and fail. (two of them used linux, one runs a 50+ computer network, he also teaches networking. So I would assume they know full well what they are doing, quite possibly better than you.)
We all came to the conclusion that the router's firmware is incapable of doing so.

Please do not tell me my router has a function, without even knowing what kind it is, how old it is, or what kind of firmware it is running.

Now. Please help me achieve what I have asked for help with, instead of trying to tell me to do something else entirely. I have done it this way for several years, I know it works, I don't care if it's the so called "Popper way" or not. I will do what works. If you will not help me fix the problem I asked for help with when I made this thread, please do not bother responding again.

Edited by ryladine, 07 October 2011 - 11:18 PM.

"Ignorance is not stupidity, refusing to correct it is. Stupidity should be a crime punishable by death." A soon to be famous quote by: Ryladine

Most scientist's think that man is the dominant species on earth, I know the truth, its not man that is the dominant species, its cats.

#14 ngм

ngм

  • Members
  • 98 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:45 AM

Posted 07 October 2011 - 11:40 PM

I use a Belkin N Wireless F5D8236-v v3
I have tried getting it to keep my internal IP the same, and failed.
I have had three others try the same thing, and fail. (two of them used linux, one runs a 50+ computer network, he also teaches networking. So I would assume they know full well what they are doing, quite possibly better than you.)
We all came to the conclusion that the router's firmware is incapable of doing so.

Please do not tell me my router has a function, without even knowing what kind it is, how old it is, or what kind of firmware it is running.

Now. Please help me achieve what I have asked for help with, instead of trying to tell me to do something else entirely. I have done it this way for several years, I know it works, I don't care if it's the so called "Popper way" or not. I will do what works. If you will not help me fix the problem I asked for help with when I made this thread, please do not bother responding again.


As I stated previously, what worked for one computer will not work for every computer. Updates happen and you must adjust your configuration. Now, every router no matter make or model has firmware placed on it. Trust me. Take in the advice, consider it and make your choice.

Now, I think it's best for you to take a step back and look at your situation. Yes, there are many ways to achieve the same goal. It seems you're stuck in the mind-set of "Well, this config worked before, so it should work now." No. Technology is changing rapidly. Sometimes you need new hardware. Sometimes you need to think outside the box. In your case, trash the Belkin N Wireless F5D8236-v v3 and buy NETGEAR. Problem(s) solved.
Nosce te ipsum.

#15 ngм

ngм

  • Members
  • 98 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:45 AM

Posted 07 October 2011 - 11:45 PM

Please understand I am trying to help you. You're wanting a software-based solution. Such as "Click here, then there" or "Go to CMD and type in..." those solutions won't work. You need a router with more options for configuration. Netgear is your solution.

Edited by ngм, 07 October 2011 - 11:47 PM.

Nosce te ipsum.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users