Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Interesting Wireless Situation


  • Please log in to reply
11 replies to this topic

#1 jmbtexas

jmbtexas

  • Members
  • 51 posts
  • OFFLINE
  •  
  • Local time:05:29 AM

Posted 03 October 2011 - 07:12 PM

Hi Experts!

I have a Time Warner modem, a Wired Linksys router, and a Wireless Linksys router.

The Wireless router is tethered to the Wired router because I don't use the wireless much and only turn it on when I need it.

It has worked flawlessly for a long time, but now I have a small issue.

1) My wired connection is working fine. I turn on the wireless router, connect via my laptop, and I have wireless internet access.
2) After 1 or 2 minutes, I lose internet connection on both my wired computer and the wireless laptop.
3) After 5 minutes, the connection is back and everything works great again until I the next time I go through the same steps.

Any ideas why this is happening and what I can do to fix it?

Thank you very much!

Sincerely,

Jeff

BC AdBot (Login to Remove)

 


#2 Nunos

Nunos

  • Members
  • 73 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:29 AM

Posted 05 October 2011 - 12:48 PM

I guess it would help to know exactly how they are plugged into each other like what ports and all. The first thing that comes to mind is that DHCP is on in both devices and creates a conflict but I would need more information about the network and the configuration in each device before I make that assumption. :)

#3 jmbtexas

jmbtexas
  • Topic Starter

  • Members
  • 51 posts
  • OFFLINE
  •  
  • Local time:05:29 AM

Posted 05 October 2011 - 02:40 PM

Hi,

Thanks for the reply Nunos! The "Internet" port on my wireless linksys router is plugged in to "2" port on my wired linksys router. This configuration has worked in the past and still does (except for the stated issue).

Default settings on both routers except for the fact that I had to change the IP Address on the wireless router from 192.168.1.1 to 192.168.1.2, so it doesn't conflict with the wired router. I also set up a WPA password for the wireless signal.

I don't ever remember doing anything with DHCP on either router.

I can answer more tonight after work. What other information do you need? Or what other questions do you have?

Thanks,

Jeff

Edited by jmbtexas, 05 October 2011 - 02:41 PM.


#4 tos226

tos226

    BleepIN--BleepOUT


  • Members
  • 1,569 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:LocalHost
  • Local time:07:29 AM

Posted 05 October 2011 - 04:37 PM

Take a look at, for instance, this Netgear suggestion about setting up the two routers - they do say to make the first router a DHCP server. And the second, i.e. your wireless should not be. Many other details included. I'd think the method they describe is valid for many other makes of routers.
http://support.netgear.com/app/answers/detail/a_id/965/~/using-wpn824,-wgr614,-or-wgt624-routers-as-an-access-point

#5 Fozzies

Fozzies

  • Members
  • 35 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:29 AM

Posted 06 October 2011 - 03:25 AM

Nunos was spot on with his dhcp. dhcp assigns dynamic ip adresses. You need to adjust the settings in one of your routers, turn off dhcp, and the conflict will be gone.
The two dhcp servers are currently fighting each other.

#6 jmbtexas

jmbtexas
  • Topic Starter

  • Members
  • 51 posts
  • OFFLINE
  •  
  • Local time:05:29 AM

Posted 06 October 2011 - 08:06 PM

Hi Guys,

Here is the info for my wired router:

IP Address 192.168.1.101
Subnet Mask 255.255.255.0
Default Gateway 192.168.1.1

I disabled the DHCP Server on my wireless router, and I chose Static IP (based on the article that was posted above).

That article said the Default Gateway should be the same IP Address as my wired router. I guess I'm confused on the difference betwee IP Address and Default Gateway.

When I try to connect my laptop to the wireless router now, it tries to acquire the network address, but it doesn't ever connect.

Please see the screen shot below of my router setup menu for the wireless router.

Should my "Internet IP Address" and my "Local IP Address" be the same on this menu?

Do I have the right value for the "Gateway" field?

Any other ideas about what I should change on the setup menu?

Thank you very much for the help!

Sorry guys, the forum says I can't use a jpeg or bmp image in this forum, so he's a link to my image...

My link

#7 tos226

tos226

    BleepIN--BleepOUT


  • Members
  • 1,569 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:LocalHost
  • Local time:07:29 AM

Posted 06 October 2011 - 09:29 PM

I assume you told your wired router to issue that static .99 address to the WRT router. Looks like it did. But now you have a LAN side issue. The WAN side seems ok. But local is not.

Change the Local IP from 192.168.1.1 to something else if the Gateway (on external router) is 192.168.1.1 on the WRT54G. You can give it any address you want. As I see it, the WAN side got .99, LAN side can now have a different last digit, can't be the same as the gateway!

If Netgear is right that "default gateway should be the same IP as your wired router" then, the gateway on the WRT54G internal should be .101 which is your wired router's IP on the LAN side. Give it a try. I've never done an access point type setup with my WRT54G.

Did you limit the range in the wired router to max .98? That's important.

Are you sure your wired router's IP ends in .101? Sure it's not your computer's IP?
It might help if you'd post a similar picture for the wired router.
Also post the results of doing ipconfig /all.

Since both of your routers are Linksys, have you looked for their ideas?

Edited by tos226, 06 October 2011 - 09:43 PM.


#8 tos226

tos226

    BleepIN--BleepOUT


  • Members
  • 1,569 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:LocalHost
  • Local time:07:29 AM

Posted 06 October 2011 - 09:40 PM

More from me, but that's about as much as I can guess for you :

As I look at the fuzzy Netgear picture, and myself trying to understand, I see it like this:
1. wired router LAN IP is .1, it's a DHCP server and can issue addresses .2 to .98. Its wireless function should be disabled. It's the primary and the only gateway, hence .1 in your picture.
2. wireless router: you give it static .99 and some SSID
3. Your PC adapter that is wireless will get something in the .2 to .98 range (I would think)
4. Your PC adapter that's wired (or another computer) will also get some address in the .2-.98 range, and it's that PC that should be configuring the access point.

Edited by tos226, 06 October 2011 - 09:42 PM.


#9 jmbtexas

jmbtexas
  • Topic Starter

  • Members
  • 51 posts
  • OFFLINE
  •  
  • Local time:05:29 AM

Posted 06 October 2011 - 10:06 PM

Hi Guys,

I figured out the problem. After messing around with Static and DHCP with no luck, I went back to the beginning.

As I said, I have had this set up for years with very little trouble. A few months ago, I had to setup my wireless again for the cascade/tether. All I ever did in the past was change the IP Address for the wireless, and it worked great.

So, as it turns out, I had changed the IP incorrectly.

There are two ways to cascade/tether the routers:

LAN to LAN

and

LAN to WAN

For LL, you have to change the IP Address for the wireless router to 192.168.1.2

For LW, you have to change the IP Address for the wireless router to 192.168.2.1

So, using LW, I had incorrectly reset the IP Address to 1.2 and not 2.1.

I made the change to 2.1. DHCP Server is still on (like it always has been), and everything is running perfectly again.

I appreciate the help!

Jeff

#10 tos226

tos226

    BleepIN--BleepOUT


  • Members
  • 1,569 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:LocalHost
  • Local time:07:29 AM

Posted 06 October 2011 - 10:55 PM

Great. And thanks for the feedback and description.
So which router is the DHCP server at this point?
Are they both wireless?

I've hooked two routers before, also both Linksys. And always have the subnet numbers different like you just did, but for my use the internal router is the DHCP server. But I never did the wireless access point alone with the DHCP server further out (external).

That said, the Netgear idea, should work, because it's perfectly ok to subdivide one subnet like that, or so I've read :)

#11 jmbtexas

jmbtexas
  • Topic Starter

  • Members
  • 51 posts
  • OFFLINE
  •  
  • Local time:05:29 AM

Posted 06 October 2011 - 11:26 PM

Hi,

I have two routers...the main one is not wireless, and the second wireless router is tethered to the first.

Actually, right now, and always, both routers have DHCP Server turned on.

The only time this hasn't worked flawlessly is when I changed the wireless to the wrong IP as described above.

Also, there is no mention of needing to turn off DHCP Server for one router on the Linksys Cascade Instruction Page.

Jeff

Edited by jmbtexas, 06 October 2011 - 11:28 PM.


#12 Nunos

Nunos

  • Members
  • 73 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:29 AM

Posted 10 October 2011 - 01:56 PM

If you do what he is describing as Lan to Lan then you need to have unique IP address for each router and disable the DHCP server in one of them or else you will have two DHCP servers on the same LAN trying to dishout the same IP range.

For the Lan to WAN he is essentialy using both routers as DHCP because he is using the first to NAT from the ISP to a 192.168.1.0/24 network and assign and address to the WAN port on the second router likely it is 192.168.1.2 and then setting the LAN address on the second router as 192.168.2.0/24 placing it in a seperate subnet and leaving DHCP enabled to hand out IP's in that range to the wireless devices. So now all traffic that is destined for the web from the second router has to come in on the 192.168.2.0 subnet and out the 192.168.1.2 interface then work its way through the first router to realize that it needs to go out the WAN port. Effectively he is double NATed and has increased the hop count for all of his traffic. This is usaually fine until you want to open a port to get to something on the second router for say VNC or RDP. Then NAT transversal becomes a nightmare. I find it easier to turn everything off in the second router and just use it as an Access Point on the same subnet.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users