Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Monitor/Video Card Driver problems


  • Please log in to reply
1 reply to this topic

#1 Kjell91

Kjell91

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:11:41 PM

Posted 02 October 2011 - 10:51 AM

Hi!

I Just updated my (around 2 years old) graphics card on my computer through "Amd Vision Engine Control Center" which is my graphics card update center I belive. The second I installed the update my screen started to look wierd, and the normal prosedure occurred like black screen, blinking and resolution change.

The problem I have after the update is Small Red moving dots (so not dead pixels) sometimes they even form small red lines, moveable as well. Sometimes I don't have red dots at all, its fine, just like normal. but the majority of time it is filled with red dots.

How can I fix this problem? I really can't see its my graphics card thats broken nor Monitor that is broken, because it occurred instantly after the Graphics card Update (I had something familiar earlier, when I updated the Graphics card I couldn't see my Mouse pointer when I moved it while playing video games, but this was fixed by uninstalling all games - then reinstalling them)

I have two monitors connected, it is only One monitor that is affected by this, my main monitor.

Info:

Graphics card: XFX Radeon HD 4890 1GB GDDR5
Windows 7 64-Bit
8 GB Ram
AMD Phenom 3.21 GHz Quad core

Thanks for any help!
Cheers from Norway

Edit:

Ive tryed uninstalling the Update center, but that is not possible, can't uninstall through Control Panel, nor can I see any uninstall options in the update center.



Edit:
Sorry for the font... went kinda fast there.

Edited by Kjell91, 02 October 2011 - 10:51 AM.


BC AdBot (Login to Remove)

 


#2 Kjell91

Kjell91
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:11:41 PM

Posted 04 October 2011 - 07:24 AM

Problem fixed.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users