Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Bought Some SSDs, Having Issues Getting Them Working


  • Please log in to reply
No replies to this topic

#1 Ryan 3000

Ryan 3000

  • Members
  • 834 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Maryland
  • Local time:02:29 AM

Posted 28 September 2011 - 08:22 AM

I own a Lenovo Thinkpad W520 and an HP Mini 1000 netbook. I felt that both could benefit from a little speed boost so I bought a new solid state drive for each of them. While the Lenovo installation went smoothly, the Mini has given me quite a few problems, and I do not have the new SSD working in the laptop yet.

The Mini uses an uncommon PATA ZIF connector on a 1.8" Pico SSD from SanDisk, which is simply enough an SSD that takes up half the space in a 1.8" slot. Although the market for PATA ZIF upgrade drives is very small, I was able to find a drive that I thought would work for the upgrade, an AMP Sabertooth ZT (edit: actually ZF). Many people reviewed it well for their netbook upgrades, so I assumed it would work for my Mini since both use PATA ZIF connectors.

However, since arriving, the old Pico SSD from my netbook and the new full-size 1.8" Sabertooth SSD have proven problematic. The Sabertooth came with a ZIF-to-USB adapter so I was able to connect it as an external drive. I plugged it into my netbook and proceeded to clone the Pico SSD's contents into the Sabertooth. Then, I opened up my Mini, removed my Pico SSD, replaced it with the Sabertooth, and tried to boot. It stopped at BIOS and claimed I had no bootable media installed in the computer. I then removed the Sabertooth, put it in the USB adapter, and tried to boot it as a USB drive. This worked perfectly. Then I plugged my Pico SSD into the adapter and tried to boot in the same fashion. Once again, no bootable media was found by the BIOS. After further testing, the Pico SSD doesn't seem to work unless connected to my netbook's motherboard, and my Sabertooth works with everything but my netbook's motherboard. When plugged into my netbook's motherboard, the Sabertooth makes a high-pitched whining like a mosquito ringtone which I believe indicates some unsafe electrical stuff going on. It does not make this sound when connected by the USB adapter. I am afraid that the Mini netbook has some proprietary tweaks or something, as the Pico SSD doesn't seem to work outside of it and standard(?) PATA ZIF drives don't seem to work inside the netbook.

As some side notes, I have opened BIOS setup on startup and when the Sabertooth is installed in the motherboard slot, nothing even shows up. It is completely unrecognized. Same for the PicoSSD through the USB adapter. I have tried connecting each drive via USB to my Lenovo laptop, and the Pico SSD doesn't work once again, while the Sabertooth does. I have also tried the assortment of cables sent with the Sabertooth as well as the Pico SSD multiple times and I'm sure the problem cannot be blamed on a faulty cable or a poor installation job. I compared the cable of the Pico SSD with the ones that came with the Sabertooth and their contacts line up.

How can this problem be fixed? I've tried my best to fix it.

p.s. I installed a Kingston HyperX Sata III drive in my Lenovo and the installation went smoothly. However, the Kingston is said to benchmark to 555MB/s sequential and I am only pulling 480MB/s. I have made sure AHCI is turned on. I understand that it may come in under Kingston's advertised benchmarks but by 15%? I paid $100 more than other drives because I wanted this maximum speed. How could I speed it up? edit: Yes, the laptop does support SATA III.

Edited by Ryan 3000, 28 September 2011 - 01:09 PM.

No pessimist ever discovered the secrets of the stars, or sailed to an uncharted land.

BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users