Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

'System Interrupts' slowing my processor


  • Please log in to reply
16 replies to this topic

#1 Goddard

Goddard

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:10:01 PM

Posted 25 September 2011 - 09:39 AM

So, I recently noticed while playing games my FPS was lower than normal. I checked my processes list and found this 'System Interrupts' process was hogging anywhere between 0 and 25% of my processor.

I've tried all the usual stuff suggested by people including cleaning the registry, reinstalling drivers, even a windows restore to a few days before.

None of these things helped. So I thought I'd just reinstall windows 7 as I was planning on doing that soon anyway.

So I reinstalled, and to my horror 'System Interrupts' was still there, on a fresh install.

I thought maybe it was the old installation, so I unplugged that hard disk, got a spare one, installed Windows Vista on it. The system interrupts were gone, so I proceeded to upgrade it to windows 7, and the interrupts returned!

So after this, I figured it must be something to do with the hardware. Here's the list of stuff I tried:

- Unplugged all unnecessary components one at a time. (Sound card, extra hard disks, DVD drive, card reader)
-Tried a different graphics card
-Tested each stick of RAM separately, also tried them in different slots
- Disabled USB controller in BIOS
- Cleaned my CPU heat sink (as it was caked in rubbish)
- Tried using windows on a different hard disk (as mentioned above)
- Cleared CMOS
- Safe mode still has interrupt.

All this stuff, and the interrupts are STILL there. (Here's a screenshot)

http://imageshack.us/photo/my-images/88/capture11w.jpg/

If anyone has any suggestions, that would be greatly appreciated.

Thanks. And here are my system specs:

Windows 7 Professional 64bit
Intel Core 2 Quad Q6700 @ 2.67GHz
2 x 2GB DDR2 800 MHz
ATI Power Colour HD3870
Gigabyte GA EP35 DS3R

Edited by Goddard, 25 September 2011 - 10:46 AM.


BC AdBot (Login to Remove)

 


#2 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,716 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:03:01 PM

Posted 25 September 2011 - 10:37 AM

Check Primary and Secondary IDE settings: Device Manager -> IDE ATA/ATAPI controllers -> Primary or Secondary IDE Channel -> Properties -> Advanced Settings. Look at the Current Transfer Mode field.
See, if it's in PIO mode instead of DMA mode.

My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 


#3 Goddard

Goddard
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:10:01 PM

Posted 25 September 2011 - 10:45 AM

Thanks for the input! Seems to be fine though.


Posted Image

#4 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,716 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:03:01 PM

Posted 25 September 2011 - 10:48 AM

Download Process Explorer: http://technet.microsoft.com/en-us/sysinternals/bb896653.aspx
Unzip ProcessExplorer.zip, and double click on procexp.exe to run the program.
Click on View > Select Colunms.
In addition to already pre-selected options, make sure, the Command Line is selected, and press OK.
Go File>Save As, and save the report as Procexp.txt.
Attach the file to your next reply.

My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 


#5 Goddard

Goddard
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:10:01 PM

Posted 25 September 2011 - 10:53 AM

Here it is.

https://docs.google.com/leaf?id=0B3-LXGdwVJjbOTEyYzE3NmEtZGZjYS00M2RjLTkyYjUtNTdmMThkYzE5ZjI5&hl=en_US&authkey=CIzm868M

Hope that link works.

#6 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,716 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:03:01 PM

Posted 25 September 2011 - 10:56 AM

I don't see any excessive CPU usage.
System Idle Process is listed at 96.27%

My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 


#7 Goddard

Goddard
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:10:01 PM

Posted 25 September 2011 - 11:01 AM

The interrupts use up between 0-2% when idling.

When I try to play a fairly intensive game it increases to around 20-30%

Edit: and this makes the game chug like hell.

Edited by Goddard, 25 September 2011 - 11:02 AM.


#8 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,716 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:03:01 PM

Posted 25 September 2011 - 11:37 AM

Download and install SIW Multilanguage With Installer (SIW free version) (bottom of the screen)

Run the tool.
After it scans your computer, navigate to Hardware>Sensors and post all info from there.

Posted Image

My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 


#9 Goddard

Goddard
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:10:01 PM

Posted 25 September 2011 - 12:01 PM

Here it is:

Posted Image

Edited by Goddard, 25 September 2011 - 12:08 PM.


#10 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,716 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:03:01 PM

Posted 25 September 2011 - 12:10 PM

If that's for an idle computer, 59C is too hot.
Your CPU max temp is listed at 71C, so if you start playing demanding game you can easily get there.

My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 


#11 Goddard

Goddard
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:10:01 PM

Posted 25 September 2011 - 12:15 PM

Well I was looking at the temperatures in the BIOS last night, and it said the core temp was around 65-69C (Although I did have the computer on all day)

I gave the heat sink and fan a clean this morning and when I checked the BIOS then it was reading as 28C. Although again, I had only just switched it on since the night before.

What do you recommend?

#12 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,716 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:03:01 PM

Posted 25 September 2011 - 12:22 PM

It really doesn't matter for how long the computer is on.
CPU heats up in a matter of seconds.

My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 


#13 Goddard

Goddard
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:10:01 PM

Posted 25 September 2011 - 12:40 PM

Just blasted it with compressed air, and the reading you read off as improved by 7C.

#14 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,716 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:03:01 PM

Posted 25 September 2011 - 12:55 PM

I suggest you s keep SIW open, start your game and see how the readings are.

My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 


#15 Goddard

Goddard
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:10:01 PM

Posted 25 September 2011 - 01:16 PM

Okay so I played Red Orchestra 2 for about 5-10 minutes, and weirdly I didn't get the large system interrupts that I got before. It sits on 0-2%, whereas before I formatted and cleaned the heat sink it was 20-30%.

Edit: I just quit. And I was watching the interrupt CPU usage and it spiked to ~10% a few times and the mouse cursor lagged.

Posted Image

Edited by Goddard, 25 September 2011 - 01:19 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users