Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

USB mouse not working after Hibernate/Sleep


  • Please log in to reply
5 replies to this topic

#1 teeth

teeth

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:09:12 AM

Posted 21 September 2011 - 05:35 PM

I am running windows 7 64 bit on my dell laptop. The mouse is a logitech M110 cabled mouse. Drivers are reported up to date.

Basically, my mouse works fine until I unplug my laptop to bring with me to class. My laptop goes to sleep in the interim, and works fine. When I return to plug my laptop back into my power source my mouse doesn't work properly! Here is the order of reconnecting: Reconnect power cable, reconnect mouse to USB, open laptop, wake from sleep. I do not have issues if I unplug my laptop and it never sleeps.

This is the error I receive when I click on the device in device manager: Windows cannot load the device driver for this hardware because a previous instance of the device driver is still in memory. (Code 38)
The device also has a '!' icon next to it.
When I unplug and replug my mouse, I get a noise that's like dong-dong instead of the usual dong-ding. When I unplug I get the usual ding-dong sound

At first I thought this was a power management issue so I turned off the option in device manager that allows windows to turn off the USB to conserve power. This did not work. I have tried uninstalling, and reinstalling but no use there either. The only way to get my mouse back online is to restart windows all together. While this works, I would rather not have to do this every time I take my laptop to class.

Edited by teeth, 21 September 2011 - 05:56 PM.


BC AdBot (Login to Remove)

 


#2 derek.ellis

derek.ellis

  • Members
  • 57 posts
  • OFFLINE
  •  
  • Local time:10:12 AM

Posted 21 September 2011 - 07:34 PM

Have you checked your BIOS setting to make sure that your PC's USB port setting are correct? Most PC Manufactuers have settings that you can adjust for the USB ports

#3 jhayz

jhayz

  • BC Advisor
  • 6,922 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:12 PM

Posted 21 September 2011 - 08:03 PM

Remove all external devices and reboot PC with only mouse device plugged in. You could troubleshoot the problem with safemode to check if its making connection issue. Do you have another mouse for testing? Try loading recommended power settings. Once you chose Balance(recommended) settings, Click change plan settings then Change Advanced power settings and look for Sleep(expand)and USB settings(expand)to toggle. Under Sleep options, my settings are Never and Off while Allow Wake Timers are Enabled. Under USB selective suspend settings, both are enabled. Sleep options are enabled on power button and lid close action. I am not a big fan of hibernate, but the only power saving modes I've been using is sleep and making sure the monitor is dim then turn off depending on your specified duration.

Tekken
 


#4 teeth

teeth
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:09:12 AM

Posted 01 October 2011 - 06:16 PM

I've tried the above, but still no luck.

#5 jhayz

jhayz

  • BC Advisor
  • 6,922 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:12 PM

Posted 02 October 2011 - 01:15 AM

USB or PS/2 mouse? Have you tried another USB cable mouse?

When I return to plug my laptop back into my power source my mouse doesn't work properly!

How about letting the USB mouse first connected before the AC adapter?

Tekken
 


#6 beachinguy005

beachinguy005

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:09:12 AM

Posted 02 October 2011 - 12:03 PM

I had the same issue with my Gateway laptop. The problem for me happened when I allowed it to go into automatic sleep mode. I had it set at 15 min.screen saver then sleep/hibernate.

I corrected it by changing my settings to manual sleep mode. Turned off, or changed it to 8 hours, the automatic screen saver and hibernate feature.

Now I just use the hibernate button manually and no more issue. Works fine whenever I bring it out of hibernation.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users