Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Failing to Restore from VISTA ‘Complete System Back-up ‘.


  • Please log in to reply
No replies to this topic

#1 Cadex

Cadex

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:11:35 AM

Posted 19 September 2011 - 04:23 PM

Hey if anyone can help, it would be great.

Problem:
Failing to Restore from VISTA ‘Complete System Back-up‘.

Error Message:
‘The Windows Complete PC Restore Operation Failed.
Error Details: There are too few disks on this computer or one or more of the disks is too small. Add or change disks so they match the disks in the backup and try the restore again. (0x80042401).’

Scenario:
I wanted to move from Vista (Ultimate 64 bit) to of Windows 7 (Home Premium 64bit).

I successfully backed up my VISTA PC (as a ‘Complete System back-up ‘) to an external USB hard drive in order to get it ready for a re-build and installation of Windows 7. I attempted to also do a ‘Files Backup’ but it wouldn’t let me – it kept saying the last ‘Files Backup’ had failed and wouldn’t proceed. As I had the complete one, I thought I’d be OK.

The PC set-up:
The PC has two 500gb (roughly 475gb available) Hitachi drives mirrored (RAID 1) using the Hardware based RAID from the MSI Platinum P35 motherboard (ICH9R).

This was set up (at the RAID level) as one 50gb partition and one 425gb partition. At the Vista level the 425gb partition was split as 100gb (97gb roughly), 100 (97gb), and 225gb (217gb).

Because I had been getting a lot of warnings about lack of space on drive C: (50gb), I decided to not use the RAID partitioning anymore and just partition at the OS level when the system was re-built (I hoped it would make it easier in future to re-size).

What I did:
Once the backup was successful, I used the configuration tool of the RAID to remove the partitions and created just one.

I installed Windows 7 and attempted to restore my backup. At this point I realised that I couldn’t because it was a ‘Complete System Backup’ not a ‘Files Backup’. So I decided to go back to what I had before thinking that I would re-create what I had and copy or otherwise get my files off the drives and then start again. I went through the process like the restore instructions at the link below
(http://www.bleepingcomputer.com/tutorials/windows-vista-complete-pc-restore/
or also
http://windows.microsoft.com/en-US/windows-vista/Restore-your-computer-from-a-system-image-backup).
The problem was that it kept giving me the error listed above.

I then decided to make the PC as much like it was before and try again. So I re-created the physical set up with the RAID (one partition of 50gb, one of 425gb), then using the ‘Install’ option of VISTA, created the 3 partitions as the 100, 100 and 225gb partitions. I restarted and tried again and still got the exact same error.

From browsing at:
http://professionalinsight.net/VistaBackup.aspx
I discovered that I might have to make sure that the partitions had the correct drive letters etc. so in the Windows Recovery Environment, I used DISKPART to make sure the different partitions had the right sizes, drive letters and were formatted as NTFS. It still would not run. I have pics of the volume set up, if that would help.

If anyone can help, it would be great as I have a lot of important information (both business and personal) on the ‘Complete System Backup’ that I can’t get at. At this stage I am getting worried and will do pretty much anything.

Thanks.

BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users