Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Trouble installing drivers for my nvidia GPU


  • Please log in to reply
6 replies to this topic

#1 lanzd

lanzd

  • Members
  • 41 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:25 AM

Posted 17 September 2011 - 07:28 PM

Hello, I just upgraded to a nvidia GeForce GTX 560 ti video card and am unsure how to install the drivers.

I've downloaded what I believe to be the correct driver for my card off of the nvidia site here http://www.nvidia.com/Download/index.aspx?lang=en-us

I chose GeForce 560 ti as the product, linux 32 bit, english US and get the file

NVIDIA-Linux-x86-280.13.run

I've tried running the file in the terminal and it gives a message saying it requires root access. So I logged into root and ran the file and then get a message saying I currently seem to be running an x server, please exit x before installing.

I'm not entirely sure what x is, from what I've been reading I think its part of the gui interface for unbuntu. But I have no idea how to exit it. Any relevant information I've found seems to involve temporarily disabling the gui and I tried one method but It completely locked up my system. I then reinstalled ubuntu after deleting the old partition. (It was a barebones install in the first place so I didn't lose anything).

Thank you for any help. And sorry if I'm a little dumb with this stuff. I'm new to linux.

Dan

BC AdBot (Login to Remove)

 


#2 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:12:25 PM

Posted 17 September 2011 - 07:34 PM

You dont need to use that driver:

Please see this guide:

https://help.ubuntu.com/8.04/hardware/C/restricted-manager.html

Or this one:

https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia?action=show&redirect=RestrictedDrivers%2FNVIDIA

Edited by cryptodan, 17 September 2011 - 07:35 PM.


#3 lanzd

lanzd
  • Topic Starter

  • Members
  • 41 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:25 AM

Posted 17 September 2011 - 08:04 PM

Hello, thank you for the quick reply. I've actually have been to both those pages before. That is how I installed the driver for my old GPU, but for some reason nothing shows up in the Hardware drivers dialog as both sites instructed to do.

It simply states "No proprietary drivers are in use on this system."

I included a new repository on my machine https://launchpad.net/~ubuntu-x-swat/+archive/x-updates

and It seems there are more nvidia related content on their. I just don't know how I am going to know which apply to me. If anyone knows what has to match between the files and my machine, please let me know. If you need more information let me know what it is you need.

#4 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:12:25 PM

Posted 17 September 2011 - 08:09 PM

You need to enable the restricted drivers, if you haven't then it wont work.

#5 lanzd

lanzd
  • Topic Starter

  • Members
  • 41 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:25 AM

Posted 17 September 2011 - 08:14 PM

How to I enable the use of restricted drivers? I see the enable button in the lower right of the window but it is grayed out because I do not have a specific driver selected above. But there aren't any drivers listed for me to select. Sorry if I'm not getting this right away.

#6 lanzd

lanzd
  • Topic Starter

  • Members
  • 41 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:25 AM

Posted 17 September 2011 - 08:54 PM

I got it working. Basically I had to include a repository and download a file through that, then restart.

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current libvdpau1

Do those in that order, and then restart and you should be in business.
Oh and when your running those commands, make sure you don't have synaptic software manager or other things like that running. It won't work properly.

Thank you for your help guys.

#7 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:12:25 PM

Posted 17 September 2011 - 08:56 PM

What version of Ubuntu are you running?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users