Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Hal.Dll Error


  • Please log in to reply
1 reply to this topic

#1 McQ83

McQ83

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:08:30 AM

Posted 17 September 2011 - 06:56 PM

Problem I'm having is that I can get as far as the Recovery Console, however, I am never given the option to choose which system I want to alter (meaning I never have the option to type "1" and ENTER) and subsequently never get to enter any password.

Also, I am only seeing C:\> instead of the C:\WINDOWS I've read elsewhere I SHOULD see.

I attempted to use the EXPAND command. I believe it was something like "EXPAND D:\i386\hal.dl_ C:\WINDOWS\SYSTEM32" and was faced with an ACCESS DENIED.

I read elsewhere to try these commands:

SET AllowWildCards = TRUE
SET AllowAllPaths = TRUE
SET AllowRemovableMedia = TRUE

But none of that worked, explaining that the SET command is currently disabled.

Next, I tried another option to directly fix my HAL.DLL problem by using "BOOTCFG /REBUILD"

It scanned it for a while and eventually gave me this error:

Error: Failed to successfully scan disks for Windows installations.
This error may be caused by a corrupt file system, which would
prevent Bootcfg from successfully scanning. Use chkdsk to
detect any disk errors.

Problem with that is, I've ran CHKDSK AND CHKDSK /R already and when they are finished it says there has been nothing fixed. I've also tried the BOOTFIX(?) command, stating it cannot work without the CHKDSK, and despite after running the CHKDSK, it still will not run the BOOTFIX(?)

Additional, possibly pointless information:
Whenever I boot my computer, two OSs are available, both are Windows XP, but one is Windows XP (bootscreen). There was a problem a while back where I'd boot into the non (bootscreen) version and it would freeze or something. Haven't had any problems booting since now.
On occasion, my system will go into sleep mode, when I move the cursor to awaken it, it will show a very, very, very dark image of the normal screen (usually a login screen).
I'm running on XP Pro (I think) on a Presario 2700T laptop.

Any help would be greatly appreciated. It seemed this just came out of nowhere. Used the computer last night without any problems and got back from work to find the HAL.DLL error.

BC AdBot (Login to Remove)

 


#2 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:04:30 PM

Posted 17 September 2011 - 07:14 PM

Find out what kind of Hard Drive you have, and post back.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users