Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Printer won't work after new hard drive and Win XP reinstallation


  • Please log in to reply
1 reply to this topic

#1 anonanon

anonanon

  • Members
  • 181 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:24 AM

Posted 13 September 2011 - 07:40 AM

My PC is running Win XP (SP3). The PC has 3 GHz speed and 3.5 GB of RAM. It is connected to a parallel printer, an HP 4L. All worked fine until my hard drive failed. I replaced the HD, reinstalled Win XP, and now everything works except not the printer.

I have tried to print from five different applications, some Windows-based, some DOS-based. Nothing is sent to the printer and I get error message (this page did not print). I have self-tested the printer and it prints the self-test print page fine. It cannot print the test page from the Windows Printer menu. It cannot print from the command prompt, using the print command or the copy con command. I have tried configuring the printer (in Windows) to use LPT1 and LPT2; no difference in the result.

As I did the first time I set up the printer (Dec. 2008), I have installed the latest drivers from HP. I have deleted, reinstalled, with restarts of the system in between. I have deleted the port that it says it's using (LPT1) in the device manager and have reinstalled it.

Are there any diagnostic tests I can try? Anything else to consider? I suspect the PC may be confused about the port; it seems to think LPT1 is active but before the reinstall it was LPT2 that was active.

Thanks for any ideas,
Roger

BC AdBot (Login to Remove)

 


#2 Eyesee

Eyesee

    Bleepin Teck Shop


  • BC Advisor
  • 3,540 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:In the middle of Kansas
  • Local time:12:24 AM

Posted 14 September 2011 - 11:54 PM

Sounds like the drivers are not installed correctly.
Try these

Alternatively, you can go through the add printer wizard and manually install the drivers for an HP laserjet series II printer. They are generic enough that they should work with your printer.
In the beginning there was the command line.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users