Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Windows 7 Security Settings/Permissions Issues?

  • Please log in to reply
1 reply to this topic

#1 animestan


  • Members
  • 14 posts
  • Local time:01:45 AM

Posted 03 September 2011 - 02:23 PM

Hello, I recently got a new laptop and was eager to setup a wireless network to transfer files from my laptop to my desktop. My laptop is running Win 7 while my desktop is using XP. After I configured the network, file sharing seemed to work perfectly except that on my desktop, I can access the "USERS" folder of my laptop.

So without any knowledge of what I was doing, I altered the security settings of the "USERS" folder and/or my C:\ drive and I believe I pretty much locked myself out of it. I tried to revert the settings (Allow - Full Control) instead of (Deny - Full Control) but it denied me access for changing these settings when I pressed apply.
I then hastily performed a system restore in hopes that it would revert the settings.

I restarted my laptop and everything seemed to be normal as I got my desktop back, but I'm not sure if I still have remnants of the security settings. For the security settings for my "USERS" folder, under "Group or user names" "SYSTEM", "Administrators(xxxxxxxx-PC/Administratiors)" and "Users (xxxxxx-PC\Users)" have Full Control. Only "EVERYONE" has the ability for: read & execute, list folder contents and read.

Something in particular I ran into though was when I had to delete a file that was in the "Program Files" folder. When I attempted to delete a file or folder within "Program Files", I would get 2 messages. The first one being, "Are you sure you want to move this folder to the Recycle Bin, Yes or No". I would click "Yes".
But the after, I get the message with the title "Folder Access Denied" that says, "You'll need to provide administrator permission to delete this folder, Continue, Skip or Cancel". I could press "Continue" and the file would be successfully deleted, but I'm worried that this message shouldn't be here in the first place.

So I'm wondering if I still have bits of the "corrupted" security settings from before and if I can revert them to their default settings. Or if there are screenshots of the default security settings. Or should I post up screenshots of my current settings and run them through you guys.

Also (although off topic), my desktop can access the folders of my laptop for file sharing (when I go to "Network Places), but when I go to network places on my laptop, my desktop does not show up (even though I know they are connected since the desktop can see the laptop and not vise versa).

Any help is appreciated.

Thank you.

Edited by animestan, 03 September 2011 - 04:24 PM.

BC AdBot (Login to Remove)


#2 Jacee


    Bleeping around

  • Malware Response Team
  • 3,716 posts
  • Gender:Female
  • Local time:10:45 PM

Posted 03 September 2011 - 04:54 PM

You may need to 'take ownership' http://www.sevenforums.com/tutorials/1911-take-ownership-shortcut.html

MS MVP Windows-Security 2006-2016
Member of UNITE, the Unified Network of Instructors and Trusted Eliminators

Admin PC Pitstop

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users