Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

White screen when opening apps


  • Please log in to reply
11 replies to this topic

#1 Keith1

Keith1

  • Members
  • 504 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Hamilton, Ohio
  • Local time:07:40 PM

Posted 03 September 2011 - 08:10 AM

I had been getting a flicker when I moused over icons on my desktop the last few days. It was a minor annoyance, and I probably should have left well enough alone, but of course, I just couldn't.

I'm using the Classic Ubuntu option in 11.04. Now when I try to open anything on my desktop, I just get the titlebar and a white screen. I can't even use SPM because it does the same thing.

Here's what happened. I Googled around for information for the flickering I was getting. I saw That Compiz was most likely the problem, and several articles said to run this command - compiz --replace. It went through some weird stuff - Icons disappeared, screen went black, curved windows appeared, then finally back to my normal desktop. I just can't open anything now, not even Firefox or Thunderbird!!!

Here's one good thing - I can run a terminal, so repairs are possible. I just wanted to stop and ask before I make anything worse.

Keith

BC AdBot (Login to Remove)

 


#2 rburkartjo

rburkartjo

  • Members
  • 3,998 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:austin,tx
  • Local time:07:40 PM

Posted 03 September 2011 - 08:50 AM

keith just a thought maybe when you removed compiz you installed emerald. so first go to terminal and remove emerald then try again to remove compiz. it is probably removed but good idea to check. then reinstall compiz and make sure you have sure you enable window decorations. good luck/cheesemaker

Edited by rburkartjo, 03 September 2011 - 08:51 AM.

quote:He that would live in peace & at ease, Must not speak all he knows,nor judge all he sees.'

#3 rburkartjo

rburkartjo

  • Members
  • 3,998 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:austin,tx
  • Local time:07:40 PM

Posted 03 September 2011 - 08:52 AM

hey i thought you said you werent going to tweak anymore. lmoa/cheesemaker
quote:He that would live in peace & at ease, Must not speak all he knows,nor judge all he sees.'

#4 Keith1

Keith1
  • Topic Starter

  • Members
  • 504 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Hamilton, Ohio
  • Local time:07:40 PM

Posted 03 September 2011 - 09:47 AM

When I tried to remove both emerald and compiz, it said they are not installed,however my desktop effects still work so I'm not sure what's going on.

And.... oh yeah, I did say I wasn't going to mess around with settings anymore - but the temptation to learn something new always wins out - hee hee

#5 rburkartjo

rburkartjo

  • Members
  • 3,998 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:austin,tx
  • Local time:07:40 PM

Posted 03 September 2011 - 11:28 AM

hey is there anyway you can change the background color on your desktop. maybe it is just set on white,???
quote:He that would live in peace & at ease, Must not speak all he knows,nor judge all he sees.'

#6 Keith1

Keith1
  • Topic Starter

  • Members
  • 504 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Hamilton, Ohio
  • Local time:07:40 PM

Posted 03 September 2011 - 12:36 PM

My desktop is normal, theme and icons all in place. It's just when I click on an icon ( for example - Firefox ) I just get the title bar and a white screen.

#7 rburkartjo

rburkartjo

  • Members
  • 3,998 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:austin,tx
  • Local time:07:40 PM

Posted 04 September 2011 - 12:54 AM

keith1 dont feel bad iwas messing around with ubuntu 11.10b1 on my testing partition and killed the kernel. thank goodness i can still access all my files and transfer them over to my working partition. as guess as we get older we just tweak till it breaks./cheesemaker
quote:He that would live in peace & at ease, Must not speak all he knows,nor judge all he sees.'

#8 stiltskin

stiltskin

  • Members
  • 238 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Western MO
  • Local time:07:40 PM

Posted 07 September 2011 - 04:04 AM

Turn off desktop effects totally and see what happens. You might not be able to do that if you have to do it graphically, though.

You could log out, go to another virtual terminal (Ctrl-Alt-F2) and rename .gnome* (I have Gnome 2, so that would be .gnome2 and .gnome2_private, note the dost at the beginning of each; you may have to change yours below if using Gnome 3) with a command like this:

mv .gnome2 gnome2
mv .gnome2_private gnome2_private

Then you could go back to the graphical terminal (Ctrl-Alt-F7) and login. Settings will be screwed, but it should get rid of the problem.

Is this still Gnome 2, or is it Gnome 3? Just curious.

#9 Keith1

Keith1
  • Topic Starter

  • Members
  • 504 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Hamilton, Ohio
  • Local time:07:40 PM

Posted 07 September 2011 - 10:06 AM

This is still Gnome 2.

I don't have the graphic way to turn off effects, but I did try something else. In System Monitor, I found Compiz in processes and ended that process. I could then open FF,TB, and SPM, though they were a bit out of adjustment. one interesting thing, it wouldn't let me type any text in SPM or a terminal. I scrolled through SPM and found and reinstalled Compiz, but things still weren't right. I thought a restart might help, but that kicked kicked me back to ground zero.

Since this started when I ran Compiz --replace, I'm thinking something is missing or broken ( though SPM shows 0 broken packages). So here is what I'm going to do now - end Compiz in processes, then go into SPM and uninstall every package having to do with Compiz. Then I'll do the cleanup stuff in this link - -

http://www.ubuntugeek.com/cleaning-up-all-unnecessary-junk-files-in-ubuntu.html

Then I'll do a fresh install of Compiz, and let it 'bring along' the dependencies it needs, and see what happens.

#10 Keith1

Keith1
  • Topic Starter

  • Members
  • 504 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Hamilton, Ohio
  • Local time:07:40 PM

Posted 07 September 2011 - 12:55 PM

Well, nothing worked, I may have it so messed up, that I'll have to delete that partition and do a fresh install. I'll let it ride for awhile yet and see if anything else might save it.

#11 stiltskin

stiltskin

  • Members
  • 238 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Western MO
  • Local time:07:40 PM

Posted 07 September 2011 - 06:01 PM

I'd still try the trick of renaming the Gnome directories from an alternate virtual terminal, then logging in. If it's a settings problem, that should clear it.

#12 Keith1

Keith1
  • Topic Starter

  • Members
  • 504 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Hamilton, Ohio
  • Local time:07:40 PM

Posted 08 September 2011 - 08:32 AM

I think I was limited to what I could do was because I couldn't log in/out. I noticed the logout item was missing from my power button drop down window, and I know it was there before. I looked at my Ubuntu 11.04 partition on my backup machine, and the logout option is in the menu there - both were installed from the same live cd.

Moving right along, I installed KDE just to see what would happen, and everything worked fine from there. So I logged out of KDE and logged in to Ubuntu Classic - no effects ( Gnome ), and everything works perfectly now, as before. I can do without the effects, I'm burned out on playing with them anyhow. I guess, in a way, this is kind of 'dancing around the problem', but since it's working fine I think I'll just let it ride ( for now ).

Thank you for the input,

Keith




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users