Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Security Protector virus


  • Please log in to reply
1 reply to this topic

#1 bs10

bs10

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Local time:01:04 PM

Posted 31 August 2011 - 05:30 PM

I'm pretty sure my Toshiba laptop has been stricken with the Security Protector virus..The shortcut randomly showed up on my desktop and my computer hasn't worked right since.

Now I'm unable to open Firefox or Malwarebytes, saying that "Windows cannot access the specified device, paath or file. You may not have the appropriate permissions to access the item."

Anyway, I've tried to run TDSSKiller, RKill and Malwarebytes (from a flash drive) while running in Safe Mode with Networking, but none of these have resolved the issue. I even tried renaming Malwarebytes to iexplorer.exe, but that didn't work either. After installing Malwarebytes, I try performing a full scan, which lasts only a few seconds before the program closes.

I've researched the issue and I thought I could resolve the issue that way, but I haven't been so lucky so far. So thanks in advance for your support!!

BC AdBot (Login to Remove)

 


#2 boopme

boopme

    To Insanity and Beyond


  • Global Moderator
  • 72,934 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NJ USA
  • Local time:02:04 PM

Posted 31 August 2011 - 10:19 PM

Use Inherit.exe to fix inappropriate permissions.
Use this fix, when you see a box that states “Windows cannot not access the specified device, path, or file. You may have inappropriate permissions to access the item”.

Download This File
Save it next to mbam.exe (this file is located in the Malwarebytes Anti-malware home folder). Once done, drag and drop mbam.exe into Inherit.exe. Click OK and attempt to run Malwarebytes Anti-malware once again.
How do I get help? Who is helping me?For the time will come when men will not put up with sound doctrine. Instead, to suit their own desires, they will gather around them a great number of teachers to say what their itching ears want to hear....Become a BleepingComputer fan: Facebook




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users