Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Advanced System Settings Performance to all User accounts


  • Please log in to reply
4 replies to this topic

#1 TheSadness

TheSadness

  • Members
  • 97 posts
  • OFFLINE
  •  
  • Local time:02:19 AM

Posted 28 August 2011 - 09:46 AM

Good day.

I'm having problems changing the Advanced system settings to all the users on my PC. How can i enforce a certain System setting to all User Accounts without having to log them on one by one?

And another one is how can transfer Personal User Directories to another Drive without removing the access permissions in them. (Example: C:\Users\Computer to D:\Users\Computer) Cause when i changed the user directory to D:/. That certain user directory can now be accessed by all Standard user accounts in my PC.

Any help?

Regards,

BC AdBot (Login to Remove)

 


#2 Azure Kite

Azure Kite

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:03:19 AM

Posted 28 August 2011 - 11:23 AM

First, what system settings are you trying to change for all users? Different settings have different locations for their values and ways of making them work for all users isn't always set to one way.

Secondly, for your file copy question you'll want to look at xcopy. xcopy has some advanced features that cover almost anything that anyone would need. In regards to your specific need you'll want to look at the K, O, and X flags in the xcopy switch list. The /K flag copies attributes over, /O is the main flag you will probably want because it copies ownership and permissions, and then the /X flag copies any audit settings if you have those set and want those copied too.

So it'd be something like: xcopy C:\Users\Jon\Desktop\file.cmd D:\Users\Jon\Documents /K /O /X
"As Rule# 87 states: Actors are not good for nothing, they're best for nothing." - Frank Kincaid

#3 TheSadness

TheSadness
  • Topic Starter

  • Members
  • 97 posts
  • OFFLINE
  •  
  • Local time:02:19 AM

Posted 30 August 2011 - 06:49 AM

For the first question,
I want to change the Appearance Advanced System Settings. The one with "Adjust for Best Performance" "Adjust for Best Appearance" Etc. for all Standard users.


Second, i don't want to copy. I just want to transfer the directory to D:\(for file safety purposes) having only the User of the said directory to be the only one to open it aside from Administrator accounts. To sum it up. I want to restrict certain folders from being accessed by other Standard Users.

#4 TheSadness

TheSadness
  • Topic Starter

  • Members
  • 97 posts
  • OFFLINE
  •  
  • Local time:02:19 AM

Posted 03 September 2011 - 09:02 AM

Bump

#5 c_robertson

c_robertson

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:01:19 AM

Posted 04 September 2014 - 10:32 AM

Very good question. I'm working on this subject as we speek. I like to get a registry tweak to make several changes globally, but have only the tweaks for the user I'm logged in as. (shown below)

 

I have found the settings in Local_machine, but haven't been that brave yet. Will let you know if I get a chance to.

 

 

 

 

;******Turn off visual effects
;
 
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\VisualEffects]
"VisualFXSetting"=dword:00000003
 
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\VisualEffects\AnimateMinMax]
"DefaultApplied"=dword:00000001
 
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\VisualEffects\ComboBoxAnimation]
"DefaultApplied"=dword:00000001
 
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\VisualEffects\ControlAnimations]
"DefaultApplied"=dword:00000001
 
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\VisualEffects\CursorShadow]
"DefaultApplied"=dword:00000001
 
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\VisualEffects\DragFullWindows]
"DefaultApplied"=dword:00000001
 
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\VisualEffects\DropShadow]
"DefaultApplied"=dword:00000001
 
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\VisualEffects\DWMAeroPeekEnabled]
"DefaultApplied"=dword:00000001
 
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\VisualEffects\DWMEnabled]
"DefaultApplied"=dword:00000001
 
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\VisualEffects\DWMSaveThumbnailEnabled]
"DefaultApplied"=dword:00000001
 
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\VisualEffects\FontSmoothing]
 
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\VisualEffects\ListBoxSmoothScrolling]
"DefaultApplied"=dword:00000001
 
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\VisualEffects\ListviewAlphaSelect]
"DefaultApplied"=dword:00000001
 
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\VisualEffects\ListviewShadow]
"DefaultApplied"=dword:00000001
 
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\VisualEffects\MenuAnimation]
"DefaultApplied"=dword:00000001
 
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\VisualEffects\SelectionFade]
"DefaultApplied"=dword:00000001
 
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\VisualEffects\TaskbarAnimations]
"DefaultApplied"=dword:00000001
 
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\VisualEffects\Themes]
 
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\VisualEffects\ThumbnailsOrIcon]
"DefaultApplied"=dword:00000001
 
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\VisualEffects\TooltipAnimation]
"DefaultApplied"=dword:00000001
 
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\VisualEffects\TransparentGlass]
"DefaultApplied"=dword:00000001






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users